diff mbox series

[1/9] luaposix: bump to version 34.0.1

Message ID 20170924075932.5990-1-francois.perrad@gadz.org
State Accepted
Headers show
Series [1/9] luaposix: bump to version 34.0.1 | expand

Commit Message

Francois Perrad Sept. 24, 2017, 7:59 a.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/luaposix/luaposix.hash |  2 +-
 package/luaposix/luaposix.mk   | 24 ++++++++++++++++++++----
 2 files changed, 21 insertions(+), 5 deletions(-)

Comments

Arnout Vandecappelle Sept. 24, 2017, 10:23 a.m. UTC | #1
Hi Francois,

On 24-09-17 09:59, Francois Perrad wrote:
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/luaposix/luaposix.hash |  2 +-
>  package/luaposix/luaposix.mk   | 24 ++++++++++++++++++++----
>  2 files changed, 21 insertions(+), 5 deletions(-)
> 
> diff --git a/package/luaposix/luaposix.hash b/package/luaposix/luaposix.hash
> index e2216be73..b3984c1d1 100644
> --- a/package/luaposix/luaposix.hash
> +++ b/package/luaposix/luaposix.hash
> @@ -1,2 +1,2 @@
>  # Locally calculated
> -sha256 e66262f5b7fe1c32c65f17a5ef5ffb31c4d1877019b4870a5d373e2ab6526a21 luaposix-33.4.0.tar.gz
> +sha256 ba0bc343783fc33958cd02a68cdbfd65430152d9f297f7ed92678b1a305bd5d7  luaposix-34.0.1.tar.gz
> diff --git a/package/luaposix/luaposix.mk b/package/luaposix/luaposix.mk
> index ea3af16fb..779e707ce 100644
> --- a/package/luaposix/luaposix.mk
> +++ b/package/luaposix/luaposix.mk
> @@ -4,11 +4,27 @@
>  #
>  ################################################################################
>  
> -LUAPOSIX_VERSION = 33.4.0
> +LUAPOSIX_VERSION = 34.0.1
>  LUAPOSIX_SITE = $(call github,luaposix,luaposix,release-v$(LUAPOSIX_VERSION))
>  LUAPOSIX_LICENSE = MIT
> -LUAPOSIX_LICENSE_FILES = COPYING
> +LUAPOSIX_LICENSE_FILES = LICENSE
>  LUAPOSIX_DEPENDENCIES = luainterpreter host-lua
> -LUAPOSIX_CONF_OPTS = --libdir="/usr/lib/lua/$(LUAINTERPRETER_ABIVER)" --datarootdir="/usr/share/lua/$(LUAINTERPRETER_ABIVER)"
>  
> -$(eval $(autotools-package))
> +define LUAPOSIX_BUILD_CMDS
> +	(cd $(@D); \
> +		$(LUA_RUN) build-aux/luke \
> +		CC="$(TARGET_CC)" \
> +		CFLAGS="$(TARGET_CFLAGS)" \
> +		LUA_INCDIR=$(STAGING_DIR)/usr/include \
> +	)

 Since you're anyway switching the build system, why not convert it to a
luarocks package?

 Regards,
 Arnout

> +endef
> +
> +define LUAPOSIX_INSTALL_TARGET_CMDS
> +	(cd $(@D); \
> +		$(LUA_RUN) build-aux/luke install \
> +		INST_LIBDIR="$(TARGET_DIR)/usr/lib/lua/$(LUAINTERPRETER_ABIVER)" \
> +		INST_LUADIR="$(TARGET_DIR)/usr/share/lua/$(LUAINTERPRETER_ABIVER)" \
> +	)
> +endef
> +
> +$(eval $(generic-package))
>
Francois Perrad Sept. 24, 2017, 2:03 p.m. UTC | #2
2017-09-24 12:23 GMT+02:00 Arnout Vandecappelle <arnout@mind.be>:

>  Hi Francois,
>
> On 24-09-17 09:59, Francois Perrad wrote:
> > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> > ---
> >  package/luaposix/luaposix.hash |  2 +-
> >  package/luaposix/luaposix.mk   | 24 ++++++++++++++++++++----
> >  2 files changed, 21 insertions(+), 5 deletions(-)
> >
> > diff --git a/package/luaposix/luaposix.hash b/package/luaposix/luaposix.
> hash
> > index e2216be73..b3984c1d1 100644
> > --- a/package/luaposix/luaposix.hash
> > +++ b/package/luaposix/luaposix.hash
> > @@ -1,2 +1,2 @@
> >  # Locally calculated
> > -sha256 e66262f5b7fe1c32c65f17a5ef5ffb31c4d1877019b4870a5d373e2ab6526a21
> luaposix-33.4.0.tar.gz
> > +sha256 ba0bc343783fc33958cd02a68cdbfd65430152d9f297f7ed92678b1a305bd5d7
> luaposix-34.0.1.tar.gz
> > diff --git a/package/luaposix/luaposix.mk b/package/luaposix/luaposix.mk
> > index ea3af16fb..779e707ce 100644
> > --- a/package/luaposix/luaposix.mk
> > +++ b/package/luaposix/luaposix.mk
> > @@ -4,11 +4,27 @@
> >  #
> >  ############################################################
> ####################
> >
> > -LUAPOSIX_VERSION = 33.4.0
> > +LUAPOSIX_VERSION = 34.0.1
> >  LUAPOSIX_SITE = $(call github,luaposix,luaposix,
> release-v$(LUAPOSIX_VERSION))
> >  LUAPOSIX_LICENSE = MIT
> > -LUAPOSIX_LICENSE_FILES = COPYING
> > +LUAPOSIX_LICENSE_FILES = LICENSE
> >  LUAPOSIX_DEPENDENCIES = luainterpreter host-lua
> > -LUAPOSIX_CONF_OPTS = --libdir="/usr/lib/lua/$(LUAINTERPRETER_ABIVER)"
> --datarootdir="/usr/share/lua/$(LUAINTERPRETER_ABIVER)"
> >
> > -$(eval $(autotools-package))
> > +define LUAPOSIX_BUILD_CMDS
> > +     (cd $(@D); \
> > +             $(LUA_RUN) build-aux/luke \
> > +             CC="$(TARGET_CC)" \
> > +             CFLAGS="$(TARGET_CFLAGS)" \
> > +             LUA_INCDIR=$(STAGING_DIR)/usr/include \
> > +     )
>
>  Since you're anyway switching the build system, why not convert it to a
> luarocks package?
>
>
luaposix have a rockspec, but not suitable for BR.
Because our luarocks infrastructure handles only the type=builtin which
represents almost 90% of all rockspec.

François


>  Regards,
>  Arnout
>
> > +endef
> > +
> > +define LUAPOSIX_INSTALL_TARGET_CMDS
> > +     (cd $(@D); \
> > +             $(LUA_RUN) build-aux/luke install \
> > +             INST_LIBDIR="$(TARGET_DIR)/usr/lib/lua/$(LUAINTERPRETER_ABIVER)"
> \
> > +             INST_LUADIR="$(TARGET_DIR)/usr/share/lua/$(LUAINTERPRETER_ABIVER)"
> \
> > +     )
> > +endef
> > +
> > +$(eval $(generic-package))
> >
>
> --
> Arnout Vandecappelle                          arnout at mind be
> Senior Embedded Software Architect            +32-16-286500
> Essensium/Mind                                http://www.mind.be
> G.Geenslaan 9, 3001 Leuven, Belgium           BE 872 984 063 RPR Leuven
> LinkedIn profile: http://www.linkedin.com/in/arnoutvandecappelle
> GPG fingerprint:  7493 020B C7E3 8618 8DEC 222C 82EB F404 F9AC 0DDF
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">2017-09-24 12:23 GMT+02:00 Arnout Vandecappelle <span dir="ltr">&lt;<a href="mailto:arnout@mind.be" target="_blank">arnout@mind.be</a>&gt;</span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"> Hi Francois,<br>
<div><div class="h5"><br>
On 24-09-17 09:59, Francois Perrad wrote:<br>
&gt; Signed-off-by: Francois Perrad &lt;<a href="mailto:francois.perrad@gadz.org">francois.perrad@gadz.org</a>&gt;<br>
&gt; ---<br>
&gt;  package/luaposix/luaposix.hash |  2 +-<br>
&gt;  package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a>   | 24 ++++++++++++++++++++----<br>
&gt;  2 files changed, 21 insertions(+), 5 deletions(-)<br>
&gt;<br>
&gt; diff --git a/package/luaposix/luaposix.<wbr>hash b/package/luaposix/luaposix.<wbr>hash<br>
&gt; index e2216be73..b3984c1d1 100644<br>
&gt; --- a/package/luaposix/luaposix.<wbr>hash<br>
&gt; +++ b/package/luaposix/luaposix.<wbr>hash<br>
&gt; @@ -1,2 +1,2 @@<br>
&gt;  # Locally calculated<br>
&gt; -sha256 e66262f5b7fe1c32c65f17a5ef5ffb<wbr>31c4d1877019b4870a5d373e2ab652<wbr>6a21 luaposix-33.4.0.tar.gz<br>
&gt; +sha256 ba0bc343783fc33958cd02a68cdbfd<wbr>65430152d9f297f7ed92678b1a305b<wbr>d5d7  luaposix-34.0.1.tar.gz<br>
&gt; diff --git a/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a> b/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a><br>
&gt; index ea3af16fb..779e707ce 100644<br>
&gt; --- a/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a><br>
&gt; +++ b/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a><br>
&gt; @@ -4,11 +4,27 @@<br>
&gt;  #<br>
&gt;  ##############################<wbr>##############################<wbr>####################<br>
&gt;<br>
&gt; -LUAPOSIX_VERSION = 33.4.0<br>
&gt; +LUAPOSIX_VERSION = 34.0.1<br>
&gt;  LUAPOSIX_SITE = $(call github,luaposix,luaposix,<wbr>release-v$(LUAPOSIX_VERSION))<br>
&gt;  LUAPOSIX_LICENSE = MIT<br>
&gt; -LUAPOSIX_LICENSE_FILES = COPYING<br>
&gt; +LUAPOSIX_LICENSE_FILES = LICENSE<br>
&gt;  LUAPOSIX_DEPENDENCIES = luainterpreter host-lua<br>
&gt; -LUAPOSIX_CONF_OPTS = --libdir=&quot;/usr/lib/lua/$(<wbr>LUAINTERPRETER_ABIVER)&quot; --datarootdir=&quot;/usr/share/lua/<wbr>$(LUAINTERPRETER_ABIVER)&quot;<br>
&gt;<br>
&gt; -$(eval $(autotools-package))<br>
&gt; +define LUAPOSIX_BUILD_CMDS<br>
&gt; +     (cd $(@D); \<br>
&gt; +             $(LUA_RUN) build-aux/luke \<br>
&gt; +             CC=&quot;$(TARGET_CC)&quot; \<br>
&gt; +             CFLAGS=&quot;$(TARGET_CFLAGS)&quot; \<br>
&gt; +             LUA_INCDIR=$(STAGING_DIR)/usr/<wbr>include \<br>
&gt; +     )<br>
<br>
</div></div> Since you&#39;re anyway switching the build system, why not convert it to a<br>
luarocks package?<br>
<br></blockquote><div><br></div><div>luaposix have a rockspec, but not suitable for BR.<br></div><div>Because our luarocks infrastructure handles only the type=builtin which represents almost 90% of all rockspec.<br></div><div><br></div><div>François<br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
 Regards,<br>
 Arnout<br>
<span class=""><br>
&gt; +endef<br>
&gt; +<br>
&gt; +define LUAPOSIX_INSTALL_TARGET_CMDS<br>
&gt; +     (cd $(@D); \<br>
&gt; +             $(LUA_RUN) build-aux/luke install \<br>
&gt; +             INST_LIBDIR=&quot;$(TARGET_DIR)/<wbr>usr/lib/lua/$(LUAINTERPRETER_<wbr>ABIVER)&quot; \<br>
&gt; +             INST_LUADIR=&quot;$(TARGET_DIR)/<wbr>usr/share/lua/$(<wbr>LUAINTERPRETER_ABIVER)&quot; \<br>
&gt; +     )<br>
&gt; +endef<br>
&gt; +<br>
&gt; +$(eval $(generic-package))<br>
&gt;<br>
<br>
--<br>
</span>Arnout Vandecappelle                          arnout at mind be<br>
Senior Embedded Software Architect            +32-16-286500<br>
Essensium/Mind                                <a href="http://www.mind.be" rel="noreferrer" target="_blank">http://www.mind.be</a><br>
G.Geenslaan 9, 3001 Leuven, Belgium           BE 872 984 063 RPR Leuven<br>
LinkedIn profile: <a href="http://www.linkedin.com/in/arnoutvandecappelle" rel="noreferrer" target="_blank">http://www.linkedin.com/in/<wbr>arnoutvandecappelle</a><br>
GPG fingerprint:  7493 020B C7E3 8618 8DEC 222C 82EB F404 F9AC 0DDF<br>
______________________________<wbr>_________________<br>
buildroot mailing list<br>
<a href="mailto:buildroot@busybox.net">buildroot@busybox.net</a><br>
<a href="http://lists.busybox.net/mailman/listinfo/buildroot" rel="noreferrer" target="_blank">http://lists.busybox.net/<wbr>mailman/listinfo/buildroot</a><br>
</blockquote></div><br></div></div>
Arnout Vandecappelle Sept. 24, 2017, 3:27 p.m. UTC | #3
On 24-09-17 16:03, François Perrad wrote:
> 
> luaposix have a rockspec, but not suitable for BR.
> Because our luarocks infrastructure handles only the type=builtin which
> represents almost 90% of all rockspec.
 OK. Would have been nice to mention this in the commit message.

 I pushed the rest of the series, with still a few things I had to fix up:

- In lua-libcurl, there was a space missing after the = in one of the assignments.
- In lua-valua and lua-sailor, the help text was not wrapped at 72 columns.
check-package caught this.
- In lua-markdown, the .mk and .hash file were called lua-mardown (missing a k).
check-package caught this as well.

 Regards,
 Arnout
diff mbox series

Patch

diff --git a/package/luaposix/luaposix.hash b/package/luaposix/luaposix.hash
index e2216be73..b3984c1d1 100644
--- a/package/luaposix/luaposix.hash
+++ b/package/luaposix/luaposix.hash
@@ -1,2 +1,2 @@ 
 # Locally calculated
-sha256 e66262f5b7fe1c32c65f17a5ef5ffb31c4d1877019b4870a5d373e2ab6526a21 luaposix-33.4.0.tar.gz
+sha256 ba0bc343783fc33958cd02a68cdbfd65430152d9f297f7ed92678b1a305bd5d7  luaposix-34.0.1.tar.gz
diff --git a/package/luaposix/luaposix.mk b/package/luaposix/luaposix.mk
index ea3af16fb..779e707ce 100644
--- a/package/luaposix/luaposix.mk
+++ b/package/luaposix/luaposix.mk
@@ -4,11 +4,27 @@ 
 #
 ################################################################################
 
-LUAPOSIX_VERSION = 33.4.0
+LUAPOSIX_VERSION = 34.0.1
 LUAPOSIX_SITE = $(call github,luaposix,luaposix,release-v$(LUAPOSIX_VERSION))
 LUAPOSIX_LICENSE = MIT
-LUAPOSIX_LICENSE_FILES = COPYING
+LUAPOSIX_LICENSE_FILES = LICENSE
 LUAPOSIX_DEPENDENCIES = luainterpreter host-lua
-LUAPOSIX_CONF_OPTS = --libdir="/usr/lib/lua/$(LUAINTERPRETER_ABIVER)" --datarootdir="/usr/share/lua/$(LUAINTERPRETER_ABIVER)"
 
-$(eval $(autotools-package))
+define LUAPOSIX_BUILD_CMDS
+	(cd $(@D); \
+		$(LUA_RUN) build-aux/luke \
+		CC="$(TARGET_CC)" \
+		CFLAGS="$(TARGET_CFLAGS)" \
+		LUA_INCDIR=$(STAGING_DIR)/usr/include \
+	)
+endef
+
+define LUAPOSIX_INSTALL_TARGET_CMDS
+	(cd $(@D); \
+		$(LUA_RUN) build-aux/luke install \
+		INST_LIBDIR="$(TARGET_DIR)/usr/lib/lua/$(LUAINTERPRETER_ABIVER)" \
+		INST_LUADIR="$(TARGET_DIR)/usr/share/lua/$(LUAINTERPRETER_ABIVER)" \
+	)
+endef
+
+$(eval $(generic-package))