diff mbox series

axel: bump to version 2.14.1

Message ID 20170922044545.18813-1-ismael@iodev.co.uk
State Changes Requested
Headers show
Series axel: bump to version 2.14.1 | expand

Commit Message

Ismael Luceno Sept. 22, 2017, 4:45 a.m. UTC
Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>
---
 package/axel/Config.in | 14 +++++++++++++-
 package/axel/axel.hash |  3 +--
 package/axel/axel.mk   | 17 ++++++++---------
 3 files changed, 22 insertions(+), 12 deletions(-)

Comments

Arnout Vandecappelle Sept. 24, 2017, 2:09 p.m. UTC | #1
Hi Ismael,

On 22-09-17 06:45, Ismael Luceno wrote:
> Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>

 Please make a longer commit message that explains a bit what changes you make:
- change upstream URL;
- add optional support for OpenSSL/LibreSSL;
...

> ---
>  package/axel/Config.in | 14 +++++++++++++-
>  package/axel/axel.hash |  3 +--
>  package/axel/axel.mk   | 17 ++++++++---------
>  3 files changed, 22 insertions(+), 12 deletions(-)
> 
> diff --git a/package/axel/Config.in b/package/axel/Config.in
> index 6e709cfb1351..c7dcbe71c179 100644
> --- a/package/axel/Config.in
> +++ b/package/axel/Config.in
> @@ -4,7 +4,19 @@ config BR2_PACKAGE_AXEL
>  	help
>  	  HTTP/FTP download accelerator.
>  
> -	  http://axel.alioth.debian.org/
> +	  https://github.com/axel-download-accelerator/

 Better refer to axel itself, that has a nice README.md:

https://github.com/axel-download-accelerator/axel

> +
> +if BR2_PACKAGE_AXEL
> +
> +config BR2_PACKAGE_AXEL_SSL
> +	bool "SSL/TLS support"
> +	default y
> +	depends on BR2_PACKAGE_OPENSSL || BR2_PACKAGE_LIBRESSL
> +
> +comment "SSL/TLS support requires openssl or libressl"
> +	depends on !(BR2_PACKAGE_OPENSSL || BR2_PACKAGE_LIBRESSL)

 Unless if there is a very good reason for it, we make this kind of dependency
automatic, i.e. don't add a Config.in option. Instead, add conditions to the .mk
file.

[snip]
>  
> -AXEL_VERSION = 2.4
> -AXEL_SITE = http://sources.buildroot.net
> +AXEL_VERSION = 2.14.1
> +AXEL_SITE = $(call github,axel-download-accelerator,axel,v$(AXEL_VERSION))

 If upstream has a v in their version, you should also have it. So

AXEL_VERSION = v2.14.1

 Note that as of today, the github helper no longer requires the third argument.

>  AXEL_LICENSE = GPL-2.0+
>  AXEL_LICENSE_FILES = COPYING
> -AXEL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
> +AXEL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) \
> +	$(if $(BR2_PACKAGE_AXEL_SSL),\
> +		$(if $(BR2_PACKAGE_LIBRESSL),libressl,openssl))

 Remove this part. Instead, add something like this:

ifeq ($(BR2_PACKAGE_OPENSSL),y)
AXEL_CONF_OPTS += --with-ssl
AXEL_DEPENDENCIES += openssl
else ifeq ($(BR2_PACKAGE_LIBRESSL),y)
AXEL_CONF_OPTS += --with-ssl
AXEL_DEPENDENCIES += libressl
else
AXEL_CONF_OPTS += --without-ssl
endif

 It's more lines, but it is easier to understand and therefore easier to maintain.

>  AXEL_LDFLAGS = -lpthread $(TARGET_NLS_LIBS)
>  
> -ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
> -AXEL_DISABLE_I18N = --i18n=0
> -endif
> -
>  define AXEL_CONFIGURE_CMDS
>  	(cd $(@D); \
> +		./autogen.sh; \
>  		./configure \
>  			--prefix=/usr \
> -			--debug=1 \
> -			$(AXEL_DISABLE_I18N) \
> +			$(if $(BR2_PACKAGE_AXEL_SSL),,--without-ssl) \
> +			$(if $(BR2_SYSTEM_ENABLE_NLS),,--disable-nls) \

 While you're at it, perhaps you can switch to the autotools infrastructure.
You'll have to set AXEL_AUTORECONF = YES because there is no configure script
included. But then the configure, build and install commands can just be removed.

 Regards,
 Arnout

>  	)
>  endef
>  
>
Ismael Luceno Sept. 25, 2017, 2:27 p.m. UTC | #2
Thanks for the feedback.

On 24/Sep/2017 16:09, Arnout Vandecappelle wrote:
<...>
> If upstream has a v in their version, you should also have it. So
> 
> AXEL_VERSION = v2.14.1
> 
> Note that as of today, the github helper no longer requires the third
> argument.

The "v" is not part of the version number, so I would prefer to leave it
out of AXEL_VERSION...
Arnout Vandecappelle Sept. 25, 2017, 4:44 p.m. UTC | #3
On 25-09-17 16:27, Ismael Luceno wrote:
> Thanks for the feedback.
> 
> On 24/Sep/2017 16:09, Arnout Vandecappelle wrote:
> <...>
>> If upstream has a v in their version, you should also have it. So
>>
>> AXEL_VERSION = v2.14.1
>>
>> Note that as of today, the github helper no longer requires the third
>> argument.
> 
> The "v" is not part of the version number, so I would prefer to leave it
> out of AXEL_VERSION...

 No, the v *is* part of the version number. If you use the github helper, the
_VERSION variable must be identical to the upstream tag.

 And as I said, the third argument to the github helper isn't needed anymore
because is automatically uses _VERSION.

 Regards,
 Arnout
Ismael Luceno Sept. 25, 2017, 5:41 p.m. UTC | #4
On 25/Sep/2017 18:44, Arnout Vandecappelle wrote:
> 
> 
> On 25-09-17 16:27, Ismael Luceno wrote:
> > Thanks for the feedback.
> > 
> > On 24/Sep/2017 16:09, Arnout Vandecappelle wrote:
> > <...>
> >> If upstream has a v in their version, you should also have it. So
> >>
> >> AXEL_VERSION = v2.14.1
> >>
> >> Note that as of today, the github helper no longer requires the third
> >> argument.
> > 
> > The "v" is not part of the version number, so I would prefer to leave it
> > out of AXEL_VERSION...
> 
>  No, the v *is* part of the version number. If you use the github helper, the
> _VERSION variable must be identical to the upstream tag.

Well, that's a matter of interpretation, the project considers it a
prefix, and Github agrees with common practice and removes the "v"
prefix when building the archive...

So if using the github macro, AXEL_VERSION must be a tag or commit id?
Arnout Vandecappelle Sept. 25, 2017, 7:50 p.m. UTC | #5
On 25-09-17 19:41, Ismael Luceno wrote:
> On 25/Sep/2017 18:44, Arnout Vandecappelle wrote:
>>
>>
>> On 25-09-17 16:27, Ismael Luceno wrote:
>>> Thanks for the feedback.
>>>
>>> On 24/Sep/2017 16:09, Arnout Vandecappelle wrote:
>>> <...>
>>>> If upstream has a v in their version, you should also have it. So
>>>>
>>>> AXEL_VERSION = v2.14.1
>>>>
>>>> Note that as of today, the github helper no longer requires the third
>>>> argument.
>>>
>>> The "v" is not part of the version number, so I would prefer to leave it
>>> out of AXEL_VERSION...
>>
>>  No, the v *is* part of the version number. If you use the github helper, the
>> _VERSION variable must be identical to the upstream tag.
> 
> Well, that's a matter of interpretation, the project considers it a
> prefix, and Github agrees with common practice and removes the "v"
> prefix when building the archive...
> 
> So if using the github macro, AXEL_VERSION must be a tag or commit id?

 Quoting [1]:

"The FOO_VERSION can either be a tag or a commit ID."


 Regards,
 Arnout


[1] https://buildroot.org/downloads/manual/manual.html#github-download-url
diff mbox series

Patch

diff --git a/package/axel/Config.in b/package/axel/Config.in
index 6e709cfb1351..c7dcbe71c179 100644
--- a/package/axel/Config.in
+++ b/package/axel/Config.in
@@ -4,7 +4,19 @@  config BR2_PACKAGE_AXEL
 	help
 	  HTTP/FTP download accelerator.
 
-	  http://axel.alioth.debian.org/
+	  https://github.com/axel-download-accelerator/
+
+if BR2_PACKAGE_AXEL
+
+config BR2_PACKAGE_AXEL_SSL
+	bool "SSL/TLS support"
+	default y
+	depends on BR2_PACKAGE_OPENSSL || BR2_PACKAGE_LIBRESSL
+
+comment "SSL/TLS support requires openssl or libressl"
+	depends on !(BR2_PACKAGE_OPENSSL || BR2_PACKAGE_LIBRESSL)
+
+endif
 
 comment "axel needs a toolchain w/ threads"
 	depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/axel/axel.hash b/package/axel/axel.hash
index 895767011892..d9b610f7e3c2 100644
--- a/package/axel/axel.hash
+++ b/package/axel/axel.hash
@@ -1,2 +1 @@ 
-# Locally calculated
-sha256	359a57ab4e354bcb6075430d977c59d33eb3e2f1415a811948fa8ae657ca8036  axel-2.4.tar.gz
+sha256	acf6820d98a792faf309fc9acf22f7caf4b8a4b7001072c8f546b3c4fc755e39  axel-2.14.1.tar.gz
diff --git a/package/axel/axel.mk b/package/axel/axel.mk
index 60bf5e4a61df..50d87d982898 100644
--- a/package/axel/axel.mk
+++ b/package/axel/axel.mk
@@ -4,23 +4,22 @@ 
 #
 ################################################################################
 
-AXEL_VERSION = 2.4
-AXEL_SITE = http://sources.buildroot.net
+AXEL_VERSION = 2.14.1
+AXEL_SITE = $(call github,axel-download-accelerator,axel,v$(AXEL_VERSION))
 AXEL_LICENSE = GPL-2.0+
 AXEL_LICENSE_FILES = COPYING
-AXEL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
+AXEL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) \
+	$(if $(BR2_PACKAGE_AXEL_SSL),\
+		$(if $(BR2_PACKAGE_LIBRESSL),libressl,openssl))
 AXEL_LDFLAGS = -lpthread $(TARGET_NLS_LIBS)
 
-ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
-AXEL_DISABLE_I18N = --i18n=0
-endif
-
 define AXEL_CONFIGURE_CMDS
 	(cd $(@D); \
+		./autogen.sh; \
 		./configure \
 			--prefix=/usr \
-			--debug=1 \
-			$(AXEL_DISABLE_I18N) \
+			$(if $(BR2_PACKAGE_AXEL_SSL),,--without-ssl) \
+			$(if $(BR2_SYSTEM_ENABLE_NLS),,--disable-nls) \
 	)
 endef