diff mbox

execline: restore --shebangdir configure option

Message ID 20170707170946.6321-1-eric.le.bihan.dev@free.fr
State Accepted
Commit d97d16034e22b68ad21706881bdc0d045f0a19db
Headers show

Commit Message

Eric Le Bihan July 7, 2017, 5:09 p.m. UTC
Passing the option --shebangdir=/usr/bin to the configuration script adds the
CPP definition EXECLINE_SHEBANGPREFIX to
execline-x.y.z/src/include/execline/config.h. It is used by `s6-rc-compile` from
the s6-rc package to set the path to the execline interpreter in the scripts it
generates.

So, when building the host variant of execline, this path will be used in the
target service scripts generated by the host variant of `s6-rc-compile`. If not
forced to /usr/bin, the location of the execline interpreter on the target, it
will default to $(HOST_DIR)/bin thus leading to non-working scripts on the
target.

So, restore this option for the host variant.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
---
 package/execline/execline.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Arnout Vandecappelle July 7, 2017, 8:17 p.m. UTC | #1
On 07-07-17 19:09, Eric Le Bihan wrote:
> Passing the option --shebangdir=/usr/bin to the configuration script adds the
> CPP definition EXECLINE_SHEBANGPREFIX to
> execline-x.y.z/src/include/execline/config.h. It is used by `s6-rc-compile` from
> the s6-rc package to set the path to the execline interpreter in the scripts it
> generates.
> 
> So, when building the host variant of execline, this path will be used in the
> target service scripts generated by the host variant of `s6-rc-compile`. If not
> forced to /usr/bin, the location of the execline interpreter on the target, it
> will default to $(HOST_DIR)/bin thus leading to non-working scripts on the
> target.
> 
> So, restore this option for the host variant.
> 
> Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
> ---
>  package/execline/execline.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/execline/execline.mk b/package/execline/execline.mk
> index d3d69a8..576f11c 100644
> --- a/package/execline/execline.mk
> +++ b/package/execline/execline.mk
> @@ -44,8 +44,11 @@ endef
>  
>  HOST_EXECLINE_DEPENDENCIES = host-skalibs
>  
> +# Set --shebangdir to /usr/bin, as this value is used by the host variant of
> +# s6-rc when generating execline scripts for the target.

 A comment that clarifies it! Excellent! And indeed, execline is installed in
/usr/bin, so

Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Regards,
 Arnout


>  HOST_EXECLINE_CONF_OPTS = \
>  	--prefix=$(HOST_DIR) \
> +	--shebangdir=/usr/bin \
>  	--with-sysdeps=$(HOST_DIR)/lib/skalibs/sysdeps \
>  	--with-include=$(HOST_DIR)/include \
>  	--with-dynlib=$(HOST_DIR)/lib \
>
Peter Korsgaard July 8, 2017, 11:44 a.m. UTC | #2
>>>>> "Eric" == Eric Le Bihan <eric.le.bihan.dev@free.fr> writes:

 > Passing the option --shebangdir=/usr/bin to the configuration script adds the
 > CPP definition EXECLINE_SHEBANGPREFIX to
 > execline-x.y.z/src/include/execline/config.h. It is used by `s6-rc-compile` from
 > the s6-rc package to set the path to the execline interpreter in the scripts it
 > generates.

 > So, when building the host variant of execline, this path will be used in the
 > target service scripts generated by the host variant of `s6-rc-compile`. If not
 > forced to /usr/bin, the location of the execline interpreter on the target, it
 > will default to $(HOST_DIR)/bin thus leading to non-working scripts on the
 > target.

 > So, restore this option for the host variant.

 > Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>

Committed, thanks.
diff mbox

Patch

diff --git a/package/execline/execline.mk b/package/execline/execline.mk
index d3d69a8..576f11c 100644
--- a/package/execline/execline.mk
+++ b/package/execline/execline.mk
@@ -44,8 +44,11 @@  endef
 
 HOST_EXECLINE_DEPENDENCIES = host-skalibs
 
+# Set --shebangdir to /usr/bin, as this value is used by the host variant of
+# s6-rc when generating execline scripts for the target.
 HOST_EXECLINE_CONF_OPTS = \
 	--prefix=$(HOST_DIR) \
+	--shebangdir=/usr/bin \
 	--with-sysdeps=$(HOST_DIR)/lib/skalibs/sysdeps \
 	--with-include=$(HOST_DIR)/include \
 	--with-dynlib=$(HOST_DIR)/lib \