diff mbox

package/libdrm: fix autoreconf

Message ID 20170402175029.25526-1-yann.morin.1998@free.fr
State Accepted
Headers show

Commit Message

Yann E. MORIN April 2, 2017, 5:50 p.m. UTC
To properly autoreconf, the xorg macros, from host-xutil_util-macros,
are needed.

Fixes:
    http://autobuild.buildroot.org/results/2e8/2e887c25b22bd36eab36ff361645306c8ddb79aa/
    http://autobuild.buildroot.org/results/7c0/7c0050d63a1d34eecb6d16e2654369cea561707a/
    http://autobuild.buildroot.org/results/2ef/2ef3d6d74c56632c012b85e05af6eaf0259b72c9/
    [...]

(Thanks Romain for confirming the fix on IRC! ;-) )

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Cc: Romain Naour <romain.naour@openwide.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/libdrm/libdrm.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Romain Naour April 2, 2017, 6:01 p.m. UTC | #1
Hi Yann, All,

Le 02/04/2017 à 19:50, Yann E. MORIN a écrit :
> To properly autoreconf, the xorg macros, from host-xutil_util-macros,
> are needed.
> 
> Fixes:
>     http://autobuild.buildroot.org/results/2e8/2e887c25b22bd36eab36ff361645306c8ddb79aa/
>     http://autobuild.buildroot.org/results/7c0/7c0050d63a1d34eecb6d16e2654369cea561707a/
>     http://autobuild.buildroot.org/results/2ef/2ef3d6d74c56632c012b85e05af6eaf0259b72c9/
>     [...]
> 
> (Thanks Romain for confirming the fix on IRC! ;-) )

Actually, I really used the target variant xutil_util-macros-1.19.1.
I don't even have the host variant in my build directory.

Best regards,
Romain

> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
> Cc: Romain Naour <romain.naour@openwide.fr>
> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
>  package/libdrm/libdrm.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libdrm/libdrm.mk b/package/libdrm/libdrm.mk
> index 875d3cc..8223262 100644
> --- a/package/libdrm/libdrm.mk
> +++ b/package/libdrm/libdrm.mk
> @@ -15,7 +15,8 @@ LIBDRM_INSTALL_STAGING = YES
>  
>  LIBDRM_DEPENDENCIES = \
>  	libpthread-stubs \
> -	host-pkgconf
> +	host-pkgconf \
> +	host-xutil_util-macros
>  
>  LIBDRM_CONF_OPTS = \
>  	--disable-cairo-tests \
>
diff mbox

Patch

diff --git a/package/libdrm/libdrm.mk b/package/libdrm/libdrm.mk
index 875d3cc..8223262 100644
--- a/package/libdrm/libdrm.mk
+++ b/package/libdrm/libdrm.mk
@@ -15,7 +15,8 @@  LIBDRM_INSTALL_STAGING = YES
 
 LIBDRM_DEPENDENCIES = \
 	libpthread-stubs \
-	host-pkgconf
+	host-pkgconf \
+	host-xutil_util-macros
 
 LIBDRM_CONF_OPTS = \
 	--disable-cairo-tests \