diff mbox

[10/51] core/legal-info: install source archives in their own sub-dir

Message ID 2015f01b3ecd96e43165cbb91c96bfd0ebd196ec.1448289515.git.yann.morin.1998@free.fr
State Changes Requested
Headers show

Commit Message

Yann E. MORIN Nov. 23, 2015, 2:47 p.m. UTC
Currently, we put all source archives side-by-side in the same
directory.

Since we're about to also save individual patches that were applied
on those sources, we don't want to make that directory a complete
mess of unassorted files.

So, we install each source archive in its own sub-directory, where
we'll later store the patches too. Store that location in a variable,
so it can be re-used later on (to install patches in a future commit).

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
---
 package/pkg-generic.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Luca Ceresoli Dec. 3, 2015, 5:16 p.m. UTC | #1
Yann,

Yann E. MORIN wrote:
> Currently, we put all source archives side-by-side in the same
> directory.
>
> Since we're about to also save individual patches that were applied
> on those sources, we don't want to make that directory a complete
> mess of unassorted files.
>
> So, we install each source archive in its own sub-directory, where
> we'll later store the patches too. Store that location in a variable,
> so it can be re-used later on (to install patches in a future commit).
>
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Luca Ceresoli <luca@lucaceresoli.net>
> ---
>   package/pkg-generic.mk | 4 +++-
>   1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
> index 98db3ba..bb3a6da 100644
> --- a/package/pkg-generic.mk
> +++ b/package/pkg-generic.mk
> @@ -482,6 +482,8 @@ endif
>
>   $(2)_REDISTRIBUTE		?= YES
>
> +$(2)_REDIST_SOURCES_DIR = $$(REDIST_SOURCES_DIR_$$(call UPPERCASE,$(4)))/$$($(2)_RAWNAME)-$$($(2)_VERSION)
> +
>   # When a target package is a toolchain dependency set this variable to
>   # 'NO' so the 'toolchain' dependency is not added to prevent a circular
>   # dependency
> @@ -812,7 +814,7 @@ endif
>   # Copy the source tarball
>   	$$(Q)$$(call hardlink-copy,\
>   		     $$(DL_DIR)/$$($(2)_ACTUAL_SOURCE_TARBALL),\
> -		     $$(REDIST_SOURCES_DIR_$$(call UPPERCASE,$(4))))
> +		     $$($(2)_REDIST_SOURCES_DIR))
>   endif # redistribute
>
>   endif # other packages
>

Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Tested-by: Luca Ceresoli <luca@lucaceresoli.net>

Although this makes little sense without the further patches up to:

   [PATCH 12/51] core/apply-patches: store full path of applied patches

which are under discussion.
Luca Ceresoli Dec. 3, 2015, 5:25 p.m. UTC | #2
Il 03/12/2015 18:16, Luca Ceresoli ha scritto:
> Yann,
>
> Yann E. MORIN wrote:
>> Currently, we put all source archives side-by-side in the same
>> directory.
>>
>> Since we're about to also save individual patches that were applied
>> on those sources, we don't want to make that directory a complete
>> mess of unassorted files.
>>
>> So, we install each source archive in its own sub-directory, where
>> we'll later store the patches too. Store that location in a variable,
>> so it can be re-used later on (to install patches in a future commit).
>>
>> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
>> Cc: Luca Ceresoli <luca@lucaceresoli.net>
>> ---
>>   package/pkg-generic.mk | 4 +++-
>>   1 file changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
>> index 98db3ba..bb3a6da 100644
>> --- a/package/pkg-generic.mk
>> +++ b/package/pkg-generic.mk
>> @@ -482,6 +482,8 @@ endif
>>
>>   $(2)_REDISTRIBUTE        ?= YES
>>
>> +$(2)_REDIST_SOURCES_DIR = $$(REDIST_SOURCES_DIR_$$(call
>> UPPERCASE,$(4)))/$$($(2)_RAWNAME)-$$($(2)_VERSION)
>> +
>>   # When a target package is a toolchain dependency set this variable to
>>   # 'NO' so the 'toolchain' dependency is not added to prevent a circular
>>   # dependency
>> @@ -812,7 +814,7 @@ endif
>>   # Copy the source tarball
>>       $$(Q)$$(call hardlink-copy,\
>>                $$(DL_DIR)/$$($(2)_ACTUAL_SOURCE_TARBALL),\
>> -             $$(REDIST_SOURCES_DIR_$$(call UPPERCASE,$(4))))
>> +             $$($(2)_REDIST_SOURCES_DIR))
>>   endif # redistribute
>>
>>   endif # other packages
>>
>
> Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
> Tested-by: Luca Ceresoli <luca@lucaceresoli.net>
>
> Although this makes little sense without the further patches up to:
>
>    [PATCH 12/51] core/apply-patches: store full path of applied patches

Sorry, I actually meant:

   [PATCH 13/51] core/legal-info: also save patches
diff mbox

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 98db3ba..bb3a6da 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -482,6 +482,8 @@  endif
 
 $(2)_REDISTRIBUTE		?= YES
 
+$(2)_REDIST_SOURCES_DIR = $$(REDIST_SOURCES_DIR_$$(call UPPERCASE,$(4)))/$$($(2)_RAWNAME)-$$($(2)_VERSION)
+
 # When a target package is a toolchain dependency set this variable to
 # 'NO' so the 'toolchain' dependency is not added to prevent a circular
 # dependency
@@ -812,7 +814,7 @@  endif
 # Copy the source tarball
 	$$(Q)$$(call hardlink-copy,\
 		     $$(DL_DIR)/$$($(2)_ACTUAL_SOURCE_TARBALL),\
-		     $$(REDIST_SOURCES_DIR_$$(call UPPERCASE,$(4))))
+		     $$($(2)_REDIST_SOURCES_DIR))
 endif # redistribute
 
 endif # other packages