diff mbox series

package/libglib2: disable compiler warnings

Message ID 1556024465-7928-1-git-send-email-jugurtha.belkalem@smile.fr
State Rejected
Headers show
Series package/libglib2: disable compiler warnings | expand

Commit Message

Jugurtha BELKALEM April 23, 2019, 1:01 p.m. UTC
This flag is not set by default which yields in a
compilation error when host-qemu package is enabled.
The build fails at libglib2 package because -Werror
is activated which stops the compilation process.
Adding this flag corrects the issue.

Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
---
 package/libglib2/libglib2.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni April 23, 2019, 2:23 p.m. UTC | #1
Hello,

On Tue, 23 Apr 2019 15:01:05 +0200
Jugurtha BELKALEM <jugurtha.belkalem@smile.fr> wrote:

> This flag is not set by default which yields in a
> compilation error when host-qemu package is enabled.
> The build fails at libglib2 package because -Werror
> is activated which stops the compilation process.
> Adding this flag corrects the issue.

Could you be more specific about the build failure you encounter ?
Also, what is the relationship with host-qemu ? host-libglib2 is build
as a dependency for tons of things, including libglib2 itself, i.e it
is built many times a day in our autobuilders. So what is different in
your situation that requires disabling compiler warnings ?

Thanks,

Thomas
Jugurtha BELKALEM April 23, 2019, 2:45 p.m. UTC | #2
Hi Thomas,

I'm currently integrating the Qemu test from toolchain builder (
https://github.com/bootlin/toolchains-builder/blob/master/build.sh) into
buildroot to check the consistency of the build and get some ensurance that
Qemu build process went successful for the various Qemu architectures. This
why I have enabled host-qemu. When compiling without using
"--disable-compile-warnings"; I got this message :

>>> host-libglib2 2.56.4 Patching libtool
>>> host-libglib2 2.56.4 Building
Failed build last output
  CC       libgio_2_0_la-glistmodel.lo
  CC       libgio_2_0_la-gliststore.lo
  CC       libgio_2_0_la-gapplication.lo
....
....
....
cc1: some warnings being treated as errors
Makefile:3927: recipe for target 'libgio_2_0_la-gunixconnection.lo' failed

A complete log errors is available here :
https://gitlab.com/jugurthaB/buildroot/-/jobs/200780681.


After disabling the warnings; most architectures passes the test with
success as shown at :
https://gitlab.com/jugurthaB/buildroot/pipelines/57964815

Thank's.

On Tue, Apr 23, 2019 at 4:23 PM Thomas Petazzoni <
thomas.petazzoni@bootlin.com> wrote:

> Hello,
>
> On Tue, 23 Apr 2019 15:01:05 +0200
> Jugurtha BELKALEM <jugurtha.belkalem@smile.fr> wrote:
>
> > This flag is not set by default which yields in a
> > compilation error when host-qemu package is enabled.
> > The build fails at libglib2 package because -Werror
> > is activated which stops the compilation process.
> > Adding this flag corrects the issue.
>
> Could you be more specific about the build failure you encounter ?
> Also, what is the relationship with host-qemu ? host-libglib2 is build
> as a dependency for tons of things, including libglib2 itself, i.e it
> is built many times a day in our autobuilders. So what is different in
> your situation that requires disabling compiler warnings ?
>
> Thanks,
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
>
>
<div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div>Hi Thomas,</div><div><br></div><div>I&#39;m currently integrating the Qemu test from toolchain builder (<a href="https://github.com/bootlin/toolchains-builder/blob/master/build.sh">https://github.com/bootlin/toolchains-builder/blob/master/build.sh</a>) into buildroot to check the consistency of the build and get some ensurance that Qemu build process went successful for the various Qemu architectures. This why I have enabled host-qemu. When compiling without using &quot;--disable-compile-warnings&quot;; I got this message : <br></div><div><br></div><div><pre class="gmail-js-build-trace gmail-build-trace gmail-qa-build-trace"><code class="gmail-bash">&gt;&gt;&gt; host-libglib2 2.56.4 Patching libtool<br>&gt;&gt;&gt; host-libglib2 2.56.4 Building<br>Failed build last output<br>  CC       libgio_2_0_la-glistmodel.lo<br>  CC       libgio_2_0_la-gliststore.lo<br>  CC       libgio_2_0_la-gapplication.lo<br>....<br>....<br>....<br><code class="gmail-bash">cc1: some warnings being treated as errors<br>Makefile:3927: recipe for target &#39;libgio_2_0_la-gunixconnection.lo&#39; failed<br><span style="font-family:arial,helvetica,sans-serif"><br></span></code></code></pre><pre class="gmail-js-build-trace gmail-build-trace gmail-qa-build-trace"><code class="gmail-bash"><code class="gmail-bash"><span style="font-family:arial,helvetica,sans-serif">A complete log errors is available here : <a href="https://gitlab.com/jugurthaB/buildroot/-/jobs/200780681">https://gitlab.com/jugurthaB/buildroot/-/jobs/200780681</a></span>.<br></code></code></pre></div></div><div dir="ltr"><br></div><div>After disabling the warnings; most architectures passes the test with success as shown at : <a href="https://gitlab.com/jugurthaB/buildroot/pipelines/57964815">https://gitlab.com/jugurthaB/buildroot/pipelines/57964815</a><br></div><div dir="ltr"><br></div><div>Thank&#39;s.</div><div><br></div><div dir="ltr"><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Tue, Apr 23, 2019 at 4:23 PM Thomas Petazzoni &lt;<a href="mailto:thomas.petazzoni@bootlin.com">thomas.petazzoni@bootlin.com</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Hello,<br>
<br>
On Tue, 23 Apr 2019 15:01:05 +0200<br>
Jugurtha BELKALEM &lt;<a href="mailto:jugurtha.belkalem@smile.fr" target="_blank">jugurtha.belkalem@smile.fr</a>&gt; wrote:<br>
<br>
&gt; This flag is not set by default which yields in a<br>
&gt; compilation error when host-qemu package is enabled.<br>
&gt; The build fails at libglib2 package because -Werror<br>
&gt; is activated which stops the compilation process.<br>
&gt; Adding this flag corrects the issue.<br>
<br>
Could you be more specific about the build failure you encounter ?<br>
Also, what is the relationship with host-qemu ? host-libglib2 is build<br>
as a dependency for tons of things, including libglib2 itself, i.e it<br>
is built many times a day in our autobuilders. So what is different in<br>
your situation that requires disabling compiler warnings ?<br>
<br>
Thanks,<br>
<br>
Thomas<br>
-- <br>
Thomas Petazzoni, CTO, Bootlin<br>
Embedded Linux and Kernel engineering<br>
<a href="https://bootlin.com" rel="noreferrer" target="_blank">https://bootlin.com</a><br>
<br>
</blockquote></div><div dir="ltr" class="gmail_signature"><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div>                    </div><div>      </div></div></div></div></div></div></div></div></div></div></div>
Vadym Kochan April 23, 2019, 2:51 p.m. UTC | #3
Hi Jugurtha, Thomas,

On Tue, Apr 23, 2019 at 04:45:34PM +0200, Jugurtha BELKALEM wrote:
> Hi Thomas,
> 
> I'm currently integrating the Qemu test from toolchain builder (
> https://github.com/bootlin/toolchains-builder/blob/master/build.sh) into
> buildroot to check the consistency of the build and get some ensurance that
> Qemu build process went successful for the various Qemu architectures. This
> why I have enabled host-qemu. When compiling without using
> "--disable-compile-warnings"; I got this message :
> 
> >>> host-libglib2 2.56.4 Patching libtool
> >>> host-libglib2 2.56.4 Building
> Failed build last output
>   CC       libgio_2_0_la-glistmodel.lo
>   CC       libgio_2_0_la-gliststore.lo
>   CC       libgio_2_0_la-gapplication.lo
> ....
> ....
> ....
> cc1: some warnings being treated as errors
> Makefile:3927: recipe for target 'libgio_2_0_la-gunixconnection.lo' failed

This is very similar error which was related to gettext-tiny libintl.h
header but issue was fixed already (may be about 1 month ago).
Could you please share the defconfig ?

> 
> A complete log errors is available here :
> https://gitlab.com/jugurthaB/buildroot/-/jobs/200780681.
> 
> 
> After disabling the warnings; most architectures passes the test with
> success as shown at :
> https://gitlab.com/jugurthaB/buildroot/pipelines/57964815
> 
> Thank's.
> 
> On Tue, Apr 23, 2019 at 4:23 PM Thomas Petazzoni <
> thomas.petazzoni@bootlin.com> wrote:
> 
> > Hello,
> >
> > On Tue, 23 Apr 2019 15:01:05 +0200
> > Jugurtha BELKALEM <jugurtha.belkalem@smile.fr> wrote:
> >
> > > This flag is not set by default which yields in a
> > > compilation error when host-qemu package is enabled.
> > > The build fails at libglib2 package because -Werror
> > > is activated which stops the compilation process.
> > > Adding this flag corrects the issue.
> >
> > Could you be more specific about the build failure you encounter ?
> > Also, what is the relationship with host-qemu ? host-libglib2 is build
> > as a dependency for tons of things, including libglib2 itself, i.e it
> > is built many times a day in our autobuilders. So what is different in
> > your situation that requires disabling compiler warnings ?
> >
> > Thanks,
> >
> > Thomas

[SNIP]

Regards,
Vadim Kochan
Arnout Vandecappelle May 5, 2019, 10:08 p.m. UTC | #4
Hi Jugurtha,

On 23/04/2019 16:51, Vadym Kochan wrote:
> Hi Jugurtha, Thomas,
> 
> On Tue, Apr 23, 2019 at 04:45:34PM +0200, Jugurtha BELKALEM wrote:
>> Hi Thomas,
>>
>> I'm currently integrating the Qemu test from toolchain builder (
>> https://github.com/bootlin/toolchains-builder/blob/master/build.sh) into
>> buildroot to check the consistency of the build and get some ensurance that
>> Qemu build process went successful for the various Qemu architectures. This
>> why I have enabled host-qemu. When compiling without using
>> "--disable-compile-warnings"; I got this message :
>>
>>>>> host-libglib2 2.56.4 Patching libtool
>>>>> host-libglib2 2.56.4 Building
>> Failed build last output
>>   CC       libgio_2_0_la-glistmodel.lo
>>   CC       libgio_2_0_la-gliststore.lo
>>   CC       libgio_2_0_la-gapplication.lo
>> ....
>> ....
>> ....
>> cc1: some warnings being treated as errors
>> Makefile:3927: recipe for target 'libgio_2_0_la-gunixconnection.lo' failed
> 
> This is very similar error which was related to gettext-tiny libintl.h
> header but issue was fixed already (may be about 1 month ago).
> Could you please share the defconfig ?

 Since you didn't come back to this issue, I assumed it was resolved in the end
in some other way, so I've marked the patch as Rejected in patchwork.

 If it still is relevant, please repost it with an updated explanation.

 Regards,
 Arnout
diff mbox series

Patch

diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
index 63bfec3..5fd0544 100644
--- a/package/libglib2/libglib2.mk
+++ b/package/libglib2/libglib2.mk
@@ -91,6 +91,7 @@  LIBGLIB2_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -marm"
 endif
 
 HOST_LIBGLIB2_CONF_OPTS = \
+	--disable-compile-warnings \
 	--disable-coverage \
 	--disable-dtrace \
 	--disable-fam \