diff mbox series

[1/1] package/qemu: allow enabling virtual filesystem

Message ID 1542900100-13157-1-git-send-email-etienne.carriere@linaro.org
State Accepted
Headers show
Series [1/1] package/qemu: allow enabling virtual filesystem | expand

Commit Message

Etienne Carriere Nov. 22, 2018, 3:21 p.m. UTC
Introduce builrdoot package configuration directive to enable Qemu host configuration directive

Signed-off-by: Etienne Carriere <etienne.carriere@linaro.org>
---
 package/qemu/Config.in.host | 6 ++++++
 package/qemu/qemu.mk        | 4 ++++
 2 files changed, 10 insertions(+)

Comments

Thomas Petazzoni Nov. 24, 2018, 1:54 p.m. UTC | #1
Hello,

On Thu, 22 Nov 2018 16:21:40 +0100, Etienne Carriere wrote:

> +config BR2_PACKAGE_HOST_QEMU_VIRTFS
> +	bool "Enable virtual filesystem in Qemu emulator"

I've reworded this to:

	bool "Virtual filesystem support"

to be more consistent with the existing VDE2 option. Indeed, indicating
"Enable" in an option is not very useful: it's pretty obvious than an
option is here to "Enable" something. Also the "in Qemu emulator" is
not very useful either, since the option being added is already a
sub-option of the main host-qemu option.

I've applied to next after this minor change. Thanks!

Thomas
Etienne Carriere Nov. 26, 2018, 7:13 a.m. UTC | #2
On Sat, 24 Nov 2018 at 14:54, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> Hello,
>
> On Thu, 22 Nov 2018 16:21:40 +0100, Etienne Carriere wrote:
>
> > +config BR2_PACKAGE_HOST_QEMU_VIRTFS
> > +     bool "Enable virtual filesystem in Qemu emulator"
>
> I've reworded this to:
>
>         bool "Virtual filesystem support"
>
> to be more consistent with the existing VDE2 option. Indeed, indicating
> "Enable" in an option is not very useful: it's pretty obvious than an
> option is here to "Enable" something. Also the "in Qemu emulator" is
> not very useful either, since the option being added is already a
> sub-option of the main host-qemu option.
>
> I've applied to next after this minor change. Thanks!

Hello Thomas,

Ok, thanks a lot.

etienne

>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/package/qemu/Config.in.host b/package/qemu/Config.in.host
index 957c7d2..8840ff5 100644
--- a/package/qemu/Config.in.host
+++ b/package/qemu/Config.in.host
@@ -67,4 +67,10 @@  config BR2_PACKAGE_HOST_QEMU_VDE2
 	  Ethernet and can be used to create virtual switches to
 	  "plug" both physical and virtual machines in them.
 
+config BR2_PACKAGE_HOST_QEMU_VIRTFS
+	bool "Enable virtual filesystem in Qemu emulator"
+	help
+	  Enables support for virtual filesystem in Qemu allowing
+	  shared filesystem between Qemu and its emulated target.
+
 endif
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 709535a..8153c06 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -254,6 +254,10 @@  HOST_QEMU_OPTS += --enable-vde
 HOST_QEMU_DEPENDENCIES += host-vde2
 endif
 
+ifdef ($(BR2_PACKAGE_HOST_QEMU_VIRTFS),y)
+HOST_QEMU_OPTS += --enable-virtfs
+endif
+
 # Override CPP, as it expects to be able to call it like it'd
 # call the compiler.
 define HOST_QEMU_CONFIGURE_CMDS