diff mbox series

ghostscript: wrong fonts path set in target application

Message ID 1532519188355-0.post@n4.nabble.com
State Accepted
Headers show
Series ghostscript: wrong fonts path set in target application | expand

Commit Message

Thomas Ehrhardt July 25, 2018, 11:46 a.m. UTC
Without this patch the fonts path of ghostscript is wrong.





--
Sent from: http://buildroot-busybox.2317881.n4.nabble.com/

Comments

Thomas Petazzoni July 25, 2018, 2:37 p.m. UTC | #1
Hello,

On Wed, 25 Jul 2018 06:46:28 -0500 (CDT), Thomas Ehrhardt wrote:
> Without this patch the fonts path of ghostscript is wrong.

This probably looks good, but could you describe a bit more how the
problem manifests itself in practice ?

Also, could you resend with your Signed-off-by line added ?

Thanks!

Thomas
Thomas Ehrhardt July 26, 2018, 8:44 a.m. UTC | #2
Hi Thomas,

in the ghostscript-fonts package the variable is set too:
GHOSTSCRIPT_FONTS_TARGET_DIR = $(TARGET_DIR)/usr/share/fonts/gs

On the target system the call ghostscript -h shows something like this:
Search path:
[..]
/[..]/output/target/usr/share/fonts/gs

This is a wrong fonts search directory compiled within ghostscript, I think
correct is /usr/share/fonts

Regards
Thomas




--
Sent from: http://buildroot-busybox.2317881.n4.nabble.com/
Thomas Ehrhardt July 26, 2018, 8:57 a.m. UTC | #3
Signed-off-by: Thomas Ehrhardt <tehrhardt@innovaphone.com> 
---
--- a/package/ghostscript/ghostscript.mk
+++ b/package/ghostscript/ghostscript.mk
@@ -40,7 +40,7 @@
        --disable-compile-inits \
        --disable-cups \
        --enable-fontconfig \
-       --with-fontpath=$(GHOSTSCRIPT_FONTS_TARGET_DIR) \
+       --with-fontpath=/usr/share/fonts \
        --enable-freetype \
        --disable-gtk \
        --without-jbig2dec \





--
Sent from: http://buildroot-busybox.2317881.n4.nabble.com/
Arnout Vandecappelle July 28, 2018, 10:04 p.m. UTC | #4
On 26-07-18 10:57, Thomas Ehrhardt wrote:
> Signed-off-by: Thomas Ehrhardt <tehrhardt@innovaphone.com> 
> ---
> --- a/package/ghostscript/ghostscript.mk
> +++ b/package/ghostscript/ghostscript.mk
> @@ -40,7 +40,7 @@
>         --disable-compile-inits \
>         --disable-cups \
>         --enable-fontconfig \
> -       --with-fontpath=$(GHOSTSCRIPT_FONTS_TARGET_DIR) \
> +       --with-fontpath=/usr/share/fonts \

 This diff was containing spaces instead of tabs, so it didn't apply. Please
send patches using git send-email in the future, as explained in the manual.

 I've made this change manually and applied. I've also improved the commit
message with the information you gave in your earlier mail:

    ghostscript: set correct font path on target

    GHOSTSCRIPT_FONTS_TARGET_DIR is set to $(TARGET_DIR)/usr/share/fonts/gs
    in ghostscript-fonts.mk. If we pass this full path to ghostscript, it
    will look for fonts in $(TARGET_DIR), which doesn't exist on the
    target.

    Instead of /usr/share/fonts/gs, use /usr/share/fonts so ghostscript can
    also access other fonts than the ones installed by ghostscript-fonts.


 Can you double-check that commit a76eab228f0bde8597bb6431733e3e1a8d25f806 works
for you?

 Regards,
 Arnout

>         --enable-freetype \
>         --disable-gtk \
>         --without-jbig2dec \
> 
> 
> 
> 
> 
> --
> Sent from: http://buildroot-busybox.2317881.n4.nabble.com/
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
diff mbox series

Patch

--- a/package/ghostscript/ghostscript.mk
+++ b/package/ghostscript/ghostscript.mk
@@ -40,7 +40,7 @@ 
        --disable-compile-inits \
        --disable-cups \
        --enable-fontconfig \
-       --with-fontpath=$(GHOSTSCRIPT_FONTS_TARGET_DIR) \
+       --with-fontpath=/usr/share/fonts \
        --enable-freetype \
        --disable-gtk \
        --without-jbig2dec \