diff mbox series

[NEXT,04/26] cpe-info: only report target pkgs

Message ID 1519697441-54194-5-git-send-email-matthew.weber@rockwellcollins.com
State Changes Requested
Headers show
Series Package CVE Reporting | expand

Commit Message

Matt Weber Feb. 27, 2018, 2:10 a.m. UTC
The reporting of host packages causes some duplication
and complicates what is really in the targets configuration.
For the purpose of the first version of this patchset,
its assumed that host packages aren't relevant for the
configuration and we only report the target's contents.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
---
 package/pkg-generic.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni Feb. 27, 2018, 9:45 p.m. UTC | #1
Hello,

On Mon, 26 Feb 2018 20:10:19 -0600, Matt Weber wrote:

> +ifneq ($$($(2)_TYPE),host)

Why not:

ifeq ($$($(2)_TYPE),target)

>  $(1)-cpe-info: PKG=$(2)
>  $(1)-cpe-info:
>  ifneq ($$(call qstrip,$$($(2)_SOURCE)),)
> @@ -852,6 +853,7 @@ else
>  	$(Q)$$(foreach id,$$($(2)_CPE_ID),$$(call cpe-manifest,$$($(2)_CPE_PREFIX):$$(id):$(CPE_SUFFIX),$$($(2)_CVE_PATCHED),$$($(2)_RAWNAME),$$($(2)_VERSION),$$($(2)_ACTUAL_SOURCE_SITE))$$(sep))
>  endif # ifeq ($$(call qstrip,$$($(2)_CPE_ID)),)
>  endif # ifneq ($$(call qstrip,$$($(2)_SOURCE)),)
> +endif # ifeq ($$($(2)_TYPE),target)

... just like your endif comment shows ? :-)

Thomas
Matt Weber Feb. 28, 2018, 4:13 a.m. UTC | #2
Thomas,

On Tue, Feb 27, 2018 at 3:45 PM, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
> Hello,
>
> On Mon, 26 Feb 2018 20:10:19 -0600, Matt Weber wrote:
>
>> +ifneq ($$($(2)_TYPE),host)
>
> Why not:
>
> ifeq ($$($(2)_TYPE),target)
>

Will include in v2  :)

Matt
diff mbox series

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 8b80de7..21d62a5 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -842,6 +842,7 @@  else
 endif
 
 
+ifneq ($$($(2)_TYPE),host)
 $(1)-cpe-info: PKG=$(2)
 $(1)-cpe-info:
 ifneq ($$(call qstrip,$$($(2)_SOURCE)),)
@@ -852,6 +853,7 @@  else
 	$(Q)$$(foreach id,$$($(2)_CPE_ID),$$(call cpe-manifest,$$($(2)_CPE_PREFIX):$$(id):$(CPE_SUFFIX),$$($(2)_CVE_PATCHED),$$($(2)_RAWNAME),$$($(2)_VERSION),$$($(2)_ACTUAL_SOURCE_SITE))$$(sep))
 endif # ifeq ($$(call qstrip,$$($(2)_CPE_ID)),)
 endif # ifneq ($$(call qstrip,$$($(2)_SOURCE)),)
+endif # ifeq ($$($(2)_TYPE),target)
 
 # legal-info: declare dependencies and set values used later for the manifest
 ifneq ($$($(2)_LICENSE_FILES),)