diff mbox

[15/51] openssl: use $(TARGET_MAKE_ENV) when calling $(MAKE)

Message ID 1476396838-12276-16-git-send-email-gustavo.zacarias@free-electrons.com
State Accepted
Headers show

Commit Message

gustavo.zacarias@free-electrons.com Oct. 13, 2016, 10:13 p.m. UTC
From: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
---
 package/openssl/openssl.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Arnout Vandecappelle Oct. 14, 2016, 2:43 p.m. UTC | #1
On 14-10-16 00:13, gustavo.zacarias@free-electrons.com wrote:
> From: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
> 
> Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
> ---
>  package/openssl/openssl.mk | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
> index 6dc4b85..5f6267c 100644
> --- a/package/openssl/openssl.mk
> +++ b/package/openssl/openssl.mk
> @@ -106,11 +106,11 @@ define HOST_OPENSSL_BUILD_CMDS
>  endef

 Could you add a patch that does the same for host-openssl as well?

 Regards,
 Arnout

>  
>  define OPENSSL_BUILD_CMDS
> -	$(MAKE) -C $(@D)
> +	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
>  endef
>  
>  define OPENSSL_INSTALL_STAGING_CMDS
> -	$(MAKE) -C $(@D) INSTALL_PREFIX=$(STAGING_DIR) install
> +	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) INSTALL_PREFIX=$(STAGING_DIR) install
>  endef
>  
>  define HOST_OPENSSL_INSTALL_CMDS
> @@ -118,7 +118,7 @@ define HOST_OPENSSL_INSTALL_CMDS
>  endef
>  
>  define OPENSSL_INSTALL_TARGET_CMDS
> -	$(MAKE) -C $(@D) INSTALL_PREFIX=$(TARGET_DIR) install
> +	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) INSTALL_PREFIX=$(TARGET_DIR) install
>  	rm -rf $(TARGET_DIR)/usr/lib/ssl
>  	rm -f $(TARGET_DIR)/usr/bin/c_rehash
>  endef
>
diff mbox

Patch

diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 6dc4b85..5f6267c 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -106,11 +106,11 @@  define HOST_OPENSSL_BUILD_CMDS
 endef
 
 define OPENSSL_BUILD_CMDS
-	$(MAKE) -C $(@D)
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
 endef
 
 define OPENSSL_INSTALL_STAGING_CMDS
-	$(MAKE) -C $(@D) INSTALL_PREFIX=$(STAGING_DIR) install
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) INSTALL_PREFIX=$(STAGING_DIR) install
 endef
 
 define HOST_OPENSSL_INSTALL_CMDS
@@ -118,7 +118,7 @@  define HOST_OPENSSL_INSTALL_CMDS
 endef
 
 define OPENSSL_INSTALL_TARGET_CMDS
-	$(MAKE) -C $(@D) INSTALL_PREFIX=$(TARGET_DIR) install
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) INSTALL_PREFIX=$(TARGET_DIR) install
 	rm -rf $(TARGET_DIR)/usr/lib/ssl
 	rm -f $(TARGET_DIR)/usr/bin/c_rehash
 endef