diff mbox

[1/1] linux: arm: config endiness based on BR2 config

Message ID 1463474820-18073-1-git-send-email-oferh@marvell.com
State Superseded
Headers show

Commit Message

Ofer Heifetz May 17, 2016, 8:47 a.m. UTC
From: Ofer Heifetz <oferh@marvell.com>

By default linux ARM arch is implicit configured LE,
when BR2 is configured BE, modify the linux config to BE
for ARM arch.

Signed-off-by: Ofer Heifetz <oferh@marvell.com>
---
 linux/linux.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Arnout Vandecappelle May 17, 2016, 10:39 p.m. UTC | #1
On 05/17/16 10:47, oferh@marvell.com wrote:
> From: Ofer Heifetz <oferh@marvell.com>
>
> By default linux ARM arch is implicit configured LE,
> when BR2 is configured BE, modify the linux config to BE
> for ARM arch.
>
> Signed-off-by: Ofer Heifetz <oferh@marvell.com>
> ---
>  linux/linux.mk | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/linux/linux.mk b/linux/linux.mk
> index d88060e..71545e4 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -218,6 +218,8 @@ define LINUX_KCONFIG_FIXUP_CMDS
>  	)
>  	$(if $(BR2_arm)$(BR2_armeb),
>  		$(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config))
> +	$(if $(BR2_armeb)$(BR2_aarch64_be),
> +		$(call KCONFIG_ENABLE_OPT,CONFIG_CPU_BIG_ENDIAN,$(@D)/.config))

  Instead of doing this specifically for ARM, perhaps it's better to do this in 
general for all platforms? Something like (untested)

ifeq ($(BR2_ENDIAN),"BIG")
	$(call KCONFIG_ENABLE_OPT,CONFIG_CPU_BIG_ENDIAN,$(@D)/.config))
else
	$(call KCONFIG_ENABLE_OPT,CONFIG_CPU_LITTLE_ENDIAN,$(@D)/.config))
endif

  Even though not all arches support these options, it's harmless to add it for 
the ones which don't have them. The subsequent olddefconfig should just remove 
it again.

  Regards,
  Arnout

>  	$(if $(BR2_TARGET_ROOTFS_CPIO),
>  		$(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config))
>  	# As the kernel gets compiled before root filesystems are
>
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index d88060e..71545e4 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -218,6 +218,8 @@  define LINUX_KCONFIG_FIXUP_CMDS
 	)
 	$(if $(BR2_arm)$(BR2_armeb),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config))
+	$(if $(BR2_armeb)$(BR2_aarch64_be),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_CPU_BIG_ENDIAN,$(@D)/.config))
 	$(if $(BR2_TARGET_ROOTFS_CPIO),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config))
 	# As the kernel gets compiled before root filesystems are