diff mbox

[1/1] Raspberry PI 3 kernel, firmware and dtb update

Message ID 1459421492-18815-1-git-send-email-ubaldo@eja.it
State Superseded
Headers show

Commit Message

Ubaldo Porcheddu March 31, 2016, 10:51 a.m. UTC
Signed-off-by: Ubaldo Porcheddu <ubaldo@eja.it>
---
 board/raspberrypi/genimage-raspberrypi2.cfg | 1 +
 configs/raspberrypi2_defconfig              | 4 ++--
 package/rpi-firmware/rpi-firmware.mk        | 2 +-
 3 files changed, 4 insertions(+), 3 deletions(-)

Comments

Peter Korsgaard April 19, 2016, 8:45 p.m. UTC | #1
>>>>> "Ubaldo" == Ubaldo Porcheddu <ubaldo@eja.it> writes:

 > Signed-off-by: Ubaldo Porcheddu <ubaldo@eja.it>
 > ---
 >  board/raspberrypi/genimage-raspberrypi2.cfg | 1 +
 >  configs/raspberrypi2_defconfig              | 4 ++--
 >  package/rpi-firmware/rpi-firmware.mk        | 2 +-
 >  3 files changed, 4 insertions(+), 3 deletions(-)

Thanks for the patch, but can you instead split it up 2 seperate
patches (with sensible descriptions) - One bumping the rpi-firmware
version and one updating the rpi2 config to also support rpi3.

The rpi3 afaik uses a different serial port than rpi2. How will that
work if we use the same defconfig for both boards? Perhaps it makes more
sense to have a seperate raspberrypi3_defconfig?

- 
 > diff --git a/board/raspberrypi/genimage-raspberrypi2.cfg b/board/raspberrypi/genimage-raspberrypi2.cfg
 > index 443c821..453fb00 100644
 > --- a/board/raspberrypi/genimage-raspberrypi2.cfg
 > +++ b/board/raspberrypi/genimage-raspberrypi2.cfg
 > @@ -2,6 +2,7 @@ image boot.vfat {
 >    vfat {
 >      files = {
 >        "bcm2709-rpi-2-b.dtb",
 > +      "bcm2710-rpi-3-b.dtb",
 >        "rpi-firmware/bootcode.bin",
 >        "rpi-firmware/cmdline.txt",
 >        "rpi-firmware/config.txt",
 > diff --git a/configs/raspberrypi2_defconfig b/configs/raspberrypi2_defconfig
 > index ce41ee3..b77db14 100644
 > --- a/configs/raspberrypi2_defconfig
 > +++ b/configs/raspberrypi2_defconfig
 > @@ -13,13 +13,13 @@ BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_1=y
 >  BR2_LINUX_KERNEL=y
 >  BR2_LINUX_KERNEL_CUSTOM_GIT=y
 >  BR2_LINUX_KERNEL_CUSTOM_REPO_URL="https://github.com/raspberrypi/linux.git"
 > -BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="d33d0293e245badc4ca6ede3984d8bb8ea63cb1a"
 > +BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="20fe468af4bb40fec0f81753da4b20a8bfc259c9"
 >  BR2_LINUX_KERNEL_DEFCONFIG="bcm2709"
 >  BR2_LINUX_KERNEL_ZIMAGE=y
 
 >  # Build the DTB from the kernel sources
 >  BR2_LINUX_KERNEL_DTS_SUPPORT=y
 > -BR2_LINUX_KERNEL_INTREE_DTS_NAME="bcm2709-rpi-2-b"
 > +BR2_LINUX_KERNEL_INTREE_DTS_NAME="bcm2709-rpi-2-b bcm2710-rpi-3-b"
 
 >  BR2_PACKAGE_RPI_FIRMWARE=y
 >  # BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTB_OVERLAYS is not set
 > diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/rpi-firmware.mk
 > index 291da3a..8476678 100644
 > --- a/package/rpi-firmware/rpi-firmware.mk
 > +++ b/package/rpi-firmware/rpi-firmware.mk
 > @@ -4,7 +4,7 @@
 >  #
 >  ################################################################################
 
 > -RPI_FIRMWARE_VERSION = 8b4e5482b52e6fb438dddc0d88ba0ba8d44af54b
 > +RPI_FIRMWARE_VERSION = 951799bbcd795ddf27769d14acf4813fdcbe53dc
 >  RPI_FIRMWARE_SITE = $(call github,raspberrypi,firmware,$(RPI_FIRMWARE_VERSION))
 >  RPI_FIRMWARE_LICENSE = BSD-3c
 >  RPI_FIRMWARE_LICENSE_FILES = boot/LICENCE.broadcom
 > -- 
 > 1.9.1

 > _______________________________________________
 > buildroot mailing list
 > buildroot@busybox.net
 > http://lists.busybox.net/mailman/listinfo/buildroot
Yann E. MORIN April 19, 2016, 9:33 p.m. UTC | #2
Ubaldo, Peter, All,

On 2016-04-19 22:45 +0200, Peter Korsgaard spake thusly:
> >>>>> "Ubaldo" == Ubaldo Porcheddu <ubaldo@eja.it> writes:
> 
>  > Signed-off-by: Ubaldo Porcheddu <ubaldo@eja.it>
>  > ---
>  >  board/raspberrypi/genimage-raspberrypi2.cfg | 1 +
>  >  configs/raspberrypi2_defconfig              | 4 ++--
>  >  package/rpi-firmware/rpi-firmware.mk        | 2 +-
>  >  3 files changed, 4 insertions(+), 3 deletions(-)
> 
> Thanks for the patch, but can you instead split it up 2 seperate
> patches (with sensible descriptions) - One bumping the rpi-firmware
> version and one updating the rpi2 config to also support rpi3.
> 
> The rpi3 afaik uses a different serial port than rpi2. How will that
> work if we use the same defconfig for both boards? Perhaps it makes more
> sense to have a seperate raspberrypi3_defconfig?

Yes, expecially since the CPU is not the same, andthat we may^Wwill one
day have it run in 64-bit mode (one can dream, no?).

So yes, make it a separate defconfig, please.

Regards,
Yann E. MORIN.

>  > diff --git a/board/raspberrypi/genimage-raspberrypi2.cfg b/board/raspberrypi/genimage-raspberrypi2.cfg
>  > index 443c821..453fb00 100644
>  > --- a/board/raspberrypi/genimage-raspberrypi2.cfg
>  > +++ b/board/raspberrypi/genimage-raspberrypi2.cfg
>  > @@ -2,6 +2,7 @@ image boot.vfat {
>  >    vfat {
>  >      files = {
>  >        "bcm2709-rpi-2-b.dtb",
>  > +      "bcm2710-rpi-3-b.dtb",
>  >        "rpi-firmware/bootcode.bin",
>  >        "rpi-firmware/cmdline.txt",
>  >        "rpi-firmware/config.txt",
>  > diff --git a/configs/raspberrypi2_defconfig b/configs/raspberrypi2_defconfig
>  > index ce41ee3..b77db14 100644
>  > --- a/configs/raspberrypi2_defconfig
>  > +++ b/configs/raspberrypi2_defconfig
>  > @@ -13,13 +13,13 @@ BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_1=y
>  >  BR2_LINUX_KERNEL=y
>  >  BR2_LINUX_KERNEL_CUSTOM_GIT=y
>  >  BR2_LINUX_KERNEL_CUSTOM_REPO_URL="https://github.com/raspberrypi/linux.git"
>  > -BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="d33d0293e245badc4ca6ede3984d8bb8ea63cb1a"
>  > +BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="20fe468af4bb40fec0f81753da4b20a8bfc259c9"
>  >  BR2_LINUX_KERNEL_DEFCONFIG="bcm2709"
>  >  BR2_LINUX_KERNEL_ZIMAGE=y
>  
>  >  # Build the DTB from the kernel sources
>  >  BR2_LINUX_KERNEL_DTS_SUPPORT=y
>  > -BR2_LINUX_KERNEL_INTREE_DTS_NAME="bcm2709-rpi-2-b"
>  > +BR2_LINUX_KERNEL_INTREE_DTS_NAME="bcm2709-rpi-2-b bcm2710-rpi-3-b"
>  
>  >  BR2_PACKAGE_RPI_FIRMWARE=y
>  >  # BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTB_OVERLAYS is not set
>  > diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/rpi-firmware.mk
>  > index 291da3a..8476678 100644
>  > --- a/package/rpi-firmware/rpi-firmware.mk
>  > +++ b/package/rpi-firmware/rpi-firmware.mk
>  > @@ -4,7 +4,7 @@
>  >  #
>  >  ################################################################################
>  
>  > -RPI_FIRMWARE_VERSION = 8b4e5482b52e6fb438dddc0d88ba0ba8d44af54b
>  > +RPI_FIRMWARE_VERSION = 951799bbcd795ddf27769d14acf4813fdcbe53dc
>  >  RPI_FIRMWARE_SITE = $(call github,raspberrypi,firmware,$(RPI_FIRMWARE_VERSION))
>  >  RPI_FIRMWARE_LICENSE = BSD-3c
>  >  RPI_FIRMWARE_LICENSE_FILES = boot/LICENCE.broadcom
>  > -- 
>  > 1.9.1
> 
>  > _______________________________________________
>  > buildroot mailing list
>  > buildroot@busybox.net
>  > http://lists.busybox.net/mailman/listinfo/buildroot
> 
> 
> -- 
> Bye, Peter Korsgaard
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard April 20, 2016, 7:08 a.m. UTC | #3
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 >> The rpi3 afaik uses a different serial port than rpi2. How will that
 >> work if we use the same defconfig for both boards? Perhaps it makes more
 >> sense to have a seperate raspberrypi3_defconfig?

 > Yes, expecially since the CPU is not the same, andthat we may^Wwill one
 > day have it run in 64-bit mode (one can dream, no?).

Yeah. I don't know about the rpi foundation, but there seems to be quite
some aarch64 activity around it in mainline U-Boot/Linux.

With the recent vc4 work it might make sense to add rpi defconfigs using
mainline as well?
Ubaldo Porcheddu April 20, 2016, 8:37 a.m. UTC | #4
Hi,

Il 2016-04-20 08:08 Peter Korsgaard ha scritto:
>>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:
> 
>  >> The rpi3 afaik uses a different serial port than rpi2. How will 
> that
>  >> work if we use the same defconfig for both boards? Perhaps it makes 
> more
>  >> sense to have a seperate raspberrypi3_defconfig?
> 
>  > Yes, expecially since the CPU is not the same, andthat we may^Wwill 
> one
>  > day have it run in 64-bit mode (one can dream, no?).
> 
> Yeah. I don't know about the rpi foundation, but there seems to be 
> quite
> some aarch64 activity around it in mainline U-Boot/Linux.
> 
> With the recent vc4 work it might make sense to add rpi defconfigs 
> using
> mainline as well?

I am going to submit a patch right now with just the firmware upgrade 
and I will then try a separate rpi3 defconfig to start with.
Gustavo Zacarias April 20, 2016, 2:25 p.m. UTC | #5
On 20/04/16 04:08, Peter Korsgaard wrote:

> Yeah. I don't know about the rpi foundation, but there seems to be quite
> some aarch64 activity around it in mainline U-Boot/Linux.
>
> With the recent vc4 work it might make sense to add rpi defconfigs using
> mainline as well?

I have a WIP rpi2 open defconfig, however the kernel part eludes me a 
bit, plain vanilla doesn't seem ready for vc4 right away and i'm 
probably missing some patches/pull to complete enable it (symptom: oops).
I can share in private if anybody is interested in picking up/trying to fix.
Regards.
Peter Korsgaard April 23, 2016, 8:36 a.m. UTC | #6
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 > On 20/04/16 04:08, Peter Korsgaard wrote:
 >> Yeah. I don't know about the rpi foundation, but there seems to be quite
 >> some aarch64 activity around it in mainline U-Boot/Linux.
 >> 
 >> With the recent vc4 work it might make sense to add rpi defconfigs using
 >> mainline as well?

 > I have a WIP rpi2 open defconfig, however the kernel part eludes me a
 > bit, plain vanilla doesn't seem ready for vc4 right away and i'm
 > probably missing some patches/pull to complete enable it (symptom:
 > oops).
> I can share in private if anybody is interested in picking up/trying to fix.

Ok, thanks. I don't actually have rpi2, so I'll leave it until we have
something working.
Yann E. MORIN April 23, 2016, 4:53 p.m. UTC | #7
Ubaldo, All,

On 2016-04-20 09:08 +0200, Peter Korsgaard spake thusly:
> The rpi3 afaik uses a different serial port than rpi2. How will that
> work if we use the same defconfig for both boards? Perhaps it makes more
> sense to have a seperate raspberrypi3_defconfig?

BTW, the serial port that is available on the 40-pin header on RPi3 is
ttyS0 (I forgot to mention that previously; not sure it was figured out
yet, so better re-hash it just in case).

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/board/raspberrypi/genimage-raspberrypi2.cfg b/board/raspberrypi/genimage-raspberrypi2.cfg
index 443c821..453fb00 100644
--- a/board/raspberrypi/genimage-raspberrypi2.cfg
+++ b/board/raspberrypi/genimage-raspberrypi2.cfg
@@ -2,6 +2,7 @@  image boot.vfat {
   vfat {
     files = {
       "bcm2709-rpi-2-b.dtb",
+      "bcm2710-rpi-3-b.dtb",
       "rpi-firmware/bootcode.bin",
       "rpi-firmware/cmdline.txt",
       "rpi-firmware/config.txt",
diff --git a/configs/raspberrypi2_defconfig b/configs/raspberrypi2_defconfig
index ce41ee3..b77db14 100644
--- a/configs/raspberrypi2_defconfig
+++ b/configs/raspberrypi2_defconfig
@@ -13,13 +13,13 @@  BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_1=y
 BR2_LINUX_KERNEL=y
 BR2_LINUX_KERNEL_CUSTOM_GIT=y
 BR2_LINUX_KERNEL_CUSTOM_REPO_URL="https://github.com/raspberrypi/linux.git"
-BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="d33d0293e245badc4ca6ede3984d8bb8ea63cb1a"
+BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="20fe468af4bb40fec0f81753da4b20a8bfc259c9"
 BR2_LINUX_KERNEL_DEFCONFIG="bcm2709"
 BR2_LINUX_KERNEL_ZIMAGE=y
 
 # Build the DTB from the kernel sources
 BR2_LINUX_KERNEL_DTS_SUPPORT=y
-BR2_LINUX_KERNEL_INTREE_DTS_NAME="bcm2709-rpi-2-b"
+BR2_LINUX_KERNEL_INTREE_DTS_NAME="bcm2709-rpi-2-b bcm2710-rpi-3-b"
 
 BR2_PACKAGE_RPI_FIRMWARE=y
 # BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTB_OVERLAYS is not set
diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/rpi-firmware.mk
index 291da3a..8476678 100644
--- a/package/rpi-firmware/rpi-firmware.mk
+++ b/package/rpi-firmware/rpi-firmware.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-RPI_FIRMWARE_VERSION = 8b4e5482b52e6fb438dddc0d88ba0ba8d44af54b
+RPI_FIRMWARE_VERSION = 951799bbcd795ddf27769d14acf4813fdcbe53dc
 RPI_FIRMWARE_SITE = $(call github,raspberrypi,firmware,$(RPI_FIRMWARE_VERSION))
 RPI_FIRMWARE_LICENSE = BSD-3c
 RPI_FIRMWARE_LICENSE_FILES = boot/LICENCE.broadcom