diff mbox

[v2] linux-firmware: Update bnx2x firwmare version

Message ID 1456805852-11045-1-git-send-email-joel@jms.id.au
State Changes Requested
Headers show

Commit Message

Joel Stanley March 1, 2016, 4:17 a.m. UTC
Linux kernel 4.2 moved the driver to a newer firmware version. As that
is our default kernel, move the firmeware to a compatable version.

Signed-off-by: Joel Stanley <joel@jms.id.au>
---
v2: Just use the new firmware to avoid adding extra cruft to our config system

 package/linux-firmware/linux-firmware.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Arnout Vandecappelle March 1, 2016, 9:17 p.m. UTC | #1
On 03/01/16 05:17, Joel Stanley wrote:
> Linux kernel 4.2 moved the driver to a newer firmware version. As that
> is our default kernel, move the firmeware to a compatable version.
> 
> Signed-off-by: Joel Stanley <joel@jms.id.au>
> ---
> v2: Just use the new firmware to avoid adding extra cruft to our config system

 No, this is certainly not good, it fixes 4.2+ and simultaneously breaks 4.1-.

 What is wrong with Thomas's proposal to remove the unneeded versions in a
post-build script? If your size is so important that 640K matters, you would
probably anyway want to keep only one of the six binaries instead of three
different chip revisions.

 Regards,
 Arnout

> 
>  package/linux-firmware/linux-firmware.mk | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/linux-firmware/linux-firmware.mk b/package/linux-firmware/linux-firmware.mk
> index 083a381ea00a..9363099b68fd 100644
> --- a/package/linux-firmware/linux-firmware.mk
> +++ b/package/linux-firmware/linux-firmware.mk
> @@ -253,9 +253,9 @@ endif
>  
>  ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_BNX2X),y)
>  LINUX_FIRMWARE_FILES += \
> -	bnx2x/bnx2x-e1-7.10.51.0.fw \
> -	bnx2x/bnx2x-e1h-7.10.51.0.fw \
> -	bnx2x/bnx2x-e2-7.10.51.0.fw
> +	bnx2x/bnx2x-e1-7.12.30.0.fw \
> +	bnx2x/bnx2x-e1h-7.12.30.0.fw \
> +	bnx2x/bnx2x-e2-7.12.30.0.fw
>  # No license file; the license is in the file WHENCE
>  # which is installed unconditionally
>  endif
>
Joel Stanley March 3, 2016, 7:06 a.m. UTC | #2
On Wed, Mar 2, 2016 at 7:47 AM, Arnout Vandecappelle <arnout@mind.be> wrote:
> On 03/01/16 05:17, Joel Stanley wrote:
>> Linux kernel 4.2 moved the driver to a newer firmware version. As that
>> is our default kernel, move the firmeware to a compatable version.
>>
>> Signed-off-by: Joel Stanley <joel@jms.id.au>
>> ---
>> v2: Just use the new firmware to avoid adding extra cruft to our config system
>
>  No, this is certainly not good, it fixes 4.2+ and simultaneously breaks 4.1-.

We currently exist in a situation where 4.2+ has always been broken,
as is anything below 3.18.

The current default version of the kernel is 4.4, so this change
ensures that the kernel will work for this device with buildroot.

>  What is wrong with Thomas's proposal to remove the unneeded versions in a
> post-build script?

This requires users of buildroot to be aware of the situation and
carry local configuration. I think this is less desirable than to work
out of the box.

From our project's perspective, it's easier to patch the
linux-firmware package to only copy the version we want.

> If your size is so important that 640K matters, you would
> probably anyway want to keep only one of the six binaries instead of three
> different chip revisions.

Good point. Thanks
diff mbox

Patch

diff --git a/package/linux-firmware/linux-firmware.mk b/package/linux-firmware/linux-firmware.mk
index 083a381ea00a..9363099b68fd 100644
--- a/package/linux-firmware/linux-firmware.mk
+++ b/package/linux-firmware/linux-firmware.mk
@@ -253,9 +253,9 @@  endif
 
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_BNX2X),y)
 LINUX_FIRMWARE_FILES += \
-	bnx2x/bnx2x-e1-7.10.51.0.fw \
-	bnx2x/bnx2x-e1h-7.10.51.0.fw \
-	bnx2x/bnx2x-e2-7.10.51.0.fw
+	bnx2x/bnx2x-e1-7.12.30.0.fw \
+	bnx2x/bnx2x-e1h-7.12.30.0.fw \
+	bnx2x/bnx2x-e2-7.12.30.0.fw
 # No license file; the license is in the file WHENCE
 # which is installed unconditionally
 endif