diff mbox

[v3] sdl: overwrite libpth autodetection

Message ID 1447969367-21983-1-git-send-email-ps.report@gmx.net
State Accepted
Commit 508bb46bade489ca9eeff6e681548e7ba97f4330
Headers show

Commit Message

Peter Seiderer Nov. 19, 2015, 9:42 p.m. UTC
The sdl libpth autodetection gets confused in case a host
version is present. Overwrite libpth autodection for the
target build dependent on BR2_PACKAGE_LIBPTHSEM_COMPAT and
use pth-config from staging directory.

Fixes [1]:

checking for pthreads... no
checking for pth-config... /usr/bin/pth-config
checking pth... yes
[...]
./src/SDL.c:33:17: fatal error: pth.h: No such file or directory
 #include <pth.h>

[1] http://autobuild.buildroot.net/results/733/73330e51b3c099d179004db0b9522ac13358b8f7

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
Changes v2 -> v3:
  - simplify libpth enable logic, check on BR2_PACKAGE_LIBPTHSEM_COMPAT is enough
   (suggested by Baruch Siach)

Changes v1 -> v2:
  - add SDL_DEPENDENCIES += libpthsem (suggested by Baruch Siach)
  - fix libpth enable logic, needs BR2_PACKAGE_LIBPTHSEM and BR2_PACKAGE_LIBPTHSEM_COMPAT
  - overwrite ac_cv_path_PTH_CONFIG to use the right pth-config from
    staging dir
---
 package/sdl/sdl.mk | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Peter Korsgaard Nov. 19, 2015, 10:05 p.m. UTC | #1
>>>>> "Peter" == Peter Seiderer <ps.report@gmx.net> writes:

 > The sdl libpth autodetection gets confused in case a host
 > version is present. Overwrite libpth autodection for the
 > target build dependent on BR2_PACKAGE_LIBPTHSEM_COMPAT and
 > use pth-config from staging directory.

 > Fixes [1]:

 > checking for pthreads... no
 > checking for pth-config... /usr/bin/pth-config
 > checking pth... yes
 > [...]
 > ./src/SDL.c:33:17: fatal error: pth.h: No such file or directory
 >  #include <pth.h>

 > [1] http://autobuild.buildroot.net/results/733/73330e51b3c099d179004db0b9522ac13358b8f7

 > Signed-off-by: Peter Seiderer <ps.report@gmx.net>
 > ---
 > Changes v2 -> v3:
 >   - simplify libpth enable logic, check on BR2_PACKAGE_LIBPTHSEM_COMPAT is enough
 >    (suggested by Baruch Siach)

Committed, thanks.
Arnout Vandecappelle Nov. 20, 2015, 10:43 p.m. UTC | #2
On 19-11-15 22:42, Peter Seiderer wrote:
> The sdl libpth autodetection gets confused in case a host
> version is present. Overwrite libpth autodection for the

 For future reference: it's override, not overwrite. You could say "overwrite"
if you had a patch that fixes the autodetection, but you want to say that you
force it not to use autodetection.

 Regards,
 Arnout

> target build dependent on BR2_PACKAGE_LIBPTHSEM_COMPAT and
> use pth-config from staging directory.
diff mbox

Patch

diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
index 78eb4dd..cc1ad06 100644
--- a/package/sdl/sdl.mk
+++ b/package/sdl/sdl.mk
@@ -58,6 +58,15 @@  ifneq ($(BR2_USE_MMU),y)
 SDL_CONF_OPTS += --enable-dga=no
 endif
 
+# overwrite autodection (prevents confusion with host libpth version)
+ifeq ($(BR2_PACKAGE_LIBPTHSEM_COMPAT),y)
+SDL_CONF_OPTS += --enable-pth
+SDL_CONF_ENV += ac_cv_path_PTH_CONFIG=$(STAGING_DIR)/usr/bin/pth-config
+SDL_DEPENDENCIES += libpthsem
+else
+SDL_CONF_OPTS += --disable-pth
+endif
+
 ifeq ($(BR2_PACKAGE_TSLIB),y)
 SDL_DEPENDENCIES += tslib
 endif