diff mbox

package/minidlna: fix static build

Message ID 1447889466-8504-1-git-send-email-yann.morin.1998@free.fr
State Accepted
Commit de5bfeac56da3a49fadad9c60898bea4fadf54dd
Headers show

Commit Message

Yann E. MORIN Nov. 18, 2015, 11:31 p.m. UTC
libvorbix.pc does not exist, it is named vorbis.pc.
Also, sqlite3 was missing when querying pkg-config.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/minidlna/minidlna.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Nov. 19, 2015, 9:52 a.m. UTC | #1
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > libvorbix.pc does not exist, it is named vorbis.pc.

libvorbis.pc

> Also, sqlite3 was missing when querying pkg-config.

No autobuilder references?

Committed, thanks.
Peter Korsgaard Nov. 19, 2015, 10 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:
 >> libvorbix.pc does not exist, it is named vorbis.pc.

 > libvorbis.pc

 >> Also, sqlite3 was missing when querying pkg-config.

 > No autobuilder references?

Looking at the autobuilder failures
(http://autobuild.buildroot.net/?reason=minidlna-1.1.5) they all seem to
be caused by BR2_COMPILER_PARANOID_UNSAFE_PATH and the configure script
adding /usr/local when checking for libraries/headers :/
Yann E. MORIN Nov. 19, 2015, 11:09 a.m. UTC | #3
On November 19, 2015 11:00:13 AM GMT+01:00, Peter Korsgaard <peter@korsgaard.com> wrote:
>>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:
>
>>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:
> >> libvorbix.pc does not exist, it is named vorbis.pc.
>
> > libvorbis.pc
>
> >> Also, sqlite3 was missing when querying pkg-config.
>
> > No autobuilder references?
>
>Looking at the autobuilder failures
>(http://autobuild.buildroot.net/?reason=minidlna-1.1.5) they all seem
>to
>be caused by BR2_COMPILER_PARANOID_UNSAFE_PATH and the configure script
>adding /usr/local when checking for libraries/headers :/
>
>-- 
>Bye, Peter Korsgaard
>_______________________________________________
>buildroot mailing list
>buildroot@busybox.net
>http://lists.busybox.net/mailman/listinfo/buildroot

Peter,

If you look earlier in the config.log,
you'll see the actual errors.

Looking at configure.ac, it becomes
obvious why that happens:

for l in "" /usr/lib ... do ...

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/minidlna/minidlna.mk b/package/minidlna/minidlna.mk
index e9df92b..e00fa09 100644
--- a/package/minidlna/minidlna.mk
+++ b/package/minidlna/minidlna.mk
@@ -17,7 +17,8 @@  MINIDLNA_DEPENDENCIES = \
 ifeq ($(BR2_STATIC_LIBS),y)
 # the configure script / Makefile forgets to link with some of the dependent
 # libraries breaking static linking, so help it along
-MINIDLNA_STATIC_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libavcodec libexif libvorbis`
+MINIDLNA_PKGCONFIG_DEPS = libavcodec libexif vorbis sqlite3
+MINIDLNA_STATIC_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs $(MINIDLNA_PKGCONFIG_DEPS)`
 MINIDLNA_STATIC_LIBS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)
 MINIDLNA_CONF_ENV += LIBS="$(MINIDLNA_STATIC_LIBS)"
 else