diff mbox

[v2] rfkill: new package

Message ID 1445950874-9848-1-git-send-email-sv99@inbox.ru
State Superseded
Headers show

Commit Message

Volkov Viacheslav Oct. 27, 2015, 1:01 p.m. UTC
Add rfkill package.

Signed-off-by: Viacheslav Volkov <sv99@inbox.ru>
---
 package/Config.in          |  1 +
 package/rfkill/Config.in   |  7 +++++++
 package/rfkill/rfkill.hash |  2 ++
 package/rfkill/rfkill.mk   | 20 ++++++++++++++++++++
 4 files changed, 30 insertions(+)
 create mode 100644 package/rfkill/Config.in
 create mode 100644 package/rfkill/rfkill.hash
 create mode 100644 package/rfkill/rfkill.mk

Comments

Vicente Olivert Riera Oct. 27, 2015, 1:47 p.m. UTC | #1
Dear Viacheslav Volkov,

your patch now looks much better. I have some comments about minor details.

The first one, you didn't marked your previous patch as superseded in
Patchwork.

On 10/27/2015 01:01 PM, Viacheslav Volkov wrote:
> Add rfkill package.
> 
> Signed-off-by: Viacheslav Volkov <sv99@inbox.ru>
> ---
I was expecting a changelog here. Please read:

http://buildroot.org/manual.html#submitting-patches

Scroll down until "21.5.2. Patch revision changelog".

>  package/Config.in          |  1 +
>  package/rfkill/Config.in   |  7 +++++++
>  package/rfkill/rfkill.hash |  2 ++
>  package/rfkill/rfkill.mk   | 20 ++++++++++++++++++++
>  4 files changed, 30 insertions(+)
>  create mode 100644 package/rfkill/Config.in
>  create mode 100644 package/rfkill/rfkill.hash
>  create mode 100644 package/rfkill/rfkill.mk
> 
> diff --git a/package/Config.in b/package/Config.in
> index 10ff94e..9933514 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -403,6 +403,7 @@ endif
>  	source "package/pps-tools/Config.in"
>  	source "package/pulseview/Config.in"
>  	source "package/read-edid/Config.in"
> +	source "package/rfkill/Config.in"
>  	source "package/rng-tools/Config.in"
>  	source "package/rpi-userland/Config.in"
>  	source "package/rtl8188eu/Config.in"
> diff --git a/package/rfkill/Config.in b/package/rfkill/Config.in
> new file mode 100644
> index 0000000..b7a676e
> --- /dev/null
> +++ b/package/rfkill/Config.in
> @@ -0,0 +1,7 @@
> +config BR2_PACKAGE_RFKILL
> +	bool "rfkill"
> +	help
> +	  rfkill is a small userspace tool to query the state of the rfkill

That line is not wrapped to 72 characters length if we consider the tab
as 8 characters wide. The trailing "rfkill" word should be placed in the
next line.

> +	  switches.
> +
> +	  https://wireless.wiki.kernel.org/en/users/documentation/rfkill

Add a trailing slash (/) to that URL.

Regards,

Vincent.
Vicente Olivert Riera Oct. 27, 2015, 1:55 p.m. UTC | #2
Dear Viacheslav Volkov,

On 10/27/2015 01:47 PM, Vicente Olivert Riera wrote:
>> +	  https://wireless.wiki.kernel.org/en/users/documentation/rfkill
> 
> Add a trailing slash (/) to that URL.

Ignore that one.

Sorry,

Vincent.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 10ff94e..9933514 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -403,6 +403,7 @@  endif
 	source "package/pps-tools/Config.in"
 	source "package/pulseview/Config.in"
 	source "package/read-edid/Config.in"
+	source "package/rfkill/Config.in"
 	source "package/rng-tools/Config.in"
 	source "package/rpi-userland/Config.in"
 	source "package/rtl8188eu/Config.in"
diff --git a/package/rfkill/Config.in b/package/rfkill/Config.in
new file mode 100644
index 0000000..b7a676e
--- /dev/null
+++ b/package/rfkill/Config.in
@@ -0,0 +1,7 @@ 
+config BR2_PACKAGE_RFKILL
+	bool "rfkill"
+	help
+	  rfkill is a small userspace tool to query the state of the rfkill
+	  switches.
+
+	  https://wireless.wiki.kernel.org/en/users/documentation/rfkill
diff --git a/package/rfkill/rfkill.hash b/package/rfkill/rfkill.hash
new file mode 100644
index 0000000..21be0a2
--- /dev/null
+++ b/package/rfkill/rfkill.hash
@@ -0,0 +1,2 @@ 
+# From: https://www.kernel.org/pub/software/network/rfkill/sha256sums.asc
+sha256	e0ae3004215e39a6c5c36e0726558740728d16f67ebdb8bea621250f6091d86a  rfkill-0.5.tar.xz
diff --git a/package/rfkill/rfkill.mk b/package/rfkill/rfkill.mk
new file mode 100644
index 0000000..b377c03
--- /dev/null
+++ b/package/rfkill/rfkill.mk
@@ -0,0 +1,20 @@ 
+################################################################################
+#
+# rfkill
+#
+################################################################################
+
+RFKILL_VERSION = 0.5
+RFKILL_SOURCE = rfkill-$(RFKILL_VERSION).tar.xz
+RFKILL_SITE = https://www.kernel.org/pub/software/network/rfkill
+
+define RFKILL_BUILD_CMDS
+	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+		VERSION_SUFFIX="-br"
+endef
+
+define RFKILL_INSTALL_TARGET_CMDS
+	$(INSTALL) -D -m 755 $(@D)/rfkill $(TARGET_DIR)/usr/bin/rfkill
+endef
+
+$(eval $(generic-package))