diff mbox

[v2] Makefile: Remove 'quiet' variable

Message ID 1444334617-23796-1-git-send-email-cedric.marie@openmailbox.org
State Accepted
Commit 474d39a1ffad52618e2d1f0afcd527a5aadd5ec1
Headers show

Commit Message

Cédric Marie Oct. 8, 2015, 8:03 p.m. UTC
'quiet' variable is set and exported, but it is not used. We can safely
remove it.

This variable is inherited from the Makefile of the Linux kernel, and
is not used in Buildroot.

In support/scripts/mkmakefile, 'quiet' value is checked, but the test
is always true ('quiet' is never set to silent_), so the test can be
removed as well.

Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>

---
Changes v1 -> v2:
  - KBUILD_VERBOSE must not be removed, it is used for packages based
    on Kbuild.

Title of PATCH v1 was:
Makefile: Remove KBUILD_VERBOSE and quiet

In order to describe how the verbosity level is managed in different
infrastructures, comments will be added in Makefile (suggested by Arnout).
It will be provided in a separate patch.

Arnout also suggested not to export 'Q', which seems to be Buildroot
internal. This will also be provided in a separate patch, if confirmed.
---
 Makefile                   | 4 +---
 support/scripts/mkmakefile | 4 +---
 2 files changed, 2 insertions(+), 6 deletions(-)

Comments

James Knight Oct. 27, 2015, 4:52 a.m. UTC | #1
On Thu, Oct 8, 2015 at 4:03 PM, Cédric Marie
<cedric.marie@openmailbox.org> wrote:
> 'quiet' variable is set and exported, but it is not used. We can safely
> remove it.
>
> This variable is inherited from the Makefile of the Linux kernel, and
> is not used in Buildroot.
>
> In support/scripts/mkmakefile, 'quiet' value is checked, but the test
> is always true ('quiet' is never set to silent_), so the test can be
> removed as well.
>
> Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>

Reviewed-by: "James Knight" <james.d.knight@live.com>
Arnout Vandecappelle Oct. 28, 2015, 9 p.m. UTC | #2
On 08-10-15 22:03, Cédric Marie wrote:
> 'quiet' variable is set and exported, but it is not used. We can safely
> remove it.
> 
> This variable is inherited from the Makefile of the Linux kernel, and
> is not used in Buildroot.
> 
> In support/scripts/mkmakefile, 'quiet' value is checked, but the test
> is always true ('quiet' is never set to silent_), so the test can be
> removed as well.
> 
> Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>

Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Regards,
 Arnout

> 
> ---
> Changes v1 -> v2:
>   - KBUILD_VERBOSE must not be removed, it is used for packages based
>     on Kbuild.
> 
> Title of PATCH v1 was:
> Makefile: Remove KBUILD_VERBOSE and quiet
> 
> In order to describe how the verbosity level is managed in different
> infrastructures, comments will be added in Makefile (suggested by Arnout).
> It will be provided in a separate patch.
> 
> Arnout also suggested not to export 'Q', which seems to be Buildroot
> internal. This will also be provided in a separate patch, if confirmed.
> ---
>  Makefile                   | 4 +---
>  support/scripts/mkmakefile | 4 +---
>  2 files changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/Makefile b/Makefile
> index 181d446..470ea65 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -226,14 +226,12 @@ ifndef KBUILD_VERBOSE
>  endif
>  
>  ifeq ($(KBUILD_VERBOSE),1)
> -  quiet =
>    Q =
>  ifndef VERBOSE
>    VERBOSE = 1
>  endif
>  export VERBOSE
>  else
> -  quiet = quiet_
>    Q = @
>  endif
>  
> @@ -245,7 +243,7 @@ SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
>  # kconfig uses CONFIG_SHELL
>  CONFIG_SHELL := $(SHELL)
>  
> -export SHELL CONFIG_SHELL quiet Q KBUILD_VERBOSE
> +export SHELL CONFIG_SHELL Q KBUILD_VERBOSE
>  
>  ifndef HOSTAR
>  HOSTAR := ar
> diff --git a/support/scripts/mkmakefile b/support/scripts/mkmakefile
> index 833be6a..37162a3 100755
> --- a/support/scripts/mkmakefile
> +++ b/support/scripts/mkmakefile
> @@ -15,9 +15,7 @@ if test -e $2/Makefile && ! grep -q Automatically $2/Makefile
>  then
>  	exit 0
>  fi
> -if [ "${quiet}" != "silent_" ]; then
> -	echo "  GEN     $2/Makefile"
> -fi
> +echo "  GEN     $2/Makefile"
>  
>  cat << EOF > $2/Makefile
>  # Automatically generated by $0: don't edit
>
Peter Korsgaard Oct. 28, 2015, 11:05 p.m. UTC | #3
>>>>> "Cédric" == Cédric Marie <cedric.marie@openmailbox.org> writes:

 > 'quiet' variable is set and exported, but it is not used. We can safely
 > remove it.

 > This variable is inherited from the Makefile of the Linux kernel, and
 > is not used in Buildroot.

 > In support/scripts/mkmakefile, 'quiet' value is checked, but the test
 > is always true ('quiet' is never set to silent_), so the test can be
 > removed as well.

 > Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>

 > ---
 > Changes v1 -> v2:
 >   - KBUILD_VERBOSE must not be removed, it is used for packages based
 >     on Kbuild.

 > Title of PATCH v1 was:
 > Makefile: Remove KBUILD_VERBOSE and quiet

 > In order to describe how the verbosity level is managed in different
 > infrastructures, comments will be added in Makefile (suggested by Arnout).
 > It will be provided in a separate patch.

 > Arnout also suggested not to export 'Q', which seems to be Buildroot
 > internal. This will also be provided in a separate patch, if confirmed.

Committed, thanks.
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 181d446..470ea65 100644
--- a/Makefile
+++ b/Makefile
@@ -226,14 +226,12 @@  ifndef KBUILD_VERBOSE
 endif
 
 ifeq ($(KBUILD_VERBOSE),1)
-  quiet =
   Q =
 ifndef VERBOSE
   VERBOSE = 1
 endif
 export VERBOSE
 else
-  quiet = quiet_
   Q = @
 endif
 
@@ -245,7 +243,7 @@  SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
 # kconfig uses CONFIG_SHELL
 CONFIG_SHELL := $(SHELL)
 
-export SHELL CONFIG_SHELL quiet Q KBUILD_VERBOSE
+export SHELL CONFIG_SHELL Q KBUILD_VERBOSE
 
 ifndef HOSTAR
 HOSTAR := ar
diff --git a/support/scripts/mkmakefile b/support/scripts/mkmakefile
index 833be6a..37162a3 100755
--- a/support/scripts/mkmakefile
+++ b/support/scripts/mkmakefile
@@ -15,9 +15,7 @@  if test -e $2/Makefile && ! grep -q Automatically $2/Makefile
 then
 	exit 0
 fi
-if [ "${quiet}" != "silent_" ]; then
-	echo "  GEN     $2/Makefile"
-fi
+echo "  GEN     $2/Makefile"
 
 cat << EOF > $2/Makefile
 # Automatically generated by $0: don't edit