diff mbox

[1/1] package/nodejs: Add node.js v4.1.2

Message ID 1444136239-22044-1-git-send-email-jaap@jcz.nl
State Superseded
Headers show

Commit Message

Jaap Crezee Oct. 6, 2015, 12:57 p.m. UTC
Signed-off-by: Jaap Crezee <jaap@jcz.nl>
---
 ...01-Remove-dependency-on-Python-bz2-module.patch | 31 ++++++++++++++++++++++
 package/nodejs/Config.in                           |  5 ++++
 package/nodejs/nodejs.hash                         |  3 +++
 3 files changed, 39 insertions(+)
 create mode 100644 package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch

Comments

Peter Korsgaard Oct. 7, 2015, 8:20 a.m. UTC | #1
>>>>> "Jaap" == Jaap Crezee <jaap@jcz.nl> writes:

 > Signed-off-by: Jaap Crezee <jaap@jcz.nl>
 > ---
 >  ...01-Remove-dependency-on-Python-bz2-module.patch | 31 ++++++++++++++++++++++
 >  package/nodejs/Config.in                           |  5 ++++
 >  package/nodejs/nodejs.hash                         |  3 +++
 >  3 files changed, 39 insertions(+)
 >  create mode 100644 package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch

 > +++ b/package/nodejs/Config.in
 > @@ -40,12 +40,17 @@ config BR2_BR2_PACKAGE_NODEJS_0_12_X
 >  	bool "v0.12.7"
 >  	depends on !BR2_ARM_CPU_ARMV5
 
 > +config BR2_BR2_PACKAGE_NODEJS_4_1_X
 > +	bool "v4.1.2"
 > +	depends on !BR2_ARM_CPU_ARMV5
 > +
 >  endchoice
 
 >  config BR2_PACKAGE_NODEJS_VERSION_STRING
 >  	string
 >  	default "0.10.40"	if BR2_BR2_PACKAGE_NODEJS_0_10_X
 >  	default "0.12.7"	if BR2_BR2_PACKAGE_NODEJS_0_12_X
 > +	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X

Is there a need to keep both 0.12.x and 4.1.x? The only reason we have a
version selection is afaik that <ARMv7 is only supported in the old
0.10.x version.
Jaap Crezee Oct. 7, 2015, 12:26 p.m. UTC | #2
Hi Peter,

On 10/07/15 10:20, Peter Korsgaard wrote:
>>>>>> "Jaap" == Jaap Crezee <jaap@jcz.nl> writes:
>  >  config BR2_PACKAGE_NODEJS_VERSION_STRING
>  >  	string
>  >  	default "0.10.40"	if BR2_BR2_PACKAGE_NODEJS_0_10_X
>  >  	default "0.12.7"	if BR2_BR2_PACKAGE_NODEJS_0_12_X
>  > +	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X
> 
> Is there a need to keep both 0.12.x and 4.1.x? The only reason we have a
> version selection is afaik that <ARMv7 is only supported in the old
> 0.10.x version.

Well not from my side. Our project just needs 4.x and I didn't want to break other users
who might still be depending on 0.12.x. I am not sure about downwards compatibility of 4.x.


regards,

Jaap Crezee
Jörg Krause Oct. 7, 2015, 10:04 p.m. UTC | #3
Dear Peter Korsgaard,

On Mi, 2015-10-07 at 10:20 +0200, Peter Korsgaard wrote:
> > > > > > "Jaap" == Jaap Crezee <jaap@jcz.nl> writes:
> 
>  > Signed-off-by: Jaap Crezee <jaap@jcz.nl>
>  > ---
>  >  ...01-Remove-dependency-on-Python-bz2-module.patch | 31
> ++++++++++++++++++++++
>  >  package/nodejs/Config.in                           |  5 ++++
>  >  package/nodejs/nodejs.hash                         |  3 +++
>  >  3 files changed, 39 insertions(+)
>  >  create mode 100644 package/nodejs/4.1.2/0001-Remove-dependency-on
> -Python-bz2-module.patch
> 
>  > +++ b/package/nodejs/Config.in
>  > @@ -40,12 +40,17 @@ config BR2_BR2_PACKAGE_NODEJS_0_12_X
>  >  	bool "v0.12.7"
>  >  	depends on !BR2_ARM_CPU_ARMV5
>  
>  > +config BR2_BR2_PACKAGE_NODEJS_4_1_X
>  > +	bool "v4.1.2"
>  > +	depends on !BR2_ARM_CPU_ARMV5
>  > +
>  >  endchoice
>  
>  >  config BR2_PACKAGE_NODEJS_VERSION_STRING
>  >  	string
>  >  	default "0.10.40"	if BR2_BR2_PACKAGE_NODEJS_0_10_X
>  >  	default "0.12.7"	if BR2_BR2_PACKAGE_NODEJS_0_12_X
>  > +	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X
> 
> Is there a need to keep both 0.12.x and 4.1.x? The only reason we
> have a
> version selection is afaik that <ARMv7 is only supported in the old
> 0.10.x version.
> 

Yes, there is! Node.js applications written for Node.js 0.12.x are not
necessarily compatible with Node.js 4.x.

Best regards
Jörg Krause
Jörg Krause Oct. 7, 2015, 10:44 p.m. UTC | #4
Dear Jaap Crezee,

On Di, 2015-10-06 at 14:57 +0200, Jaap Crezee wrote:
> Signed-off-by: Jaap Crezee <jaap@jcz.nl>
> ---
>  ...01-Remove-dependency-on-Python-bz2-module.patch | 31
> ++++++++++++++++++++++
>  package/nodejs/Config.in                           |  5 ++++
>  package/nodejs/nodejs.hash                         |  3 +++
>  3 files changed, 39 insertions(+)
>  create mode 100644 package/nodejs/4.1.2/0001-Remove-dependency-on
> -Python-bz2-module.patch
> 
> diff --git a/package/nodejs/4.1.2/0001-Remove-dependency-on-Python
> -bz2-module.patch b/package/nodejs/4.1.2/0001-Remove-dependency-on
> -Python-bz2-module.patch
> new file mode 100644
> index 0000000..de83d44
> --- /dev/null
> +++ b/package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2
> -module.patch
> @@ -0,0 +1,31 @@
> +From 3d4817c152d6f3afddcc699949c4d1664da91e2b Mon Sep 17 00:00:00
> 2001
> +From: Martin Bark <martin@barkynet.com>
> +Date: Tue, 30 Jun 2015 09:43:11 +0100
> +Subject: [PATCH 1/4] Remove dependency on Python bz2 module
> +
> +The Python bz2 module is only needed in certain cases, so only
> import
> +it when needed. In the normal nodejs build, this allows to remove
> the
> +dependency on this module.
> +
> +Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com
> >
> +[Martin: adapt to 0.12.5]
> +Signed-off-by: Martin Bark <martin@barkynet.com>
> +---
> + deps/v8/tools/js2c.py | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/deps/v8/tools/js2c.py b/deps/v8/tools/js2c.py
> +index 77485f6..371caf5 100755
> +--- a/deps/v8/tools/js2c.py
> ++++ b/deps/v8/tools/js2c.py
> +@@ -34,7 +34,6 @@
> + import os, re, sys, string
> + import optparse
> + import jsmin
> +-import bz2
> + import textwrap
> + 
> + 
> +-- 
> +2.1.4
> +
> diff --git a/package/nodejs/Config.in b/package/nodejs/Config.in
> index 329d270..b25375b 100644
> --- a/package/nodejs/Config.in
> +++ b/package/nodejs/Config.in
> @@ -40,12 +40,17 @@ config BR2_BR2_PACKAGE_NODEJS_0_12_X
>  	bool "v0.12.7"
>  	depends on !BR2_ARM_CPU_ARMV5
>  
> +config BR2_BR2_PACKAGE_NODEJS_4_1_X
> +	bool "v4.1.2"
> +	depends on !BR2_ARM_CPU_ARMV5
> +
>  endchoice
>  
>  config BR2_PACKAGE_NODEJS_VERSION_STRING
>  	string
>  	default "0.10.40"	if BR2_BR2_PACKAGE_NODEJS_0_10_X
>  	default "0.12.7"	if BR2_BR2_PACKAGE_NODEJS_0_12_X
> +	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X
>  
>  menu "Module Selection"
>  
> diff --git a/package/nodejs/nodejs.hash b/package/nodejs/nodejs.hash
> index 9be2806..9f75471 100644
> --- a/package/nodejs/nodejs.hash
> +++ b/package/nodejs/nodejs.hash
> @@ -3,3 +3,6 @@ sha256	bae79c2fd959aebe1629af36077bebbb760128d
> b753da226d2344cd91499149f  node-v0
>  
>  # From upstream URL: http://nodejs.org/dist/v0.12.7/SHASUMS256.txt
>  sha256	b23d64df051c9c969b0c583f802d5d71de342e53067127a5061415
> be7e12f39d  node-v0.12.7.tar.gz
> +
> +# From upstream URL: http://nodejs.org/dist/v4.1.2/SHASUMS256.txt
> +sha256	febec3703a3fea9b64c46100a7b6a4408250027aa8259a2a815fd2
> 275d502c49  node-v4.1.2.tar.gz

No need for patch #2 and #3 from 0.12.x?

Additionally, this package does not compile with the Sourcery CodeBench
x86/x86_64 2012.09 toolchain:

    In file included from ../src/js_stream.h:6:0,
                     from ../src/js_stream.cc:1:
    ../src/stream_base.h:218:11: error: looser throw specifier for
    'virtual node::StreamBase::~StreamBase()'
    ../src/stream_base.h:134:11: error:   overriding 'virtual
    node::StreamResource::~StreamResource() noexcept (true)'
    In file included from ../src/js_stream.cc:1:0:
    ../src/js_stream.h:17:3: error: looser throw specifier for 'virtual
    node::JSStream::~JSStream()'
    In file included from ../src/js_stream.h:6:0,
                     from ../src/js_stream.cc:1:
    ../src/stream_base.h:218:11: error:   overriding 'virtual
    node::StreamBase::~StreamBase() noexcept (true)'
    node.target.mk:146: recipe for target
    '/home/joerg/Development/git/buildroot/output/build/nodejs
    -4.1.2/out/Release/obj.target/node/src/js_stream.o' failed
    make[2]: ***
    [/home/joerg/Development/git/buildroot/output/build/nodejs
    -4.1.2/out/Release/obj.target/node/src/js_stream.o] Error 1
    make[2]: *** Waiting for unfinished jobs....
    make[2]: Leaving directory
    '/home/joerg/Development/git/buildroot/output/build/nodejs
    -4.1.2/out'
    Makefile:45: recipe for target 'node' failed
    make[1]: *** [node] Error 2
    make[1]: Leaving directory
    '/home/joerg/Development/git/buildroot/output/build/nodejs-4.1.2'
    package/pkg-generic.mk:156: recipe for target
    '/home/joerg/Development/git/buildroot/output/build/nodejs
    -4.1.2/.stamp_built' failed
    make: *** [/home/joerg/Development/git/buildroot/output/build/nodejs
    -4.1.2/.stamp_built] Error 2

Maybe gcc > 4.7 required?

Best regards
Jörg Krause
Jaap Crezee Oct. 8, 2015, 9:26 a.m. UTC | #5
Hi Jörg,

On 10/08/15 00:44, Jörg Krause wrote:
> No need for patch #2 and #3 from 0.12.x?

Not when using our cross environment...
Running on an up-to-date Archlinux system.
The (unmodified) patches don't apply cleanly as well.

> Additionally, this package does not compile with the Sourcery CodeBench
> x86/x86_64 2012.09 toolchain:
> 
>     In file included from ../src/js_stream.h:6:0,
>                      from ../src/js_stream.cc:1:
>     ../src/stream_base.h:218:11: error: looser throw specifier for
>     'virtual node::StreamBase::~StreamBase()'
>     ../src/stream_base.h:134:11: error:   overriding 'virtual
>     node::StreamResource::~StreamResource() noexcept (true)'
>     In file included from ../src/js_stream.cc:1:0:
>     ../src/js_stream.h:17:3: error: looser throw specifier for 'virtual
>     node::JSStream::~JSStream()'
>     In file included from ../src/js_stream.h:6:0,
>                      from ../src/js_stream.cc:1:
>     ../src/stream_base.h:218:11: error:   overriding 'virtual
>     node::StreamBase::~StreamBase() noexcept (true)'
>     node.target.mk:146: recipe for target
>     '/home/joerg/Development/git/buildroot/output/build/nodejs
>     -4.1.2/out/Release/obj.target/node/src/js_stream.o' failed
>     make[2]: ***
>     [/home/joerg/Development/git/buildroot/output/build/nodejs
>     -4.1.2/out/Release/obj.target/node/src/js_stream.o] Error 1
>     make[2]: *** Waiting for unfinished jobs....
>     make[2]: Leaving directory
>     '/home/joerg/Development/git/buildroot/output/build/nodejs
>     -4.1.2/out'
>     Makefile:45: recipe for target 'node' failed
>     make[1]: *** [node] Error 2
>     make[1]: Leaving directory
>     '/home/joerg/Development/git/buildroot/output/build/nodejs-4.1.2'
>     package/pkg-generic.mk:156: recipe for target
>     '/home/joerg/Development/git/buildroot/output/build/nodejs
>     -4.1.2/.stamp_built' failed
>     make: *** [/home/joerg/Development/git/buildroot/output/build/nodejs
>     -4.1.2/.stamp_built] Error 2
> 
> Maybe gcc > 4.7 required?

I think so, I am using:

gcc version 4.9.3 20141031 (prerelease) (Linaro GCC 2014.11)
from
gcc-linaro-arm-linux-gnueabihf-4.9-2014.07_linux


regards,

Jaap Crezee
Peter Korsgaard Oct. 9, 2015, 7:03 a.m. UTC | #6
>>>>> "Jörg" == Jörg Krause <joerg.krause@embedded.rocks> writes:

Hi,

>> >  config BR2_PACKAGE_NODEJS_VERSION_STRING
 >> >  	string
 >> >  	default "0.10.40"	if BR2_BR2_PACKAGE_NODEJS_0_10_X
 >> >  	default "0.12.7"	if BR2_BR2_PACKAGE_NODEJS_0_12_X
 >> > +	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X
 >> 
 >> Is there a need to keep both 0.12.x and 4.1.x? The only reason we
 >> have a
 >> version selection is afaik that <ARMv7 is only supported in the old
 >> 0.10.x version.

 > Yes, there is! Node.js applications written for Node.js 0.12.x are not
 > necessarily compatible with Node.js 4.x.

Ok, but where does that leave us? Is the 0.12.x series still supported
upstream? When can it be dropped?
Jörg Krause Oct. 9, 2015, 7:13 a.m. UTC | #7
Dear Peter,

On Fr, 2015-10-09 at 09:03 +0200, Peter Korsgaard wrote:
> > > > > > "Jörg" == Jörg Krause <joerg.krause@embedded.rocks> writes:
> 
> Hi,
> 
> > > >  config BR2_PACKAGE_NODEJS_VERSION_STRING
>  >> >  	string
>  >> >  	default "0.10.40"	if
> BR2_BR2_PACKAGE_NODEJS_0_10_X
>  >> >  	default "0.12.7"	if
> BR2_BR2_PACKAGE_NODEJS_0_12_X
>  >> > +	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X
>  >> 
>  >> Is there a need to keep both 0.12.x and 4.1.x? The only reason we
>  >> have a
>  >> version selection is afaik that <ARMv7 is only supported in the
> old
>  >> 0.10.x version.
> 
>  > Yes, there is! Node.js applications written for Node.js 0.12.x are
> not
>  > necessarily compatible with Node.js 4.x.
> 
> Ok, but where does that leave us? Is the 0.12.x series still
> supported
> upstream? When can it be dropped?
> 

The Node.js foundation has a plan to establish Long-Term Support for
the current releases [1]. However, it is not officially yet.

[1] http://dailyjs.com/2015/07/01/node-long-term-support-working-group/
Yann E. MORIN Oct. 19, 2015, 4:34 p.m. UTC | #8
Jaap, All,

On 2015-10-06 14:57 +0200, Jaap Crezee spake thusly:
> Signed-off-by: Jaap Crezee <jaap@jcz.nl>

I have an alternative patch in the works to bump nodejs:
    http://git.buildroot.org/~ymorin/git/buildroot/commit/?h=yem/node&id=d080958d76d5737c0cb300976659d708889daeed

Compred to your patch:
  - it fixes a build failure for armv VFPv2
  - it drops 0.12.x
  - it forward ports and cleans up more patches.

From what I understand from the htread, we may want to keep 0.12.x
because of API changes.

So I'll adapt my patch to not get rif of 0.12.x and submit shortly.

Regards,
Yann E. MORIN.

>  ...01-Remove-dependency-on-Python-bz2-module.patch | 31 ++++++++++++++++++++++
>  package/nodejs/Config.in                           |  5 ++++
>  package/nodejs/nodejs.hash                         |  3 +++
>  3 files changed, 39 insertions(+)
>  create mode 100644 package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch
> 
> diff --git a/package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch b/package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch
> new file mode 100644
> index 0000000..de83d44
> --- /dev/null
> +++ b/package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch
> @@ -0,0 +1,31 @@
> +From 3d4817c152d6f3afddcc699949c4d1664da91e2b Mon Sep 17 00:00:00 2001
> +From: Martin Bark <martin@barkynet.com>
> +Date: Tue, 30 Jun 2015 09:43:11 +0100
> +Subject: [PATCH 1/4] Remove dependency on Python bz2 module
> +
> +The Python bz2 module is only needed in certain cases, so only import
> +it when needed. In the normal nodejs build, this allows to remove the
> +dependency on this module.
> +
> +Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> +[Martin: adapt to 0.12.5]
> +Signed-off-by: Martin Bark <martin@barkynet.com>
> +---
> + deps/v8/tools/js2c.py | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/deps/v8/tools/js2c.py b/deps/v8/tools/js2c.py
> +index 77485f6..371caf5 100755
> +--- a/deps/v8/tools/js2c.py
> ++++ b/deps/v8/tools/js2c.py
> +@@ -34,7 +34,6 @@
> + import os, re, sys, string
> + import optparse
> + import jsmin
> +-import bz2
> + import textwrap
> + 
> + 
> +-- 
> +2.1.4
> +
> diff --git a/package/nodejs/Config.in b/package/nodejs/Config.in
> index 329d270..b25375b 100644
> --- a/package/nodejs/Config.in
> +++ b/package/nodejs/Config.in
> @@ -40,12 +40,17 @@ config BR2_BR2_PACKAGE_NODEJS_0_12_X
>  	bool "v0.12.7"
>  	depends on !BR2_ARM_CPU_ARMV5
>  
> +config BR2_BR2_PACKAGE_NODEJS_4_1_X
> +	bool "v4.1.2"
> +	depends on !BR2_ARM_CPU_ARMV5
> +
>  endchoice
>  
>  config BR2_PACKAGE_NODEJS_VERSION_STRING
>  	string
>  	default "0.10.40"	if BR2_BR2_PACKAGE_NODEJS_0_10_X
>  	default "0.12.7"	if BR2_BR2_PACKAGE_NODEJS_0_12_X
> +	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X
>  
>  menu "Module Selection"
>  
> diff --git a/package/nodejs/nodejs.hash b/package/nodejs/nodejs.hash
> index 9be2806..9f75471 100644
> --- a/package/nodejs/nodejs.hash
> +++ b/package/nodejs/nodejs.hash
> @@ -3,3 +3,6 @@ sha256	bae79c2fd959aebe1629af36077bebbb760128db753da226d2344cd91499149f  node-v0
>  
>  # From upstream URL: http://nodejs.org/dist/v0.12.7/SHASUMS256.txt
>  sha256	b23d64df051c9c969b0c583f802d5d71de342e53067127a5061415be7e12f39d  node-v0.12.7.tar.gz
> +
> +# From upstream URL: http://nodejs.org/dist/v4.1.2/SHASUMS256.txt
> +sha256	febec3703a3fea9b64c46100a7b6a4408250027aa8259a2a815fd2275d502c49  node-v4.1.2.tar.gz
> -- 
> 2.6.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox

Patch

diff --git a/package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch b/package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch
new file mode 100644
index 0000000..de83d44
--- /dev/null
+++ b/package/nodejs/4.1.2/0001-Remove-dependency-on-Python-bz2-module.patch
@@ -0,0 +1,31 @@ 
+From 3d4817c152d6f3afddcc699949c4d1664da91e2b Mon Sep 17 00:00:00 2001
+From: Martin Bark <martin@barkynet.com>
+Date: Tue, 30 Jun 2015 09:43:11 +0100
+Subject: [PATCH 1/4] Remove dependency on Python bz2 module
+
+The Python bz2 module is only needed in certain cases, so only import
+it when needed. In the normal nodejs build, this allows to remove the
+dependency on this module.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+[Martin: adapt to 0.12.5]
+Signed-off-by: Martin Bark <martin@barkynet.com>
+---
+ deps/v8/tools/js2c.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/deps/v8/tools/js2c.py b/deps/v8/tools/js2c.py
+index 77485f6..371caf5 100755
+--- a/deps/v8/tools/js2c.py
++++ b/deps/v8/tools/js2c.py
+@@ -34,7 +34,6 @@
+ import os, re, sys, string
+ import optparse
+ import jsmin
+-import bz2
+ import textwrap
+ 
+ 
+-- 
+2.1.4
+
diff --git a/package/nodejs/Config.in b/package/nodejs/Config.in
index 329d270..b25375b 100644
--- a/package/nodejs/Config.in
+++ b/package/nodejs/Config.in
@@ -40,12 +40,17 @@  config BR2_BR2_PACKAGE_NODEJS_0_12_X
 	bool "v0.12.7"
 	depends on !BR2_ARM_CPU_ARMV5
 
+config BR2_BR2_PACKAGE_NODEJS_4_1_X
+	bool "v4.1.2"
+	depends on !BR2_ARM_CPU_ARMV5
+
 endchoice
 
 config BR2_PACKAGE_NODEJS_VERSION_STRING
 	string
 	default "0.10.40"	if BR2_BR2_PACKAGE_NODEJS_0_10_X
 	default "0.12.7"	if BR2_BR2_PACKAGE_NODEJS_0_12_X
+	default "4.1.2"     if BR2_BR2_PACKAGE_NODEJS_4_1_X
 
 menu "Module Selection"
 
diff --git a/package/nodejs/nodejs.hash b/package/nodejs/nodejs.hash
index 9be2806..9f75471 100644
--- a/package/nodejs/nodejs.hash
+++ b/package/nodejs/nodejs.hash
@@ -3,3 +3,6 @@  sha256	bae79c2fd959aebe1629af36077bebbb760128db753da226d2344cd91499149f  node-v0
 
 # From upstream URL: http://nodejs.org/dist/v0.12.7/SHASUMS256.txt
 sha256	b23d64df051c9c969b0c583f802d5d71de342e53067127a5061415be7e12f39d  node-v0.12.7.tar.gz
+
+# From upstream URL: http://nodejs.org/dist/v4.1.2/SHASUMS256.txt
+sha256	febec3703a3fea9b64c46100a7b6a4408250027aa8259a2a815fd2275d502c49  node-v4.1.2.tar.gz