diff mbox

gdb: prevent building the documentation

Message ID 1441718565-24492-1-git-send-email-Vincent.Riera@imgtec.com
State Superseded
Headers show

Commit Message

Vicente Olivert Riera Sept. 8, 2015, 1:22 p.m. UTC
gdb needs makeinfo to build the documentation. Since we do not provide a
host-makeinfo package this will fail in any system where makeinfo is
missing. However, we can workaround this problem by preventing gdb to
build the documentation.

Fixes:

  http://autobuild.buildroot.net/results/dd5/dd50ed99abb2c8495def826866b184030953f90e/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/gdb/gdb.mk |    6 ++++++
 1 files changed, 6 insertions(+), 0 deletions(-)

Comments

Arnout Vandecappelle Sept. 8, 2015, 1:39 p.m. UTC | #1
On 08-09-15 15:22, Vicente Olivert Riera wrote:
> gdb needs makeinfo to build the documentation. Since we do not provide a
> host-makeinfo package this will fail in any system where makeinfo is
> missing. However, we can workaround this problem by preventing gdb to
> build the documentation.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/dd5/dd50ed99abb2c8495def826866b184030953f90e/
> 
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
> ---
>  package/gdb/gdb.mk |    6 ++++++
>  1 files changed, 6 insertions(+), 0 deletions(-)
> 
> diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
> index 338de20..7a8f8c7 100644
> --- a/package/gdb/gdb.mk
> +++ b/package/gdb/gdb.mk
> @@ -114,6 +114,12 @@ else
>  GDB_CONF_OPTS += --without-zlib
>  endif
>  
> +# Prevent gdb to build the documentation
> +define GDB_DISABLE_DOC
> +$(SED) '/^SUBDIRS =/ s/doc//' $(@D)/gdb/Makefile.in
> +endef
> +GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC

 Since it is patching the source, it should be POST_PATCH_HOOKS rather than
PRE_CONFIGURE_HOOKS.

 That does mean that people using OVERRIDE_SRCDIR should do this fix in the
overridden source, but I think that's OK.

 Regards,
 Arnout

> +
>  # This removes some unneeded Python scripts and XML target description
>  # files that are not useful for a normal usage of the debugger.
>  define GDB_REMOVE_UNNEEDED_FILES
>
Brendan Heading Sept. 8, 2015, 1:49 p.m. UTC | #2
>  Since it is patching the source, it should be POST_PATCH_HOOKS rather than
> PRE_CONFIGURE_HOOKS.
>
>  That does mean that people using OVERRIDE_SRCDIR should do this fix in the
> overridden source, but I think that's OK.

I was looking at this in parallel and was about to start looking at
adding a host-texinfo package (which includes makeinfo).

I was a little hesitant, as I think most buildroot users don't care
about building documentation. On the other hand, adding the dependency
avoids patches and makes life a little easier when using
OVERRIDE_SRCDIR as you noted.

regards

Brendan
Brendan Heading Sept. 8, 2015, 1:53 p.m. UTC | #3
> I was looking at this in parallel and was about to start looking at
> adding a host-texinfo package (which includes makeinfo).

Stop press. There is already a host-texinfo package, and making
host-gdb dependent on it fixes this build problem. Just running a few
tests at the moment.

I think this is a cleaner and better way to solve this one ...

regards

Brendan
Vicente Olivert Riera Sept. 8, 2015, 1:55 p.m. UTC | #4
Dear Brendan Heading,

On 09/08/2015 02:53 PM, Brendan Heading wrote:
>> I was looking at this in parallel and was about to start looking at
>> adding a host-texinfo package (which includes makeinfo).
> 
> Stop press. There is already a host-texinfo package, and making
> host-gdb dependent on it fixes this build problem. Just running a few
> tests at the moment.
> 
> I think this is a cleaner and better way to solve this one ...

yes, it is. Please complete your tests and feel free to submit a patch.
When you do it, I will test it and mark mine as superseded.

Thanks,

Vincent.

> regards
> 
> Brendan
>
Arnout Vandecappelle Sept. 9, 2015, 10:48 a.m. UTC | #5
On 08-09-15 15:22, Vicente Olivert Riera wrote:
> gdb needs makeinfo to build the documentation. Since we do not provide a
> host-makeinfo package this will fail in any system where makeinfo is
> missing. However, we can workaround this problem by preventing gdb to
> build the documentation.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/dd5/dd50ed99abb2c8495def826866b184030953f90e/

 Thomas prefers this solution and I agree.

 However, there is one thing missing in this patch: removing the now-redundant
dependency on host-texinfo.

 Still, that can be done as a follow-up patch, so:

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>


 Regards,
 Arnout

> 
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
> ---
>  package/gdb/gdb.mk |    6 ++++++
>  1 files changed, 6 insertions(+), 0 deletions(-)
> 
> diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
> index 338de20..7a8f8c7 100644
> --- a/package/gdb/gdb.mk
> +++ b/package/gdb/gdb.mk
> @@ -114,6 +114,12 @@ else
>  GDB_CONF_OPTS += --without-zlib
>  endif
>  
> +# Prevent gdb to build the documentation
> +define GDB_DISABLE_DOC
> +$(SED) '/^SUBDIRS =/ s/doc//' $(@D)/gdb/Makefile.in
> +endef
> +GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC
> +
>  # This removes some unneeded Python scripts and XML target description
>  # files that are not useful for a normal usage of the debugger.
>  define GDB_REMOVE_UNNEEDED_FILES
>
Vicente Olivert Riera Sept. 9, 2015, 10:51 a.m. UTC | #6
Dear Arnout Vandecappelle,

On 09/09/2015 11:48 AM, Arnout Vandecappelle wrote:
> On 08-09-15 15:22, Vicente Olivert Riera wrote:
>> gdb needs makeinfo to build the documentation. Since we do not provide a
>> host-makeinfo package this will fail in any system where makeinfo is
>> missing. However, we can workaround this problem by preventing gdb to
>> build the documentation.
>>
>> Fixes:
>>
>>   http://autobuild.buildroot.net/results/dd5/dd50ed99abb2c8495def826866b184030953f90e/
> 
>  Thomas prefers this solution and I agree.
> 
>  However, there is one thing missing in this patch: removing the now-redundant
> dependency on host-texinfo.
> 
>  Still, that can be done as a follow-up patch, so:

nah..., I will send a v2. Note the sed command is not indented ;-)

Regards,

Vincent.

> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> 
> 
>  Regards,
>  Arnout
> 
>>
>> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
>> ---
>>  package/gdb/gdb.mk |    6 ++++++
>>  1 files changed, 6 insertions(+), 0 deletions(-)
>>
>> diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
>> index 338de20..7a8f8c7 100644
>> --- a/package/gdb/gdb.mk
>> +++ b/package/gdb/gdb.mk
>> @@ -114,6 +114,12 @@ else
>>  GDB_CONF_OPTS += --without-zlib
>>  endif
>>  
>> +# Prevent gdb to build the documentation
>> +define GDB_DISABLE_DOC
>> +$(SED) '/^SUBDIRS =/ s/doc//' $(@D)/gdb/Makefile.in
>> +endef
>> +GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC
>> +
>>  # This removes some unneeded Python scripts and XML target description
>>  # files that are not useful for a normal usage of the debugger.
>>  define GDB_REMOVE_UNNEEDED_FILES
>>
> 
>
Brendan Heading Sept. 9, 2015, 10:53 a.m. UTC | #7
>>  Still, that can be done as a follow-up patch, so:
>
> nah..., I will send a v2. Note the sed command is not indented ;-)

I will help test depending on when the patch comes through.

It'd be nice to get this in quick - there's a huge amount of noise
related to this in the autobuild output.

Brendan
diff mbox

Patch

diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 338de20..7a8f8c7 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -114,6 +114,12 @@  else
 GDB_CONF_OPTS += --without-zlib
 endif
 
+# Prevent gdb to build the documentation
+define GDB_DISABLE_DOC
+$(SED) '/^SUBDIRS =/ s/doc//' $(@D)/gdb/Makefile.in
+endef
+GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC
+
 # This removes some unneeded Python scripts and XML target description
 # files that are not useful for a normal usage of the debugger.
 define GDB_REMOVE_UNNEEDED_FILES