diff mbox

directfb: add an option for debugging support

Message ID 1433882623-15782-1-git-send-email-cedric.marie@openmailbox.org
State Changes Requested
Headers show

Commit Message

Cédric Marie June 9, 2015, 8:43 p.m. UTC
DirectFB debugging support is enabled by default. This new option makes
it possible to disable it (--disable-debug-support) and build the
library with no debug feature at all.

NB: When debugging support is disabled, the target installation path is
suffixed with -pure.

Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>
---
 package/directfb/Config.in   | 7 +++++++
 package/directfb/directfb.mk | 4 ++++
 2 files changed, 11 insertions(+)

Comments

Arnout Vandecappelle June 10, 2015, 9:45 p.m. UTC | #1
On 06/09/15 22:43, Cédric Marie wrote:
> DirectFB debugging support is enabled by default. This new option makes
> it possible to disable it (--disable-debug-support) and build the
> library with no debug feature at all.
> 
> NB: When debugging support is disabled, the target installation path is
> suffixed with -pure.
> 
> Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>
> ---
>  package/directfb/Config.in   | 7 +++++++
>  package/directfb/directfb.mk | 4 ++++
>  2 files changed, 11 insertions(+)
> 
> diff --git a/package/directfb/Config.in b/package/directfb/Config.in
> index 7759f8f..0015c0c 100644
> --- a/package/directfb/Config.in
> +++ b/package/directfb/Config.in
> @@ -20,8 +20,15 @@ config BR2_PACKAGE_DIRECTFB_MULTI
>  comment "directfb multi application needs a Linux kernel to be built"
>  	depends on !BR2_LINUX_KERNEL
>  
> +config BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
> +	bool "directfb debugging support"
> +	default y
> +	help
> +	  Compile DirectFB with debugging support

 I think the explanation you gave in your first mail would be valuable here.
Certainly, the fact that the target installation path is suffixed with -pure
should be clarified.

 Do all the packages that depend on directfb still build correctly with this
-pure suffix?

 Regards,
 Arnout

> +
>  config BR2_PACKAGE_DIRECTFB_DEBUG
>  	bool "directfb debugging"
> +	depends on BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
>  	help
>  	  Compile DirectFB with lots of debug output
>  
> diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
> index e3dc506..cf0609c 100644
> --- a/package/directfb/directfb.mk
> +++ b/package/directfb/directfb.mk
> @@ -39,9 +39,13 @@ DIRECTFB_CONF_OPTS += --enable-multi --enable-fusion
>  DIRECTFB_DEPENDENCIES += linux-fusion
>  endif
>  
> +ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
>  ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
>  DIRECTFB_CONF_OPTS += --enable-debug
>  endif
> +else
> +DIRECTFB_CONF_OPTS += --disable-debug-support
> +endif
>  
>  ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
>  DIRECTFB_CONF_OPTS += --enable-trace
>
Cédric Marie June 11, 2015, 12:58 p.m. UTC | #2
Hi,

Le 2015-06-10 23:45, Arnout Vandecappelle a écrit :
>  I think the explanation you gave in your first mail would be valuable 
> here.

OK. I didn't want to give too much details in the end, but you're right.


> Certainly, the fact that the target installation path is suffixed with 
> -pure
> should be clarified.
> 
>  Do all the packages that depend on directfb still build correctly with 
> this
> -pure suffix?

The public library is not moved: /usr/lib/libdirectfb.so
Only internal libraries are placed in a different directory: 
/usr/lib/directfb-x.y.z-pure/
It contains following directories: gfxdrivers, inputdrivers, interfaces, 
systems, wm.
It makes no difference for applications using DFB.


Would you be satisfied with that description below, as a commit message?


DirectFB provides two options for debug:
* --enable-debug-support (default is yes)
* --enable-debug (default is no)
The first one provides the functions to print debug information. These
functions can be called inside DirectFB, or by an external DirectFB
driver in another package.
The second one enables verbose mode in DirectFB, using these functions.

Buildroot currently provides an option for the second one only. The
first one - which is necessary for the second one - is always enabled,
because this is the default value.

The new option (BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT) makes it possible
to disable debugging support (--disable-debug-support) in order to
build the library with no debug feature at all.

When debugging support is disabled, the target installation path of
internal libraries (/usr/lib/directfb-<version>) is suffixed with
-pure. The public library (/usr/lib/libdirectfb.so) remains unchanged.

Some external DirectFB drivers will install in
/usr/lib/directfb-<version>-pure in release mode. For that reason, it
is important that DirectFB can be configured to use this directory.
Arnout Vandecappelle June 11, 2015, 8:32 p.m. UTC | #3
On 06/11/15 14:58, Cédric Marie wrote:
> Hi,
> 
> Le 2015-06-10 23:45, Arnout Vandecappelle a écrit :
>>  I think the explanation you gave in your first mail would be valuable here.
> 
> OK. I didn't want to give too much details in the end, but you're right.
> 
> 
>> Certainly, the fact that the target installation path is suffixed with -pure
>> should be clarified.
>>
>>  Do all the packages that depend on directfb still build correctly with this
>> -pure suffix?
> 
> The public library is not moved: /usr/lib/libdirectfb.so
> Only internal libraries are placed in a different directory:
> /usr/lib/directfb-x.y.z-pure/
> It contains following directories: gfxdrivers, inputdrivers, interfaces,
> systems, wm.
> It makes no difference for applications using DFB.
> 
> 
> Would you be satisfied with that description below, as a commit message?

 Yes, but I was in fact mainly talking about the help text of the new option.

 Regards,
 Arnout

> 
> 
> DirectFB provides two options for debug:
> * --enable-debug-support (default is yes)
> * --enable-debug (default is no)
> The first one provides the functions to print debug information. These
> functions can be called inside DirectFB, or by an external DirectFB
> driver in another package.
> The second one enables verbose mode in DirectFB, using these functions.
> 
> Buildroot currently provides an option for the second one only. The
> first one - which is necessary for the second one - is always enabled,
> because this is the default value.
> 
> The new option (BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT) makes it possible
> to disable debugging support (--disable-debug-support) in order to
> build the library with no debug feature at all.
> 
> When debugging support is disabled, the target installation path of
> internal libraries (/usr/lib/directfb-<version>) is suffixed with
> -pure. The public library (/usr/lib/libdirectfb.so) remains unchanged.
> 
> Some external DirectFB drivers will install in
> /usr/lib/directfb-<version>-pure in release mode. For that reason, it
> is important that DirectFB can be configured to use this directory.
> 
> 
>
Cédric Marie June 11, 2015, 9:20 p.m. UTC | #4
Hi,

Le 11/06/2015 22:32, Arnout Vandecappelle a écrit :
>   Yes, but I was in fact mainly talking about the help text of the new option.

Oops, sorry.
But I suppose I shouldn't give so much details in the help text, as in 
the commit message.
What do you think is important to mention?

Here is a proposal, feel free to comment/modify:

Compile DirectFB with debugging support. It provides functions to print 
debug information, for DirectFB as well as external DirectFB drivers.
When disabled, DirectFB has got no debug feature at all, and the 
directory that contains the internal libraries is suffixed with -pure
(/usr/lib/directfb-<version>-pure/).


NB: I'm not really satisfied with "internal libraries", but I can't find 
the right expression for that. It contains gfx drivers, but not only...
Arnout Vandecappelle June 11, 2015, 10:24 p.m. UTC | #5
On 06/11/15 23:20, Cédric Marie wrote:
> Hi,
> 
> Le 11/06/2015 22:32, Arnout Vandecappelle a écrit :
>>   Yes, but I was in fact mainly talking about the help text of the new option.
> 
> Oops, sorry.
> But I suppose I shouldn't give so much details in the help text, as in the
> commit message.
> What do you think is important to mention?
> 
> Here is a proposal, feel free to comment/modify:
> 
> Compile DirectFB with debugging support. It provides functions to print debug
> information, for DirectFB as well as external DirectFB drivers.
> When disabled, DirectFB has got no debug feature at all, and the directory that

When disabled, DirectFB does not print any debug information. The drivers will
be installed to and loaded from /usr/lib/directfb-<version>-pure instead of
/usr/lib/directfb-<version>-.

> contains the internal libraries is suffixed with -pure
> (/usr/lib/directfb-<version>-pure/).
> 
> 
> NB: I'm not really satisfied with "internal libraries", but I can't find the
> right expression for that. It contains gfx drivers, but not only...

 gfx drivers, input drivers, window systems drivers, ... I think it's drivers
:-) Only interfaces doesn't fit.


 Regards,
 Arnout
Cédric Marie June 12, 2015, 7:09 a.m. UTC | #6
Le 2015-06-12 00:24, Arnout Vandecappelle a écrit :
> When disabled, DirectFB does not print any debug information. The 
> drivers will
> be installed to and loaded from /usr/lib/directfb-<version>-pure 
> instead of
> /usr/lib/directfb-<version>.

OK. Sounds better like this :)


>  gfx drivers, input drivers, window systems drivers, ... I think it's 
> drivers
> :-) Only interfaces doesn't fit.

hmmm... I guess you're right :)
Thank you, I will "git format" a nice brand new patch. Coming "soon"...


Regards,
diff mbox

Patch

diff --git a/package/directfb/Config.in b/package/directfb/Config.in
index 7759f8f..0015c0c 100644
--- a/package/directfb/Config.in
+++ b/package/directfb/Config.in
@@ -20,8 +20,15 @@  config BR2_PACKAGE_DIRECTFB_MULTI
 comment "directfb multi application needs a Linux kernel to be built"
 	depends on !BR2_LINUX_KERNEL
 
+config BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
+	bool "directfb debugging support"
+	default y
+	help
+	  Compile DirectFB with debugging support
+
 config BR2_PACKAGE_DIRECTFB_DEBUG
 	bool "directfb debugging"
+	depends on BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
 	help
 	  Compile DirectFB with lots of debug output
 
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index e3dc506..cf0609c 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -39,9 +39,13 @@  DIRECTFB_CONF_OPTS += --enable-multi --enable-fusion
 DIRECTFB_DEPENDENCIES += linux-fusion
 endif
 
+ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
 ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
 DIRECTFB_CONF_OPTS += --enable-debug
 endif
+else
+DIRECTFB_CONF_OPTS += --disable-debug-support
+endif
 
 ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
 DIRECTFB_CONF_OPTS += --enable-trace