diff mbox

directfb: add an option for debugging support

Message ID 1433881958-15591-1-git-send-email-cedric.marie@openmailbox.org
State Superseded
Headers show

Commit Message

Cédric Marie June 9, 2015, 8:32 p.m. UTC
DirectFB debugging support is enabled by default. This new option makes
it possible to disable it (--disable-debug-support) and build the
library with no debug feature at all.

NB: When debugging support is disabled, the target installation path is
suffixed with -pure.

Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>
---
 package/directfb/Config.in   | 7 +++++++
 package/directfb/directfb.mk | 4 ++++
 2 files changed, 11 insertions(+)

Comments

Cédric Marie June 9, 2015, 8:45 p.m. UTC | #1
Hi,

Sorry for the noise...
Please forget the first version of the patch. The second one looks 
better to me.

Thank you.

Cédric


Le 09/06/2015 22:32, Cédric Marie a écrit :
> DirectFB debugging support is enabled by default. This new option makes
> it possible to disable it (--disable-debug-support) and build the
> library with no debug feature at all.
>
> NB: When debugging support is disabled, the target installation path is
> suffixed with -pure.
>
> Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>
> ---
>   package/directfb/Config.in   | 7 +++++++
>   package/directfb/directfb.mk | 4 ++++
>   2 files changed, 11 insertions(+)
>
> diff --git a/package/directfb/Config.in b/package/directfb/Config.in
> index 7759f8f..0015c0c 100644
> --- a/package/directfb/Config.in
> +++ b/package/directfb/Config.in
> @@ -20,8 +20,15 @@ config BR2_PACKAGE_DIRECTFB_MULTI
>   comment "directfb multi application needs a Linux kernel to be built"
>   	depends on !BR2_LINUX_KERNEL
>
> +config BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
> +	bool "directfb debugging support"
> +	default y
> +	help
> +	  Compile DirectFB with debugging support
> +
>   config BR2_PACKAGE_DIRECTFB_DEBUG
>   	bool "directfb debugging"
> +	depends on BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
>   	help
>   	  Compile DirectFB with lots of debug output
>
> diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
> index e3dc506..d8af56e 100644
> --- a/package/directfb/directfb.mk
> +++ b/package/directfb/directfb.mk
> @@ -39,6 +39,10 @@ DIRECTFB_CONF_OPTS += --enable-multi --enable-fusion
>   DIRECTFB_DEPENDENCIES += linux-fusion
>   endif
>
> +ifneq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
> +DIRECTFB_CONF_OPTS += --disable-debug-support
> +endif
> +
>   ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
>   DIRECTFB_CONF_OPTS += --enable-debug
>   endif
>
diff mbox

Patch

diff --git a/package/directfb/Config.in b/package/directfb/Config.in
index 7759f8f..0015c0c 100644
--- a/package/directfb/Config.in
+++ b/package/directfb/Config.in
@@ -20,8 +20,15 @@  config BR2_PACKAGE_DIRECTFB_MULTI
 comment "directfb multi application needs a Linux kernel to be built"
 	depends on !BR2_LINUX_KERNEL
 
+config BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
+	bool "directfb debugging support"
+	default y
+	help
+	  Compile DirectFB with debugging support
+
 config BR2_PACKAGE_DIRECTFB_DEBUG
 	bool "directfb debugging"
+	depends on BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
 	help
 	  Compile DirectFB with lots of debug output
 
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index e3dc506..d8af56e 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -39,6 +39,10 @@  DIRECTFB_CONF_OPTS += --enable-multi --enable-fusion
 DIRECTFB_DEPENDENCIES += linux-fusion
 endif
 
+ifneq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
+DIRECTFB_CONF_OPTS += --disable-debug-support
+endif
+
 ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
 DIRECTFB_CONF_OPTS += --enable-debug
 endif