diff mbox

package/iproute2: disable iptables support for static build

Message ID 1431982453-17867-1-git-send-email-romain.naour@openwide.fr
State Superseded
Headers show

Commit Message

Romain Naour May 18, 2015, 8:54 p.m. UTC
If iptable support is enabled, it will try to build m_xt.so even
for static build only.

So, disable iptables support for static build and remove
TC_CONFIG_IPSET and TC_CONFIG_XT if previously added by the
configure script.

Fixes:
http://autobuild.buildroot.net/results/3b3/3b37871bdf5766677fc20dca22c13177091d104f/

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
 package/iproute2/iproute2.mk | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard May 21, 2015, 9:22 p.m. UTC | #1
>>>>> "Romain" == Romain Naour <romain.naour@openwide.fr> writes:

 > If iptable support is enabled, it will try to build m_xt.so even
 > for static build only.

 > So, disable iptables support for static build and remove
 > TC_CONFIG_IPSET and TC_CONFIG_XT if previously added by the
 > configure script.

 > Fixes:
 > http://autobuild.buildroot.net/results/3b3/3b37871bdf5766677fc20dca22c13177091d104f/

FYI, I ended up applying Baruch's patch (and then some followup patches
of my own). Your two patches were almost identical, but for his patch I
didn't have to drop the SED lines, and I was lazy ;)

Thanks!
Romain Naour May 23, 2015, 10:02 a.m. UTC | #2
Hi Peter,

Le 21/05/2015 23:22, Peter Korsgaard a écrit :
>>>>>> "Romain" == Romain Naour <romain.naour@openwide.fr> writes:
> 
>  > If iptable support is enabled, it will try to build m_xt.so even
>  > for static build only.
> 
>  > So, disable iptables support for static build and remove
>  > TC_CONFIG_IPSET and TC_CONFIG_XT if previously added by the
>  > configure script.
> 
>  > Fixes:
>  > http://autobuild.buildroot.net/results/3b3/3b37871bdf5766677fc20dca22c13177091d104f/
> 
> FYI, I ended up applying Baruch's patch (and then some followup patches
> of my own). Your two patches were almost identical, but for his patch I
> didn't have to drop the SED lines, and I was lazy ;)

Ok, no problem and sorry for the late answer...

The sed invocation to remove -Werror is just a nop and can also be removed.
See:
http://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=3140e9a3a343d37a8d828ee27e16ad9f3f9ab389

The real fix would be to write a real autotools configure script but it's
probably too late for the Buildroot release...

See also the note in the commit log ;-)
http://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=06ec9039c3aa07924f9c23b0daa8885204704a62

Best regards,
Romain

> 
> Thanks!
>
Peter Korsgaard May 25, 2015, 8:32 p.m. UTC | #3
>>>>> "Romain" == Romain Naour <romain.naour@openwide.fr> writes:

Hi,

>> FYI, I ended up applying Baruch's patch (and then some followup patches
 >> of my own). Your two patches were almost identical, but for his patch I
 >> didn't have to drop the SED lines, and I was lazy ;)

 > Ok, no problem and sorry for the late answer...

 > The sed invocation to remove -Werror is just a nop and can also be removed.
 > See:
 > http://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=3140e9a3a343d37a8d828ee27e16ad9f3f9ab389

Ahh, thanks - Will remove.

 > The real fix would be to write a real autotools configure script but it's
 > probably too late for the Buildroot release...

 > See also the note in the commit log ;-)
 > http://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=06ec9039c3aa07924f9c23b0daa8885204704a62

Yeah!
diff mbox

Patch

diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index 9595165..d97e75e 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -18,7 +18,7 @@  IPROUTE2_DEPENDENCIES += busybox
 endif
 
 # If we've got iptables enable xtables support for tc
-ifeq ($(BR2_PACKAGE_IPTABLES),y)
+ifeq ($(BR2_PACKAGE_IPTABLES)x$(BR2_STATIC_LIBS),yx)
 IPROUTE2_DEPENDENCIES += iptables
 define IPROUTE2_WITH_IPTABLES
 	# Makefile is busted so it never passes IPT_LIB_DIR properly
@@ -27,6 +27,9 @@  define IPROUTE2_WITH_IPTABLES
 endef
 else
 define IPROUTE2_WITH_IPTABLES
+	# delete TC_CONFIG_IPSET and TC_CONFIG_XT if any
+	$(SED) '/TC_CONFIG_IPSET/d' $(IPROUTE2_DIR)/Config
+	$(SED) '/TC_CONFIG_XT/d' $(IPROUTE2_DIR)/Config
 	# em_ipset needs xtables, but configure misdetects it
 	echo "TC_CONFIG_IPSET:=n" >>$(IPROUTE2_DIR)/Config
 endef