diff mbox

package/aircrack-ng: fix static build

Message ID 1416150910-5691-1-git-send-email-yann.morin.1998@free.fr
State Accepted
Commit d26d6e63e02dce6323fb886b85dc4ffe669eaab6
Headers show

Commit Message

Yann E. MORIN Nov. 16, 2014, 3:15 p.m. UTC
Two fixes in one:

  - openssl's libcrypto needs -lz, but because aircrack-ng does not use
    pkg-config, it misses this dependency. The proper fix would be to
    use pkg-config, like is done for pcre with patch
    0001-Makefile-use-pkg-config-to-find-libpcre-it-s-more-cros.patch
    but adding -lz is much easier.

  - sqlite needs -lpthread, so -lpthread must be added _after_ -lsqlite,
    but we currently add it before. So, force -lpthread after -lsqlite
    when we are doing a static build.

Fixes:
    http://autobuild.buildroot.net/results/1ea/1ea877851e9d2aeeaf9d320bef12321ec2925b5b/
    http://autobuild.buildroot.net/results/cdf/cdf0203fc99d5f7e41e508f6d9edb78a0f0ea732/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/aircrack-ng/aircrack-ng.mk | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Nov. 16, 2014, 3:59 p.m. UTC | #1
All,

On 2014-11-16 16:15 +0100, Yann E. MORIN spake thusly:
> Two fixes in one:

So, why did I not submit two patches?

Because both fixes are needed to fix the autobuild failures mentioned
below...

> Fixes:
>     http://autobuild.buildroot.net/results/1ea/1ea877851e9d2aeeaf9d320bef12321ec2925b5b/
>     http://autobuild.buildroot.net/results/cdf/cdf0203fc99d5f7e41e508f6d9edb78a0f0ea732/

Regards,
Yann E. MORIN.
Peter Korsgaard Nov. 16, 2014, 9:46 p.m. UTC | #2
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > All,
 > On 2014-11-16 16:15 +0100, Yann E. MORIN spake thusly:
 >> Two fixes in one:

 > So, why did I not submit two patches?

 > Because both fixes are needed to fix the autobuild failures mentioned
 > below...

Talking to yourself? ;)

Committed, thanks.
Yann E. MORIN Nov. 16, 2014, 9:52 p.m. UTC | #3
Peter, All,

On 2014-11-16 22:46 +0100, Peter Korsgaard spake thusly:
> >>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:
> 
>  > All,
>  > On 2014-11-16 16:15 +0100, Yann E. MORIN spake thusly:
>  >> Two fixes in one:
> 
>  > So, why did I not submit two patches?
> 
>  > Because both fixes are needed to fix the autobuild failures mentioned
>  > below...
> 
> Talking to yourself? ;)

No, it was Alter talking to Ego, not me.

Muhahaha! :-)

> Committed, thanks.

Thanks!

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/aircrack-ng/aircrack-ng.mk b/package/aircrack-ng/aircrack-ng.mk
index 30298f5..c7fcb63 100644
--- a/package/aircrack-ng/aircrack-ng.mk
+++ b/package/aircrack-ng/aircrack-ng.mk
@@ -14,7 +14,7 @@  AIRCRACK_NG_MAKE_OPTS = unstable=true
 
 # Account for libpthread in static
 AIRCRACK_NG_LDFLAGS = $(TARGET_LDFLAGS) \
-	$(if $(BR2_PREFER_STATIC_LIB),-lpthread)
+	$(if $(BR2_PREFER_STATIC_LIB),-lpthread -lz)
 
 # libnl support has issues when building static
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
@@ -39,9 +39,10 @@  else
 	AIRCRACK_NG_MAKE_OPTS += pcre=false
 endif
 
+# Duplicate -lpthread, because it is also needed by sqlite
 ifeq ($(BR2_PACKAGE_SQLITE),y)
 	AIRCRACK_NG_DEPENDENCIES += sqlite
-	AIRCRACK_NG_MAKE_OPTS += sqlite=true LIBSQL="-lsqlite3"
+	AIRCRACK_NG_MAKE_OPTS += sqlite=true LIBSQL="-lsqlite3 $(if $(BR2_PREFER_STATIC_LIB),-lpthread)"
 else
 	AIRCRACK_NG_MAKE_OPTS += sqlite=false
 endif