diff mbox

[04/11] gdb: Fix on-target threads debugging

Message ID 1396558881-29631-4-git-send-email-paul@crapouillou.net
State Rejected
Headers show

Commit Message

Paul Cercueil April 3, 2014, 9:01 p.m. UTC
From: Maarten ter Huurne <maarten@treewalker.org>

Signed-Off-By: Maarten ter Huurne <maarten@treewalker.org>
Acked-By: Paul Cercueil <paul@crapouillou.net>
---
 Makefile | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Yann E. MORIN April 3, 2014, 9:23 p.m. UTC | #1
Paul, Maarten, All,

On 2014-04-03 23:01 +0200, Paul Cercueil spake thusly:
> From: Maarten ter Huurne <maarten@treewalker.org>
> 
> Signed-Off-By: Maarten ter Huurne <maarten@treewalker.org>
> Acked-By: Paul Cercueil <paul@crapouillou.net>
> ---
>  Makefile | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/Makefile b/Makefile
> index 09be13c..69ef7a5 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -506,6 +506,10 @@ $(BUILD_DIR)/.root:
>  
>  $(TARGET_DIR): $(BUILD_DIR)/.root
>  
> +ifeq ($(BR2_PACKAGE_GDB),y)
> +BR2_STRIP_EXCLUDE_FILES += libpthread*.so*
> +endif

Is that really needed? The exclude code already excludes that file:

Makefile@513:
    [...] $(call findfileclauses,libpthread*.so* $(call qstrip,$(BR2_STRIP_EXCLUDE_FILES))) [...]

So, libpthread*.so* is always excluded from being stripped.

Do you have a case where libpthread*.so* is still stripped?

Regards,
Yann E. MORIN.

>  STRIP_FIND_CMD = find $(TARGET_DIR)
>  ifneq (,$(call qstrip,$(BR2_STRIP_EXCLUDE_DIRS)))
>  STRIP_FIND_CMD += \( $(call finddirclauses,$(TARGET_DIR),$(call qstrip,$(BR2_STRIP_EXCLUDE_DIRS))) \) -prune -o
> -- 
> 1.9.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 09be13c..69ef7a5 100644
--- a/Makefile
+++ b/Makefile
@@ -506,6 +506,10 @@  $(BUILD_DIR)/.root:
 
 $(TARGET_DIR): $(BUILD_DIR)/.root
 
+ifeq ($(BR2_PACKAGE_GDB),y)
+BR2_STRIP_EXCLUDE_FILES += libpthread*.so*
+endif
+
 STRIP_FIND_CMD = find $(TARGET_DIR)
 ifneq (,$(call qstrip,$(BR2_STRIP_EXCLUDE_DIRS)))
 STRIP_FIND_CMD += \( $(call finddirclauses,$(TARGET_DIR),$(call qstrip,$(BR2_STRIP_EXCLUDE_DIRS))) \) -prune -o