diff mbox

[2/2] slang: add ncurses optional dependency

Message ID 1395961593-9826-2-git-send-email-romain.naour@openwide.fr
State Accepted
Commit 3a7aee7742fbe802f26c9ec341580be16e4d1c25
Headers show

Commit Message

Romain Naour March 27, 2014, 11:06 p.m. UTC
Ncurses check need to be disabled if ncurses package is not
selected.
If we don't do that, host's ncurses5-config may be used by
configure script.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
Note: others optional dependencies may be missing
(pcre oniguruma png z iconv)

 package/slang/slang.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Peter Korsgaard March 28, 2014, 8:56 a.m. UTC | #1
>>>>> "Romain" == Romain Naour <romain.naour@openwide.fr> writes:

 > Ncurses check need to be disabled if ncurses package is not
 > selected.
 > If we don't do that, host's ncurses5-config may be used by
 > configure script.

 > Signed-off-by: Romain Naour <romain.naour@openwide.fr>

Committed, thanks.

 > Note: others optional dependencies may be missing
 > (pcre oniguruma png z iconv)

Care to cook up a patch for those?
Romain Naour March 29, 2014, 9:39 a.m. UTC | #2
Hi Peter,

Le 28/03/2014 09:56, Peter Korsgaard a écrit :
>>>>>> "Romain" == Romain Naour <romain.naour@openwide.fr> writes:
>   > Ncurses check need to be disabled if ncurses package is not
>   > selected.
>   > If we don't do that, host's ncurses5-config may be used by
>   > configure script.
>
>   > Signed-off-by: Romain Naour <romain.naour@openwide.fr>
>
> Committed, thanks.
>
>   > Note: others optional dependencies may be missing
>   > (pcre oniguruma png z iconv)
>
> Care to cook up a patch for those?
>
Sorry, I had notime to rework on this patch yesterday.
In the meantime Gustavo Zacarias added a patch for slsh and
added the missing dependencies.

Also, my patch for slang has broken the newt package.
newt could not find the slang library.
http://autobuild.buildroot.net/results/553/5533328ec987f12d0b3dd81c430e960d3dc50503/build-end.log

Thanks to Gustavo the problem is gone.

Best regards,
Romain
diff mbox

Patch

diff --git a/package/slang/slang.mk b/package/slang/slang.mk
index 38f0b6f..2006c71 100644
--- a/package/slang/slang.mk
+++ b/package/slang/slang.mk
@@ -13,6 +13,12 @@  SLANG_LICENSE_FILES = COPYING
 SLANG_INSTALL_STAGING = YES
 SLANG_MAKE = $(MAKE1)
 
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+	SLANG_DEPENDENCIES = ncurses
+else
+	SLANG_CONF_OPT = ac_cv_path_nc5config=no
+endif
+
 # The installation location of the slang library
 # does not take into account the DESTDIR directory.
 # So SLANG_INST_LIB is initialized with -L/usr/lib/