diff mbox

[1/2] slang: fix linking issue

Message ID 1395961593-9826-1-git-send-email-romain.naour@openwide.fr
State Accepted
Commit 32c0fbbcdec5e4fdf853cb566a83680a4d393b90
Headers show

Commit Message

Romain Naour March 27, 2014, 11:06 p.m. UTC
The installation location of the slang library
does not take into account the DESTDIR directory.
So SLANG_INST_LIB is initialized with -L/usr/lib/
and slang may be linked with host's libdl.so (if any)
Therefore, we have to pass correct installation paths.

Fixes:
http://autobuild.buildroot.net/results/df4/df435d9cebbdc84b3581ba258b618123570dde8b/

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
 package/slang/slang.mk | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

Peter Korsgaard March 28, 2014, 8:55 a.m. UTC | #1
>>>>> "Romain" == Romain Naour <romain.naour@openwide.fr> writes:

 > The installation location of the slang library
 > does not take into account the DESTDIR directory.
 > So SLANG_INST_LIB is initialized with -L/usr/lib/
 > and slang may be linked with host's libdl.so (if any)
 > Therefore, we have to pass correct installation paths.

 > Fixes:
 > http://autobuild.buildroot.net/results/df4/df435d9cebbdc84b3581ba258b618123570dde8b/

 > Signed-off-by: Romain Naour <romain.naour@openwide.fr>

The real problem is that the slang build system gets confused and
rebuilds slsh even though it has just built it in the build step (called
slsh_exe for some reason though).

But ok, I tried fiddling a bit with Makefile.in, but also didn't manage
to fix it - So committed, thanks.
diff mbox

Patch

diff --git a/package/slang/slang.mk b/package/slang/slang.mk
index d519eca..38f0b6f 100644
--- a/package/slang/slang.mk
+++ b/package/slang/slang.mk
@@ -13,4 +13,21 @@  SLANG_LICENSE_FILES = COPYING
 SLANG_INSTALL_STAGING = YES
 SLANG_MAKE = $(MAKE1)
 
+# The installation location of the slang library
+# does not take into account the DESTDIR directory.
+# So SLANG_INST_LIB is initialized with -L/usr/lib/
+# and slang may be linked with host's libdl.so (if any)
+# Therefore, we have to pass correct installation paths.
+SLANG_INSTALL_STAGING_OPT = \
+	prefix=$(STAGING_DIR)/usr \
+	exec_prefix=$(STAGING_DIR)/usr \
+	DESTDIR=$(STAGING_DIR) \
+	install
+
+SLANG_INSTALL_TARGET_OPT = \
+	prefix=$(STAGING_DIR)/usr \
+	exec_prefix=$(STAGING_DIR)/usr \
+	DESTDIR=$(TARGET_DIR) \
+	install
+
 $(eval $(autotools-package))