diff mbox

[6/6] Makefile: do not add the toolchain target to the TARGETS variable

Message ID 1394540278-28740-7-git-send-email-fabio.porcedda@gmail.com
State Superseded
Headers show

Commit Message

Fabio Porcedda March 11, 2014, 12:17 p.m. UTC
Do not add the toolchain target to the TARGETS variable because now the
toolchain target is a dependency added automatically so it is not
necessary to add it anymore.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle March 17, 2014, 7:42 a.m. UTC | #1
On 03/11/14 13:17, Fabio Porcedda wrote:
> Do not add the toolchain target to the TARGETS variable because now the
> toolchain target is a dependency added automatically so it is not
> necessary to add it anymore.

 I disagree with this one. When you run make, you expect buildroot to
build the toolchain even if no target package is selected. One use case I
can think of: when preparing an internal toolchain for use as an external
toolchain in later builds.


 Regards,
 Arnout

> 
> Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/Makefile b/Makefile
> index 0420364..481f779 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -300,7 +300,7 @@ GNU_HOST_NAME := $(shell support/gnuconfig/config.guess)
>  #
>  ################################################################################
>  
> -TARGETS := toolchain
> +TARGETS :=
>  
>  # silent mode requested?
>  QUIET := $(if $(findstring s,$(MAKEFLAGS)),-q)
>
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 0420364..481f779 100644
--- a/Makefile
+++ b/Makefile
@@ -300,7 +300,7 @@  GNU_HOST_NAME := $(shell support/gnuconfig/config.guess)
 #
 ################################################################################
 
-TARGETS := toolchain
+TARGETS :=
 
 # silent mode requested?
 QUIET := $(if $(findstring s,$(MAKEFLAGS)),-q)