diff mbox

[2/2] libsigc: Don't copy devel documentation onto target

Message ID 1354239752-18102-1-git-send-email-cdhmanning@gmail.com
State Accepted
Commit 537556b22ca6252d319a33ac797afb45b215dbd1
Headers show

Commit Message

Charles Manning Nov. 30, 2012, 1:42 a.m. UTC
The libsigc++ developer documentation was being copied onto the target.
Add a clean-up to fix that.

There is probably a better way to do this but I still have training wheels.

Signed-off-by: Charles Manning <cdhmanning@gmail.com>
---
 package/libsigc/libsigc.mk |    6 ++++++
 1 files changed, 6 insertions(+), 0 deletions(-)

Comments

Arnout Vandecappelle Nov. 30, 2012, 8:18 a.m. UTC | #1
On 30/11/12 02:42, Charles Manning wrote:
> The libsigc++ developer documentation was being copied onto the target.
> Add a clean-up to fix that.
>
> There is probably a better way to do this but I still have training wheels.

  A command like that should typically go below ---, otherwise it will
appear in the git log for all eternity...

>
> Signed-off-by: Charles Manning<cdhmanning@gmail.com>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>


> ---
>   package/libsigc/libsigc.mk |    6 ++++++
>   1 files changed, 6 insertions(+), 0 deletions(-)
>
> diff --git a/package/libsigc/libsigc.mk b/package/libsigc/libsigc.mk
> index 92d1d8b..10f5803 100644
> --- a/package/libsigc/libsigc.mk
> +++ b/package/libsigc/libsigc.mk
> @@ -8,4 +8,10 @@ LIBSIGC_SOURCE = libsigc++-$(LIBSIGC_VERSION).tar.bz2
>   LIBSIGC_SITE = http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2
>   LIBSIGC_INSTALL_STAGING = YES
>
> +define LIBSIGC_INSTALL_TARGET_FIXUP
> +	rm -rf $(TARGET_DIR)/usr/share/devhelp/books/libsigc++*

  Perhaps we should globally remove devhelp together with man and doc?
OTOH this is currently the only package that installs anything in
devhelp.

  BTW, if someone wanted to remark that this shouldn't be done if
BR2_HAVE_DOCUMENTATION is y: we don't have a devhelp reader, so installing
the devhelp texts is always pointless.


  Regards,
  Arnout

> +endef
> +
> +LIBSIGC_POST_INSTALL_TARGET_HOOKS += LIBSIGC_INSTALL_TARGET_FIXUP
> +
>   $(eval $(autotools-package))
Peter Korsgaard Dec. 1, 2012, 6:08 a.m. UTC | #2
>>>>> "Charles" == Charles Manning <cdhmanning@gmail.com> writes:

 Charles> The libsigc++ developer documentation was being copied onto the target.
 Charles> Add a clean-up to fix that.

Committed, thanks.
diff mbox

Patch

diff --git a/package/libsigc/libsigc.mk b/package/libsigc/libsigc.mk
index 92d1d8b..10f5803 100644
--- a/package/libsigc/libsigc.mk
+++ b/package/libsigc/libsigc.mk
@@ -8,4 +8,10 @@  LIBSIGC_SOURCE = libsigc++-$(LIBSIGC_VERSION).tar.bz2
 LIBSIGC_SITE = http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2
 LIBSIGC_INSTALL_STAGING = YES
 
+define LIBSIGC_INSTALL_TARGET_FIXUP
+	rm -rf $(TARGET_DIR)/usr/share/devhelp/books/libsigc++*
+endef
+
+LIBSIGC_POST_INSTALL_TARGET_HOOKS += LIBSIGC_INSTALL_TARGET_FIXUP
+
 $(eval $(autotools-package))