diff mbox

[4/5] lua: remove 3 sub-options, always install all

Message ID 1346741921-28968-4-git-send-email-francois.perrad@gadz.org
State Accepted
Commit 76983349cf2c77ed86e636cf81df5a61dce15a59
Headers show

Commit Message

Francois Perrad Sept. 4, 2012, 6:58 a.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/lua/Config.in |   18 ------------------
 package/lua/lua.mk    |   18 +-----------------
 2 files changed, 1 insertion(+), 35 deletions(-)

Comments

Arnout Vandecappelle Nov. 9, 2012, 9:41 p.m. UTC | #1
On 09/04/12 08:58, Francois Perrad wrote:
> Signed-off-by: Francois Perrad<francois.perrad@gadz.org>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

  Peter, please commit this one before -rc1, it fixes
http://autobuild.buildroot.net/results/d47b983abde8eebe02c228d638101b8d5cd92965/

  Regards,
  Arnout
Peter Korsgaard Nov. 15, 2012, 11:37 a.m. UTC | #2
>>>>> "Francois" == Francois Perrad <fperrad@gmail.com> writes:

 Francois> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>

Committed, thanks.
diff mbox

Patch

diff --git a/package/lua/Config.in b/package/lua/Config.in
index ad454a6..febec45 100644
--- a/package/lua/Config.in
+++ b/package/lua/Config.in
@@ -32,29 +32,11 @@  endchoice
 
 if BR2_PACKAGE_LUA
 
-config BR2_PACKAGE_LUA_COMPILER
-	bool "lua compiler"
-	select BR2_PACKAGE_LUA_SHARED_LIBRARY
-	help
-	  Install luac binary
-
-config BR2_PACKAGE_LUA_INTERPRETER
-	bool "lua interpreter"
-	select BR2_PACKAGE_LUA_SHARED_LIBRARY
-	help
-	  Install lua binary
-
 config BR2_PACKAGE_LUA_INTERPRETER_READLINE
 	bool "readline support"
-	depends on BR2_PACKAGE_LUA_INTERPRETER
 	select BR2_PACKAGE_READLINE
 	select BR2_PACKAGE_NCURSES
 	help
 	  Enables command-line editing in the lua interpreter.
 
-config BR2_PACKAGE_LUA_SHARED_LIBRARY
-	bool "shared library"
-	help
-	  Install shared liblua.so
-
 endif
diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index de60c57..4704e4c 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -10,11 +10,7 @@  LUA_INSTALL_STAGING = YES
 LUA_LICENSE = MIT
 LUA_LICENSE_FILES = COPYRIGHT
 
-LUA_CFLAGS = -Wall
-ifeq ($(BR2_PACKAGE_LUA_SHARED_LIBRARY),y)
-	LUA_CFLAGS += -fPIC
-endif
-
+LUA_CFLAGS = -Wall -fPIC
 LUA_MYLIBS += -ldl
 
 ifeq ($(BR2_PACKAGE_LUA_INTERPRETER_READLINE),y)
@@ -46,13 +42,11 @@  define HOST_LUA_BUILD_CMDS
 	PKG_VERSION=$(LUA_VERSION) -C $(@D)/src all
 endef
 
-ifeq ($(BR2_PACKAGE_LUA_SHARED_LIBRARY),y)
 define LUA_INSTALL_STAGING_SHARED_LIB
 	$(INSTALL) -m 0755 -D $(@D)/src/liblua.so.$(LUA_VERSION) \
 		$(STAGING_DIR)/usr/lib/liblua.so.$(LUA_VERSION)
 	ln -sf liblua.so.$(LUA_VERSION) $(STAGING_DIR)/usr/lib/liblua.so
 endef
-endif
 
 define LUA_INSTALL_STAGING_CMDS
 	$(INSTALL) -m 0644 -D $(@D)/etc/lua.pc \
@@ -66,29 +60,19 @@  define LUA_INSTALL_STAGING_CMDS
 	$(INSTALL) -m 0644 -D $(@D)/src/lauxlib.h $(STAGING_DIR)/usr/include/lauxlib.h
 endef
 
-ifeq ($(BR2_PACKAGE_LUA_INTERPRETER),y)
 define LUA_INSTALL_INTERPRETER
 	$(INSTALL) -m 0755 -D $(@D)/src/lua $(TARGET_DIR)/usr/bin/lua
 endef
-endif
 
-ifeq ($(BR2_PACKAGE_LUA_COMPILER),y)
 define LUA_INSTALL_COMPILER
 	$(INSTALL) -m 0755 -D $(@D)/src/luac $(TARGET_DIR)/usr/bin/luac
 endef
-endif
 
-ifeq ($(BR2_PACKAGE_LUA_SHARED_LIBRARY),y)
 define LUA_INSTALL_LIBRARY
 	$(INSTALL) -m 0755 -D $(@D)/src/liblua.so.$(LUA_VERSION) \
 		$(TARGET_DIR)/usr/lib/liblua.so.$(LUA_VERSION)
 	ln -sf liblua.so.$(LUA_VERSION) $(TARGET_DIR)/usr/lib/liblua.so
 	$(INSTALL) -m 0644 -D $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
-endef
-else
-define LUA_INSTALL_LIBRARY
-	$(INSTALL) -m 0644 -D $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
-endef
 endif
 
 ifeq ($(BR2_HAVE_DEVFILES),y)