[v2,3/5] package/gdb: switch to 8.0 as the default version

Message ID 20180205211015.26819-4-thomas.petazzoni@bootlin.com
State Superseded
Headers show
Series
  • Add gdb 8.1 support, switch to 8.0 as default, drop old versions
Related show

Commit Message

Thomas Petazzoni Feb. 5, 2018, 9:10 p.m.
From: Romain Naour <romain.naour@gmail.com>

8.1 is around, 8.0 has already seen a point release, so it's time to
make 8.0 the default version for gdb.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/gdb/Config.in.host | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN Feb. 7, 2018, 10:10 a.m. | #1
Thomas, Romain, All,

On 2018-02-05 22:10 +0100, Thomas Petazzoni spake thusly:
> From: Romain Naour <romain.naour@gmail.com>
> 
> 8.1 is around, 8.0 has already seen a point release, so it's time to
> make 8.0 the default version for gdb.
> 
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/gdb/Config.in.host | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/gdb/Config.in.host b/package/gdb/Config.in.host
> index ae9a7257dd..8324271283 100644
> --- a/package/gdb/Config.in.host
> +++ b/package/gdb/Config.in.host
> @@ -45,7 +45,7 @@ config BR2_PACKAGE_HOST_GDB_SIM
>  
>  choice
>  	prompt "GDB debugger Version"
> -	default BR2_GDB_VERSION_7_11
> +	default BR2_GDB_VERSION_8_0
>  	depends on !BR2_arc
>  	help
>  	  Select the version of gdb you wish to use.
> @@ -78,8 +78,8 @@ config BR2_GDB_VERSION
>  	string
>  	default "arc-2017.09-release-gdb" if BR2_arc
>  	default "7.10.1"   if BR2_GDB_VERSION_7_10
> -	default "7.11.1"   if BR2_GDB_VERSION_7_11 || !BR2_PACKAGE_HOST_GDB
> +	default "7.11.1"   if BR2_GDB_VERSION_7_11
>  	default "7.12.1"   if BR2_GDB_VERSION_7_12
> -	default "8.0.1"    if BR2_GDB_VERSION_8_0
> +	default "8.0.1"    if BR2_GDB_VERSION_8_0 || !BR2_PACKAGE_HOST_GDB
>  	default "8.1"      if BR2_GDB_VERSION_8_1
>  	depends on BR2_PACKAGE_GDB || BR2_PACKAGE_HOST_GDB
> -- 
> 2.14.3
>

Patch

diff --git a/package/gdb/Config.in.host b/package/gdb/Config.in.host
index ae9a7257dd..8324271283 100644
--- a/package/gdb/Config.in.host
+++ b/package/gdb/Config.in.host
@@ -45,7 +45,7 @@  config BR2_PACKAGE_HOST_GDB_SIM
 
 choice
 	prompt "GDB debugger Version"
-	default BR2_GDB_VERSION_7_11
+	default BR2_GDB_VERSION_8_0
 	depends on !BR2_arc
 	help
 	  Select the version of gdb you wish to use.
@@ -78,8 +78,8 @@  config BR2_GDB_VERSION
 	string
 	default "arc-2017.09-release-gdb" if BR2_arc
 	default "7.10.1"   if BR2_GDB_VERSION_7_10
-	default "7.11.1"   if BR2_GDB_VERSION_7_11 || !BR2_PACKAGE_HOST_GDB
+	default "7.11.1"   if BR2_GDB_VERSION_7_11
 	default "7.12.1"   if BR2_GDB_VERSION_7_12
-	default "8.0.1"    if BR2_GDB_VERSION_8_0
+	default "8.0.1"    if BR2_GDB_VERSION_8_0 || !BR2_PACKAGE_HOST_GDB
 	default "8.1"      if BR2_GDB_VERSION_8_1
 	depends on BR2_PACKAGE_GDB || BR2_PACKAGE_HOST_GDB