[1/1] package/libpqxx: needs gcc >= 4.9
diff mbox series

Message ID 20191015193901.29050-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series
  • [1/1] package/libpqxx: needs gcc >= 4.9
Related show

Commit Message

Fabrice Fontaine Oct. 15, 2019, 7:39 p.m. UTC
libpqxx uses brace-initialisation since version 6.3.0 and
https://github.com/jtv/libpqxx/commit/c93a4626f4d1311a9566f5d8d69052acf2082df9

Fixes:
 - http://autobuild.buildroot.org/results/3416a2eaa6b69014f733d38a17c161b024301534

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libpqxx/Config.in | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Oct. 16, 2019, 8:19 p.m. UTC | #1
On Tue, 15 Oct 2019 21:39:01 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> libpqxx uses brace-initialisation since version 6.3.0 and
> https://github.com/jtv/libpqxx/commit/c93a4626f4d1311a9566f5d8d69052acf2082df9
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/3416a2eaa6b69014f733d38a17c161b024301534
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libpqxx/Config.in | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

Applied to master, thanks.

Thomas

Patch
diff mbox series

diff --git a/package/libpqxx/Config.in b/package/libpqxx/Config.in
index 9553d7903c..d06451d792 100644
--- a/package/libpqxx/Config.in
+++ b/package/libpqxx/Config.in
@@ -2,7 +2,7 @@  config BR2_PACKAGE_LIBPQXX
 	bool "libpqxx"
 	depends on BR2_PACKAGE_POSTGRESQL
 	depends on BR2_TOOLCHAIN_HAS_THREADS
-	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++11
 	depends on BR2_INSTALL_LIBSTDCPP
 	help
 	  libpqxx is the official C++ client API for PostgreSQL, the
@@ -10,8 +10,8 @@  config BR2_PACKAGE_LIBPQXX
 
 	  http://pqxx.org/development/libpqxx/
 
-comment "libpqxx needs toolchain w/ C++, gcc >= 4.8, threads"
+comment "libpqxx needs toolchain w/ C++, gcc >= 4.9, threads"
 	depends on BR2_PACKAGE_POSTGRESQL
 	depends on !BR2_INSTALL_LIBSTDCPP || \
-		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || \
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
 		!BR2_TOOLCHAIN_HAS_THREADS