diff mbox series

[U-Boot,v2,02/37] cbfs: Add an enum and comment for the magic number

Message ID 20190708191856.138863-3-sjg@chromium.org
State Accepted
Commit 08b7bc3c3afd20b9fc62dd356c0e961e6dba5f26
Delegated to: Simon Glass
Headers show
Series binman: Add CBFS support | expand

Commit Message

Simon Glass July 8, 2019, 7:18 p.m. UTC
This field is not commented in the original file. Add a comment.

Signed-off-by: Simon Glass <sjg@chromium.org>
---

Changes in v2: None

 include/cbfs.h | 11 +++++++++++
 1 file changed, 11 insertions(+)
diff mbox series

Patch

diff --git a/include/cbfs.h b/include/cbfs.h
index bd1bf75bbfc..f2ede25f517 100644
--- a/include/cbfs.h
+++ b/include/cbfs.h
@@ -40,6 +40,17 @@  enum cbfs_filetype {
 	CBFS_TYPE_CMOS_LAYOUT = 0x01aa
 };
 
+enum {
+	CBFS_HEADER_MAGIC	= 0x4f524243,
+};
+
+/**
+ * struct cbfs_header - header at the start of a CBFS region
+ *
+ * All fields use big-endian format.
+ *
+ * @magic: Magic number (CBFS_HEADER_MAGIC)
+ */
 struct cbfs_header {
 	u32 magic;
 	u32 version;