diff mbox

[1/3] net: kill unused macros in head file

Message ID 4CF34DEC.6090907@cn.fujitsu.com
State Changes Requested, archived
Delegated to: David Miller
Headers show

Commit Message

Shan Wei Nov. 29, 2010, 6:53 a.m. UTC
These macros have been defined for several years since v2.6.12-rc2(tracing by git),
but never be used. So remove them.


Signed-off-by: Shan Wei <shanwei@cn.fujitsu.com>
---
 include/net/addrconf.h  |    2 --
 include/net/ip6_route.h |    1 -
 include/net/ndisc.h     |    6 ------
 include/net/snmp.h      |    1 -
 include/net/sock.h      |    3 ---
 include/net/tcp.h       |    6 ------
 6 files changed, 0 insertions(+), 19 deletions(-)

Comments

YOSHIFUJI Hideaki / 吉藤英明 Nov. 29, 2010, 7:42 a.m. UTC | #1
2010-11-29 14:53 +0800, Shan Wei wrote:
> These macros have been defined for several years since v2.6.12-rc2(tracing by git),
> but never be used. So remove them.
> 
> 
> Signed-off-by: Shan Wei <shanwei@cn.fujitsu.com>
> ---
>  include/net/addrconf.h  |    2 --
>  include/net/ip6_route.h |    1 -
>  include/net/ndisc.h     |    6 ------
>  include/net/snmp.h      |    1 -
>  include/net/sock.h      |    3 ---
>  include/net/tcp.h       |    6 ------
>  6 files changed, 0 insertions(+), 19 deletions(-)
> 
> diff --git a/include/net/addrconf.h b/include/net/addrconf.h
> index a944124..23710aa 100644
> --- a/include/net/addrconf.h
> +++ b/include/net/addrconf.h
> @@ -1,8 +1,6 @@
>  #ifndef _ADDRCONF_H
>  #define _ADDRCONF_H
>  
> -#define RETRANS_TIMER	HZ
> -
>  #define MAX_RTR_SOLICITATIONS		3
>  #define RTR_SOLICITATION_INTERVAL	(4*HZ)
>  

I think we should use it in net/ipv6/addrconf.c,
instead of magic number.

> diff --git a/include/net/ndisc.h b/include/net/ndisc.h
> index 895997b..f134987 100644
> --- a/include/net/ndisc.h
> +++ b/include/net/ndisc.h
> @@ -39,12 +39,6 @@ enum {
>  
>  #define MAX_RTR_SOLICITATION_DELAY	HZ
>  
> -#define ND_REACHABLE_TIME		(30*HZ)
> -#define ND_RETRANS_TIMER		HZ

ditto (in net/ipv6/ndisc.c)

--yoshfuji

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Shan Wei Nov. 29, 2010, 8:21 a.m. UTC | #2
Hi yoshifuji-san:

YOSHIFUJI Hideaki wrote, at 11/29/2010 03:42 PM:
>>  
>> -#define RETRANS_TIMER	HZ
>> -
>>  #define MAX_RTR_SOLICITATIONS		3
>>  #define RTR_SOLICITATION_INTERVAL	(4*HZ)
>>  
> 
> I think we should use it in net/ipv6/addrconf.c,
> instead of magic number.

Do you mean to replace all HZ in net/ipv6/addrconf.c with RETRANS_TIMER?

HZ is also a macro. And I think HZ is more easier to read than RETRANS_TIMER.
David Miller Dec. 1, 2010, 8:33 p.m. UTC | #3
From: Shan Wei <shanwei@cn.fujitsu.com>
Date: Mon, 29 Nov 2010 16:21:14 +0800

> Hi yoshifuji-san:
> 
> YOSHIFUJI Hideaki wrote, at 11/29/2010 03:42 PM:
>>>  
>>> -#define RETRANS_TIMER	HZ
>>> -
>>>  #define MAX_RTR_SOLICITATIONS		3
>>>  #define RTR_SOLICITATION_INTERVAL	(4*HZ)
>>>  
>> 
>> I think we should use it in net/ipv6/addrconf.c,
>> instead of magic number.
> 
> Do you mean to replace all HZ in net/ipv6/addrconf.c with RETRANS_TIMER?
> 
> HZ is also a macro. And I think HZ is more easier to read than RETRANS_TIMER.

These things currently say "1 * HZ" and "30 * HZ", so I think Hideaki's
request is reasonable.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/include/net/addrconf.h b/include/net/addrconf.h
index a944124..23710aa 100644
--- a/include/net/addrconf.h
+++ b/include/net/addrconf.h
@@ -1,8 +1,6 @@ 
 #ifndef _ADDRCONF_H
 #define _ADDRCONF_H
 
-#define RETRANS_TIMER	HZ
-
 #define MAX_RTR_SOLICITATIONS		3
 #define RTR_SOLICITATION_INTERVAL	(4*HZ)
 
diff --git a/include/net/ip6_route.h b/include/net/ip6_route.h
index 278312c..52c0550 100644
--- a/include/net/ip6_route.h
+++ b/include/net/ip6_route.h
@@ -3,7 +3,6 @@ 
 
 #define IP6_RT_PRIO_USER	1024
 #define IP6_RT_PRIO_ADDRCONF	256
-#define IP6_RT_PRIO_KERN	512
 
 struct route_info {
 	__u8			type;
diff --git a/include/net/ndisc.h b/include/net/ndisc.h
index 895997b..f134987 100644
--- a/include/net/ndisc.h
+++ b/include/net/ndisc.h
@@ -39,12 +39,6 @@  enum {
 
 #define MAX_RTR_SOLICITATION_DELAY	HZ
 
-#define ND_REACHABLE_TIME		(30*HZ)
-#define ND_RETRANS_TIMER		HZ
-
-#define ND_MIN_RANDOM_FACTOR		(1/2)
-#define ND_MAX_RANDOM_FACTOR		(3/2)
-
 #ifdef __KERNEL__
 
 #include <linux/compiler.h>
diff --git a/include/net/snmp.h b/include/net/snmp.h
index a0e6180..835c587 100644
--- a/include/net/snmp.h
+++ b/include/net/snmp.h
@@ -60,7 +60,6 @@  struct ipstats_mib {
 };
 
 /* ICMP */
-#define ICMP_MIB_DUMMY	__ICMP_MIB_MAX
 #define ICMP_MIB_MAX	(__ICMP_MIB_MAX + 1)
 
 struct icmp_mib {
diff --git a/include/net/sock.h b/include/net/sock.h
index 5557dfb..717cfbf 100644
--- a/include/net/sock.h
+++ b/include/net/sock.h
@@ -516,9 +516,6 @@  static __inline__ void sk_add_bind_node(struct sock *sk,
 #define sk_nulls_for_each_from(__sk, node) \
 	if (__sk && ({ node = &(__sk)->sk_nulls_node; 1; })) \
 		hlist_nulls_for_each_entry_from(__sk, node, sk_nulls_node)
-#define sk_for_each_continue(__sk, node) \
-	if (__sk && ({ node = &(__sk)->sk_node; 1; })) \
-		hlist_for_each_entry_continue(__sk, node, sk_node)
 #define sk_for_each_safe(__sk, node, tmp, list) \
 	hlist_for_each_entry_safe(__sk, node, tmp, list, sk_node)
 #define sk_for_each_bound(__sk, node, list) \
diff --git a/include/net/tcp.h b/include/net/tcp.h
index e36c874..ea819cc 100644
--- a/include/net/tcp.h
+++ b/include/net/tcp.h
@@ -100,12 +100,6 @@  extern void tcp_time_wait(struct sock *sk, int state, int timeo);
 #define TCP_SYNACK_RETRIES 5	/* number of times to retry passive opening a
 				 * connection: ~180sec is RFC minimum	*/
 
-
-#define TCP_ORPHAN_RETRIES 7	/* number of times to retry on an orphaned
-				 * socket. 7 is ~50sec-16min.
-				 */
-
-
 #define TCP_TIMEWAIT_LEN (60*HZ) /* how long to wait to destroy TIME-WAIT
 				  * state, about 60 seconds	*/
 #define TCP_FIN_TIMEOUT	TCP_TIMEWAIT_LEN