diff mbox

[RFC,v1,01/10] exec: Remove cpu from cpus list during cpu_exec_exit()

Message ID 1457074461-14285-2-git-send-email-bharata@linux.vnet.ibm.com
State New
Headers show

Commit Message

Bharata B Rao March 4, 2016, 6:54 a.m. UTC
CPUState *cpu gets added to the cpus list during cpu_exec_init(). It
should be removed from cpu_exec_exit().

cpu_exec_init() is called from generic CPU::instance_finalize and some
archs like PowerPC call it from CPU unrealizefn. So ensure that we
dequeue the cpu only once.

Now -1 value for cpu->cpu_index indicates that we have already dequeued
the cpu for CONFIG_USER_ONLY case also.

Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com>
---
 exec.c | 32 ++++++++++++++++++++++++--------
 1 file changed, 24 insertions(+), 8 deletions(-)

Comments

David Gibson March 7, 2016, 2:41 a.m. UTC | #1
On Fri, Mar 04, 2016 at 12:24:12PM +0530, Bharata B Rao wrote:
> CPUState *cpu gets added to the cpus list during cpu_exec_init(). It
> should be removed from cpu_exec_exit().
> 
> cpu_exec_init() is called from generic CPU::instance_finalize and some
> archs like PowerPC call it from CPU unrealizefn. So ensure that we
> dequeue the cpu only once.
> 
> Now -1 value for cpu->cpu_index indicates that we have already dequeued
> the cpu for CONFIG_USER_ONLY case also.
> 
> Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com>

Reviewed-by: David Gibson <david@gibson.dropbear.id.au>
Thomas Huth March 7, 2016, 4:23 p.m. UTC | #2
On 04.03.2016 07:54, Bharata B Rao wrote:
> CPUState *cpu gets added to the cpus list during cpu_exec_init(). It
> should be removed from cpu_exec_exit().
> 
> cpu_exec_init() is called from generic CPU::instance_finalize and some

s/cpu_exec_init/cpu_exec_exit/

> archs like PowerPC call it from CPU unrealizefn. So ensure that we
> dequeue the cpu only once.
> 
> Now -1 value for cpu->cpu_index indicates that we have already dequeued
> the cpu for CONFIG_USER_ONLY case also.
> 
> Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com>
> ---
>  exec.c | 32 ++++++++++++++++++++++++--------
>  1 file changed, 24 insertions(+), 8 deletions(-)
> 
> diff --git a/exec.c b/exec.c
> index c62c439..7c3f747 100644
> --- a/exec.c
> +++ b/exec.c
> @@ -588,15 +588,9 @@ static int cpu_get_free_index(Error **errp)
>      return cpu;
>  }
>  
> -void cpu_exec_exit(CPUState *cpu)
> +static void cpu_release_index(CPUState *cpu)
>  {
> -    if (cpu->cpu_index == -1) {
> -        /* cpu_index was never allocated by this @cpu or was already freed. */
> -        return;
> -    }
> -
>      bitmap_clear(cpu_index_map, cpu->cpu_index, 1);
> -    cpu->cpu_index = -1;
>  }
>  #else
>  
> @@ -611,11 +605,33 @@ static int cpu_get_free_index(Error **errp)
>      return cpu_index;
>  }
>  
> -void cpu_exec_exit(CPUState *cpu)
> +static void cpu_release_index(CPUState *cpu)
>  {
> +    return;

You could also simply leave that return statement away, I think.

>  }
>  #endif
>  
> +void cpu_exec_exit(CPUState *cpu)
> +{
> +#if defined(CONFIG_USER_ONLY)
> +    cpu_list_lock();
> +#endif
> +    if (cpu->cpu_index == -1) {
> +        /* cpu_index was never allocated by this @cpu or was already freed. */
> +#if defined(CONFIG_USER_ONLY)
> +        cpu_list_unlock();
> +#endif
> +        return;
> +    }
> +
> +    QTAILQ_REMOVE(&cpus, cpu, node);
> +    cpu_release_index(cpu);
> +    cpu->cpu_index = -1;
> +#if defined(CONFIG_USER_ONLY)
> +    cpu_list_unlock();
> +#endif
> +}

Since there are a couple of these

#if defined(CONFIG_USER_ONLY)
    cpu_list_[un]lock();
#endif

in exec.c already, it might be somewhat nices to declare them at the
beginning of the file as empty functions, somewhat like:

#if !defined(CONFIG_USER_ONLY)
static inline void cpu_list_lock(void)
{
}
static inline void cpu_list_unlock(void)
{
}
#endif

What do you think about that?

Apart from that, the patch looks fine to me.

 Thomas
Bharata B Rao March 9, 2016, 7:57 a.m. UTC | #3
On Mon, Mar 07, 2016 at 05:23:48PM +0100, Thomas Huth wrote:
> On 04.03.2016 07:54, Bharata B Rao wrote:
> > CPUState *cpu gets added to the cpus list during cpu_exec_init(). It
> > should be removed from cpu_exec_exit().
> > 
> > cpu_exec_init() is called from generic CPU::instance_finalize and some
> 
> s/cpu_exec_init/cpu_exec_exit/
> 
> > archs like PowerPC call it from CPU unrealizefn. So ensure that we
> > dequeue the cpu only once.
> > 
> > Now -1 value for cpu->cpu_index indicates that we have already dequeued
> > the cpu for CONFIG_USER_ONLY case also.
> > 
> > Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com>
> > ---
> >  exec.c | 32 ++++++++++++++++++++++++--------
> >  1 file changed, 24 insertions(+), 8 deletions(-)
> > 
> > diff --git a/exec.c b/exec.c
> > index c62c439..7c3f747 100644
> > --- a/exec.c
> > +++ b/exec.c
> > @@ -588,15 +588,9 @@ static int cpu_get_free_index(Error **errp)
> >      return cpu;
> >  }
> >  
> > -void cpu_exec_exit(CPUState *cpu)
> > +static void cpu_release_index(CPUState *cpu)
> >  {
> > -    if (cpu->cpu_index == -1) {
> > -        /* cpu_index was never allocated by this @cpu or was already freed. */
> > -        return;
> > -    }
> > -
> >      bitmap_clear(cpu_index_map, cpu->cpu_index, 1);
> > -    cpu->cpu_index = -1;
> >  }
> >  #else
> >  
> > @@ -611,11 +605,33 @@ static int cpu_get_free_index(Error **errp)
> >      return cpu_index;
> >  }
> >  
> > -void cpu_exec_exit(CPUState *cpu)
> > +static void cpu_release_index(CPUState *cpu)
> >  {
> > +    return;
> 
> You could also simply leave that return statement away, I think.
> 
> >  }
> >  #endif
> >  
> > +void cpu_exec_exit(CPUState *cpu)
> > +{
> > +#if defined(CONFIG_USER_ONLY)
> > +    cpu_list_lock();
> > +#endif
> > +    if (cpu->cpu_index == -1) {
> > +        /* cpu_index was never allocated by this @cpu or was already freed. */
> > +#if defined(CONFIG_USER_ONLY)
> > +        cpu_list_unlock();
> > +#endif
> > +        return;
> > +    }
> > +
> > +    QTAILQ_REMOVE(&cpus, cpu, node);
> > +    cpu_release_index(cpu);
> > +    cpu->cpu_index = -1;
> > +#if defined(CONFIG_USER_ONLY)
> > +    cpu_list_unlock();
> > +#endif
> > +}
> 
> Since there are a couple of these
> 
> #if defined(CONFIG_USER_ONLY)
>     cpu_list_[un]lock();
> #endif
> 
> in exec.c already, it might be somewhat nices to declare them at the
> beginning of the file as empty functions, somewhat like:
> 
> #if !defined(CONFIG_USER_ONLY)
> static inline void cpu_list_lock(void)
> {
> }
> static inline void cpu_list_unlock(void)
> {
> }
> #endif
> 
> What do you think about that?

If you and/or the maintainer insist/prefer, I can make the change.

Regards,
Bharata.
Thomas Huth March 9, 2016, 8:13 a.m. UTC | #4
On 09.03.2016 08:57, Bharata B Rao wrote:
> On Mon, Mar 07, 2016 at 05:23:48PM +0100, Thomas Huth wrote:
>> On 04.03.2016 07:54, Bharata B Rao wrote:
>>> CPUState *cpu gets added to the cpus list during cpu_exec_init(). It
>>> should be removed from cpu_exec_exit().
>>>
>>> cpu_exec_init() is called from generic CPU::instance_finalize and some
>>
>> s/cpu_exec_init/cpu_exec_exit/
>>
>>> archs like PowerPC call it from CPU unrealizefn. So ensure that we
>>> dequeue the cpu only once.
>>>
>>> Now -1 value for cpu->cpu_index indicates that we have already dequeued
>>> the cpu for CONFIG_USER_ONLY case also.
>>>
>>> Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com>
>>> ---
>>>  exec.c | 32 ++++++++++++++++++++++++--------
>>>  1 file changed, 24 insertions(+), 8 deletions(-)
>>>
>>> diff --git a/exec.c b/exec.c
>>> index c62c439..7c3f747 100644
>>> --- a/exec.c
>>> +++ b/exec.c
>>> @@ -588,15 +588,9 @@ static int cpu_get_free_index(Error **errp)
>>>      return cpu;
>>>  }
>>>  
>>> -void cpu_exec_exit(CPUState *cpu)
>>> +static void cpu_release_index(CPUState *cpu)
>>>  {
>>> -    if (cpu->cpu_index == -1) {
>>> -        /* cpu_index was never allocated by this @cpu or was already freed. */
>>> -        return;
>>> -    }
>>> -
>>>      bitmap_clear(cpu_index_map, cpu->cpu_index, 1);
>>> -    cpu->cpu_index = -1;
>>>  }
>>>  #else
>>>  
>>> @@ -611,11 +605,33 @@ static int cpu_get_free_index(Error **errp)
>>>      return cpu_index;
>>>  }
>>>  
>>> -void cpu_exec_exit(CPUState *cpu)
>>> +static void cpu_release_index(CPUState *cpu)
>>>  {
>>> +    return;
>>
>> You could also simply leave that return statement away, I think.
>>
>>>  }
>>>  #endif
>>>  
>>> +void cpu_exec_exit(CPUState *cpu)
>>> +{
>>> +#if defined(CONFIG_USER_ONLY)
>>> +    cpu_list_lock();
>>> +#endif
>>> +    if (cpu->cpu_index == -1) {
>>> +        /* cpu_index was never allocated by this @cpu or was already freed. */
>>> +#if defined(CONFIG_USER_ONLY)
>>> +        cpu_list_unlock();
>>> +#endif
>>> +        return;
>>> +    }
>>> +
>>> +    QTAILQ_REMOVE(&cpus, cpu, node);
>>> +    cpu_release_index(cpu);
>>> +    cpu->cpu_index = -1;
>>> +#if defined(CONFIG_USER_ONLY)
>>> +    cpu_list_unlock();
>>> +#endif
>>> +}
>>
>> Since there are a couple of these
>>
>> #if defined(CONFIG_USER_ONLY)
>>     cpu_list_[un]lock();
>> #endif
>>
>> in exec.c already, it might be somewhat nices to declare them at the
>> beginning of the file as empty functions, somewhat like:
>>
>> #if !defined(CONFIG_USER_ONLY)
>> static inline void cpu_list_lock(void)
>> {
>> }
>> static inline void cpu_list_unlock(void)
>> {
>> }
>> #endif
>>
>> What do you think about that?
> 
> If you and/or the maintainer insist/prefer, I can make the change.

It would be a nice way to get rid of some #if statements in the code,
but I don't insist on that change ... so feel free to keep the current
state, if you prefer it.

 Thomas
diff mbox

Patch

diff --git a/exec.c b/exec.c
index c62c439..7c3f747 100644
--- a/exec.c
+++ b/exec.c
@@ -588,15 +588,9 @@  static int cpu_get_free_index(Error **errp)
     return cpu;
 }
 
-void cpu_exec_exit(CPUState *cpu)
+static void cpu_release_index(CPUState *cpu)
 {
-    if (cpu->cpu_index == -1) {
-        /* cpu_index was never allocated by this @cpu or was already freed. */
-        return;
-    }
-
     bitmap_clear(cpu_index_map, cpu->cpu_index, 1);
-    cpu->cpu_index = -1;
 }
 #else
 
@@ -611,11 +605,33 @@  static int cpu_get_free_index(Error **errp)
     return cpu_index;
 }
 
-void cpu_exec_exit(CPUState *cpu)
+static void cpu_release_index(CPUState *cpu)
 {
+    return;
 }
 #endif
 
+void cpu_exec_exit(CPUState *cpu)
+{
+#if defined(CONFIG_USER_ONLY)
+    cpu_list_lock();
+#endif
+    if (cpu->cpu_index == -1) {
+        /* cpu_index was never allocated by this @cpu or was already freed. */
+#if defined(CONFIG_USER_ONLY)
+        cpu_list_unlock();
+#endif
+        return;
+    }
+
+    QTAILQ_REMOVE(&cpus, cpu, node);
+    cpu_release_index(cpu);
+    cpu->cpu_index = -1;
+#if defined(CONFIG_USER_ONLY)
+    cpu_list_unlock();
+#endif
+}
+
 void cpu_exec_init(CPUState *cpu, Error **errp)
 {
     CPUClass *cc = CPU_GET_CLASS(cpu);