diff mbox series

[SRU,R,v2,2/2] UBUNTU: SAUCE: bpf: Add missing NULL argument to zap_page_range_single

Message ID 20260825155524.338587-3-alice.munduruca@canonical.com
State New
Headers show
Series Resolute Stable Update v6.18.40, v7.1.5 bugs | expand

Commit Message

Alice C. Munduruca Aug. 25, 2026, 3:55 p.m. UTC
BugLink: https://bugs.launchpad.net/bugs/2165040

Renaming `zap_vma_range()` to `zap_page_range_single()` is insufficient,
since not only was the function previously renamed in commit 0326440c3545
("mm: rename zap_page_range_single() to zap_vma_range()"), but resolute
is also missing the commit de008c9ba568 ("mm/memory: remove "zap_details"
parameter from zap_page_range_single()") which was not considered in
the stable update.

This was not caught due to a validation build on CBD firing only for
tools, and thus skipping compilation errors in the kernel.

Signed-off-by: Alice C. Munduruca <alice.munduruca@canonical.com>
---
 kernel/bpf/arena.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/kernel/bpf/arena.c b/kernel/bpf/arena.c
index 29205106ee22..95b73d922089 100644
--- a/kernel/bpf/arena.c
+++ b/kernel/bpf/arena.c
@@ -719,7 +719,7 @@  static void zap_pages(struct bpf_arena *arena, long uaddr, long page_cnt)
 		vma = find_vma(mm, vm_start);
 		if (vma && vma->vm_start == vm_start &&
 		    vma->vm_file && vma->vm_file->private_data == &arena->map)
-			zap_page_range_single(vma, uaddr, size);
+			zap_page_range_single(vma, uaddr, size, NULL);
 		mmap_read_unlock(mm);
 		mmput(mm);