diff mbox series

UBUNTU: [Config] gcp: Disable CONFIG_DELL_SMBIOS_SMM, CONFIG_DELL_UART_BACKLIGHT, CONFIG_I2C_AMD_MP2

Message ID 20210420181141.30530-2-tim.gardner@canonical.com
State New
Headers show
Series UBUNTU: [Config] gcp: Disable CONFIG_DELL_SMBIOS_SMM, CONFIG_DELL_UART_BACKLIGHT, CONFIG_I2C_AMD_MP2 | expand

Commit Message

Tim Gardner April 20, 2021, 6:11 p.m. UTC
BugLink: https://bugs.launchpad.net/bugs/1925241

Enforcement annotations indicate that these config options should never have
been set.

Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
---
 debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules | 1 -
 debian.gcp/config/config.common.ubuntu         | 6 +++---
 2 files changed, 3 insertions(+), 4 deletions(-)

Comments

Stefan Bader April 21, 2021, 7:52 a.m. UTC | #1
On 20.04.21 20:11, Tim Gardner wrote:
> BugLink: https://bugs.launchpad.net/bugs/1925241
> 
> Enforcement annotations indicate that these config options should never have
> been set.
> 
> Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
> ---
>   debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules | 1 -
>   debian.gcp/config/config.common.ubuntu         | 6 +++---
>   2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> index a7cd5e6bf7ee..46c43d3d68e0 100644
> --- a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> +++ b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> @@ -959,7 +959,6 @@ dell-rbtn
>   dell-smbios
>   dell-smm-hwmon
>   dell-smo8800
> -dell-uart-backlight
>   dell-wmi
>   dell-wmi-aio
>   dell-wmi-descriptor
> diff --git a/debian.gcp/config/config.common.ubuntu b/debian.gcp/config/config.common.ubuntu
> index ecf964926e6e..61c0a4a685a5 100644
> --- a/debian.gcp/config/config.common.ubuntu
> +++ b/debian.gcp/config/config.common.ubuntu
> @@ -1669,10 +1669,10 @@ CONFIG_DELL_LAPTOP=m
>   CONFIG_DELL_RBTN=m
>   CONFIG_DELL_RBU=m
>   CONFIG_DELL_SMBIOS=m
> -CONFIG_DELL_SMBIOS_SMM=y
> +# CONFIG_DELL_SMBIOS_SMM is not set
>   CONFIG_DELL_SMBIOS_WMI=y
>   CONFIG_DELL_SMO8800=m
> -CONFIG_DELL_UART_BACKLIGHT=m
> +# CONFIG_DELL_UART_BACKLIGHT is not set

Does this ^ still compile or should there not be a change to the abi which drops 
the module (done to the current previous files which git puts into the right 
place when cranking and moving the open commit right after the last close, that 
just for additional info)?

-Stefan

>   CONFIG_DELL_WMI=m
>   CONFIG_DELL_WMI_AIO=m
>   CONFIG_DELL_WMI_DESCRIPTOR=m
> @@ -3027,7 +3027,7 @@ CONFIG_I2C_ALI15X3=m
>   CONFIG_I2C_AMD756=m
>   CONFIG_I2C_AMD756_S4882=m
>   CONFIG_I2C_AMD8111=m
> -CONFIG_I2C_AMD_MP2=y
> +# CONFIG_I2C_AMD_MP2 is not set
>   CONFIG_I2C_BOARDINFO=y
>   CONFIG_I2C_CBUS_GPIO=m
>   CONFIG_I2C_CHARDEV=y
>
Kleber Souza April 21, 2021, 8:36 a.m. UTC | #2
On 20.04.21 20:11, Tim Gardner wrote:
> BugLink: https://bugs.launchpad.net/bugs/1925241
> 
> Enforcement annotations indicate that these config options should never have
> been set.
> 
> Signed-off-by: Tim Gardner <tim.gardner@canonical.com>

Acked-by: Kleber Sacilotto de Souza <kleber.souza@canonical.com>

Thanks

> ---
>   debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules | 1 -
>   debian.gcp/config/config.common.ubuntu         | 6 +++---
>   2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> index a7cd5e6bf7ee..46c43d3d68e0 100644
> --- a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> +++ b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> @@ -959,7 +959,6 @@ dell-rbtn
>   dell-smbios
>   dell-smm-hwmon
>   dell-smo8800
> -dell-uart-backlight
>   dell-wmi
>   dell-wmi-aio
>   dell-wmi-descriptor
> diff --git a/debian.gcp/config/config.common.ubuntu b/debian.gcp/config/config.common.ubuntu
> index ecf964926e6e..61c0a4a685a5 100644
> --- a/debian.gcp/config/config.common.ubuntu
> +++ b/debian.gcp/config/config.common.ubuntu
> @@ -1669,10 +1669,10 @@ CONFIG_DELL_LAPTOP=m
>   CONFIG_DELL_RBTN=m
>   CONFIG_DELL_RBU=m
>   CONFIG_DELL_SMBIOS=m
> -CONFIG_DELL_SMBIOS_SMM=y
> +# CONFIG_DELL_SMBIOS_SMM is not set
>   CONFIG_DELL_SMBIOS_WMI=y
>   CONFIG_DELL_SMO8800=m
> -CONFIG_DELL_UART_BACKLIGHT=m
> +# CONFIG_DELL_UART_BACKLIGHT is not set
>   CONFIG_DELL_WMI=m
>   CONFIG_DELL_WMI_AIO=m
>   CONFIG_DELL_WMI_DESCRIPTOR=m
> @@ -3027,7 +3027,7 @@ CONFIG_I2C_ALI15X3=m
>   CONFIG_I2C_AMD756=m
>   CONFIG_I2C_AMD756_S4882=m
>   CONFIG_I2C_AMD8111=m
> -CONFIG_I2C_AMD_MP2=y
> +# CONFIG_I2C_AMD_MP2 is not set
>   CONFIG_I2C_BOARDINFO=y
>   CONFIG_I2C_CBUS_GPIO=m
>   CONFIG_I2C_CHARDEV=y
>
Tim Gardner April 21, 2021, 11:27 a.m. UTC | #3
On 4/21/21 1:52 AM, Stefan Bader wrote:
> On 20.04.21 20:11, Tim Gardner wrote:
>> BugLink: https://bugs.launchpad.net/bugs/1925241
>>
>> Enforcement annotations indicate that these config options should 
>> never have
>> been set.
>>
>> Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
>> ---
>>   debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules | 1 -
>>   debian.gcp/config/config.common.ubuntu         | 6 +++---
>>   2 files changed, 3 insertions(+), 4 deletions(-)
>>
>> diff --git a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules 
>> b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
>> index a7cd5e6bf7ee..46c43d3d68e0 100644
>> --- a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
>> +++ b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
>> @@ -959,7 +959,6 @@ dell-rbtn
>>   dell-smbios
>>   dell-smm-hwmon
>>   dell-smo8800
>> -dell-uart-backlight
>>   dell-wmi
>>   dell-wmi-aio
>>   dell-wmi-descriptor
>> diff --git a/debian.gcp/config/config.common.ubuntu 
>> b/debian.gcp/config/config.common.ubuntu
>> index ecf964926e6e..61c0a4a685a5 100644
>> --- a/debian.gcp/config/config.common.ubuntu
>> +++ b/debian.gcp/config/config.common.ubuntu
>> @@ -1669,10 +1669,10 @@ CONFIG_DELL_LAPTOP=m
>>   CONFIG_DELL_RBTN=m
>>   CONFIG_DELL_RBU=m
>>   CONFIG_DELL_SMBIOS=m
>> -CONFIG_DELL_SMBIOS_SMM=y
>> +# CONFIG_DELL_SMBIOS_SMM is not set
>>   CONFIG_DELL_SMBIOS_WMI=y
>>   CONFIG_DELL_SMO8800=m
>> -CONFIG_DELL_UART_BACKLIGHT=m
>> +# CONFIG_DELL_UART_BACKLIGHT is not set
> 
> Does this ^ still compile or should there not be a change to the abi 
> which drops the module (done to the current previous files which git 
> puts into the right place when cranking and moving the open commit right 
> after the last close, that just for additional info)?
> 
> -Stefan
> 

I'm confused. This does compile because dell-uart-backlight is removed 
from debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules in the immediately 
preceding diff.

rtg

-----------
Tim Gardner
Canonical, Inc
Stefan Bader April 21, 2021, 11:54 a.m. UTC | #4
On 21.04.21 13:27, Tim Gardner wrote:
> 
> 
> On 4/21/21 1:52 AM, Stefan Bader wrote:
>> On 20.04.21 20:11, Tim Gardner wrote:
>>> BugLink: https://bugs.launchpad.net/bugs/1925241
>>>
>>> Enforcement annotations indicate that these config options should never have
>>> been set.
>>>
>>> Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
>>> ---
>>>   debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules | 1 -
>>>   debian.gcp/config/config.common.ubuntu         | 6 +++---
>>>   2 files changed, 3 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules 
>>> b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
>>> index a7cd5e6bf7ee..46c43d3d68e0 100644
>>> --- a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
>>> +++ b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
>>> @@ -959,7 +959,6 @@ dell-rbtn
>>>   dell-smbios
>>>   dell-smm-hwmon
>>>   dell-smo8800
>>> -dell-uart-backlight
>>>   dell-wmi
>>>   dell-wmi-aio
>>>   dell-wmi-descriptor
>>> diff --git a/debian.gcp/config/config.common.ubuntu 
>>> b/debian.gcp/config/config.common.ubuntu
>>> index ecf964926e6e..61c0a4a685a5 100644
>>> --- a/debian.gcp/config/config.common.ubuntu
>>> +++ b/debian.gcp/config/config.common.ubuntu
>>> @@ -1669,10 +1669,10 @@ CONFIG_DELL_LAPTOP=m
>>>   CONFIG_DELL_RBTN=m
>>>   CONFIG_DELL_RBU=m
>>>   CONFIG_DELL_SMBIOS=m
>>> -CONFIG_DELL_SMBIOS_SMM=y
>>> +# CONFIG_DELL_SMBIOS_SMM is not set
>>>   CONFIG_DELL_SMBIOS_WMI=y
>>>   CONFIG_DELL_SMO8800=m
>>> -CONFIG_DELL_UART_BACKLIGHT=m
>>> +# CONFIG_DELL_UART_BACKLIGHT is not set
>>
>> Does this ^ still compile or should there not be a change to the abi which 
>> drops the module (done to the current previous files which git puts into the 
>> right place when cranking and moving the open commit right after the last 
>> close, that just for additional info)?
>>
>> -Stefan
>>
> 
> I'm confused. This does compile because dell-uart-backlight is removed from 
> debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules in the immediately preceding diff.

This is what one ends up with doing those reviews in the morning... that hunk 
was not visible to me then.

-Stefan
> 
> rtg
> 
> -----------
> Tim Gardner
> Canonical, Inc
Stefan Bader April 21, 2021, 11:54 a.m. UTC | #5
On 20.04.21 20:11, Tim Gardner wrote:
> BugLink: https://bugs.launchpad.net/bugs/1925241
> 
> Enforcement annotations indicate that these config options should never have
> been set.
> > Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Acked-by: Stefan Bader <stefan.bader@canonical.com>
> ---
>   debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules | 1 -
>   debian.gcp/config/config.common.ubuntu         | 6 +++---
>   2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> index a7cd5e6bf7ee..46c43d3d68e0 100644
> --- a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> +++ b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
> @@ -959,7 +959,6 @@ dell-rbtn
>   dell-smbios
>   dell-smm-hwmon
>   dell-smo8800
> -dell-uart-backlight
>   dell-wmi
>   dell-wmi-aio
>   dell-wmi-descriptor
> diff --git a/debian.gcp/config/config.common.ubuntu b/debian.gcp/config/config.common.ubuntu
> index ecf964926e6e..61c0a4a685a5 100644
> --- a/debian.gcp/config/config.common.ubuntu
> +++ b/debian.gcp/config/config.common.ubuntu
> @@ -1669,10 +1669,10 @@ CONFIG_DELL_LAPTOP=m
>   CONFIG_DELL_RBTN=m
>   CONFIG_DELL_RBU=m
>   CONFIG_DELL_SMBIOS=m
> -CONFIG_DELL_SMBIOS_SMM=y
> +# CONFIG_DELL_SMBIOS_SMM is not set
>   CONFIG_DELL_SMBIOS_WMI=y
>   CONFIG_DELL_SMO8800=m
> -CONFIG_DELL_UART_BACKLIGHT=m
> +# CONFIG_DELL_UART_BACKLIGHT is not set
>   CONFIG_DELL_WMI=m
>   CONFIG_DELL_WMI_AIO=m
>   CONFIG_DELL_WMI_DESCRIPTOR=m
> @@ -3027,7 +3027,7 @@ CONFIG_I2C_ALI15X3=m
>   CONFIG_I2C_AMD756=m
>   CONFIG_I2C_AMD756_S4882=m
>   CONFIG_I2C_AMD8111=m
> -CONFIG_I2C_AMD_MP2=y
> +# CONFIG_I2C_AMD_MP2 is not set
>   CONFIG_I2C_BOARDINFO=y
>   CONFIG_I2C_CBUS_GPIO=m
>   CONFIG_I2C_CHARDEV=y
>
diff mbox series

Patch

diff --git a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
index a7cd5e6bf7ee..46c43d3d68e0 100644
--- a/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
+++ b/debian.gcp/abi/5.8.0-1028.29/amd64/gcp.modules
@@ -959,7 +959,6 @@  dell-rbtn
 dell-smbios
 dell-smm-hwmon
 dell-smo8800
-dell-uart-backlight
 dell-wmi
 dell-wmi-aio
 dell-wmi-descriptor
diff --git a/debian.gcp/config/config.common.ubuntu b/debian.gcp/config/config.common.ubuntu
index ecf964926e6e..61c0a4a685a5 100644
--- a/debian.gcp/config/config.common.ubuntu
+++ b/debian.gcp/config/config.common.ubuntu
@@ -1669,10 +1669,10 @@  CONFIG_DELL_LAPTOP=m
 CONFIG_DELL_RBTN=m
 CONFIG_DELL_RBU=m
 CONFIG_DELL_SMBIOS=m
-CONFIG_DELL_SMBIOS_SMM=y
+# CONFIG_DELL_SMBIOS_SMM is not set
 CONFIG_DELL_SMBIOS_WMI=y
 CONFIG_DELL_SMO8800=m
-CONFIG_DELL_UART_BACKLIGHT=m
+# CONFIG_DELL_UART_BACKLIGHT is not set
 CONFIG_DELL_WMI=m
 CONFIG_DELL_WMI_AIO=m
 CONFIG_DELL_WMI_DESCRIPTOR=m
@@ -3027,7 +3027,7 @@  CONFIG_I2C_ALI15X3=m
 CONFIG_I2C_AMD756=m
 CONFIG_I2C_AMD756_S4882=m
 CONFIG_I2C_AMD8111=m
-CONFIG_I2C_AMD_MP2=y
+# CONFIG_I2C_AMD_MP2 is not set
 CONFIG_I2C_BOARDINFO=y
 CONFIG_I2C_CBUS_GPIO=m
 CONFIG_I2C_CHARDEV=y