mbox series

[SRU,O,v2,00/19] Introduce configfs-based interface for gpio-aggregator (LP: #2103496)

Message ID cover.1744694749.git.koichiro.den@canonical.com
Headers show
Series Introduce configfs-based interface for gpio-aggregator (LP: #2103496) | expand

Message

Koichiro Den April 15, 2025, 6:13 a.m. UTC
BugLink: https://bugs.launchpad.net/bugs/2103496

Bartosz Golaszewski (1):
  gpio: aggregator: simplify aggr_parse() with scoped bitmap

Dan Carpenter (5):
  UBUNTU: SAUCE: gpio: aggregator: Fix error code in
    gpio_aggregator_activate()
  UBUNTU: SAUCE: gpio: aggregator: fix "_sysfs" prefix check in
    gpio_aggregator_make_group()
  UBUNTU: SAUCE: gpio: aggregator: Fix gpio_aggregator_line_alloc()
    checking
  UBUNTU: SAUCE: gpio: aggregator: Return an error if there are no GPIOs
    in gpio_aggregator_parse()
  UBUNTU: SAUCE: gpio: aggregator: Fix leak in gpio_aggregator_parse()

Koichiro Den (13):
  gpio: introduce utilities for synchronous fake device creation
  gpio: aggregator: protect driver attr handlers against module unload
  gpio: aggregator: reorder functions to prepare for configfs
    introduction
  gpio: aggregator: unify function naming
  gpio: aggregator: add gpio_aggregator_{alloc,free}()
  gpio: aggregator: introduce basic configfs interface
  UBUNTU: [Config] updateconfigs for DEV_SYNC_PROBE
  gpio: aggregator: rename 'name' to 'key' in gpio_aggregator_parse()
  gpio: aggregator: expose aggregator created via legacy sysfs to
    configfs
  gpio: aggregator: cancel deferred probe for devices created via
    configfs
  Documentation: gpio: document configfs interface for gpio-aggregator
  selftests: gpio: add test cases for gpio-aggregator
  UBUNTU: SAUCE: selftests: gpio: gpio-aggregator: add a test case for
    _sysfs prefix reservation

 .../admin-guide/gpio/gpio-aggregator.rst      |  107 ++
 debian.master/config/annotations              |    1 +
 drivers/gpio/Kconfig                          |    5 +
 drivers/gpio/Makefile                         |    3 +
 drivers/gpio/dev-sync-probe.c                 |   97 ++
 drivers/gpio/dev-sync-probe.h                 |   25 +
 drivers/gpio/gpio-aggregator.c                | 1094 ++++++++++++++---
 tools/testing/selftests/gpio/Makefile         |    2 +-
 tools/testing/selftests/gpio/config           |    1 +
 .../testing/selftests/gpio/gpio-aggregator.sh |  727 +++++++++++
 10 files changed, 1907 insertions(+), 155 deletions(-)
 create mode 100644 drivers/gpio/dev-sync-probe.c
 create mode 100644 drivers/gpio/dev-sync-probe.h
 create mode 100755 tools/testing/selftests/gpio/gpio-aggregator.sh

Comments

Stefan Bader April 22, 2025, 5:12 p.m. UTC | #1
On 15.04.25 08:13, Koichiro Den wrote:
> BugLink: https://bugs.launchpad.net/bugs/2103496
> 
> Bartosz Golaszewski (1):
>    gpio: aggregator: simplify aggr_parse() with scoped bitmap
> 
> Dan Carpenter (5):
>    UBUNTU: SAUCE: gpio: aggregator: Fix error code in
>      gpio_aggregator_activate()
>    UBUNTU: SAUCE: gpio: aggregator: fix "_sysfs" prefix check in
>      gpio_aggregator_make_group()
>    UBUNTU: SAUCE: gpio: aggregator: Fix gpio_aggregator_line_alloc()
>      checking
>    UBUNTU: SAUCE: gpio: aggregator: Return an error if there are no GPIOs
>      in gpio_aggregator_parse()
>    UBUNTU: SAUCE: gpio: aggregator: Fix leak in gpio_aggregator_parse()
> 
> Koichiro Den (13):
>    gpio: introduce utilities for synchronous fake device creation
>    gpio: aggregator: protect driver attr handlers against module unload
>    gpio: aggregator: reorder functions to prepare for configfs
>      introduction
>    gpio: aggregator: unify function naming
>    gpio: aggregator: add gpio_aggregator_{alloc,free}()
>    gpio: aggregator: introduce basic configfs interface
>    UBUNTU: [Config] updateconfigs for DEV_SYNC_PROBE
>    gpio: aggregator: rename 'name' to 'key' in gpio_aggregator_parse()
>    gpio: aggregator: expose aggregator created via legacy sysfs to
>      configfs
>    gpio: aggregator: cancel deferred probe for devices created via
>      configfs
>    Documentation: gpio: document configfs interface for gpio-aggregator
>    selftests: gpio: add test cases for gpio-aggregator
>    UBUNTU: SAUCE: selftests: gpio: gpio-aggregator: add a test case for
>      _sysfs prefix reservation
> 
>   .../admin-guide/gpio/gpio-aggregator.rst      |  107 ++
>   debian.master/config/annotations              |    1 +
>   drivers/gpio/Kconfig                          |    5 +
>   drivers/gpio/Makefile                         |    3 +
>   drivers/gpio/dev-sync-probe.c                 |   97 ++
>   drivers/gpio/dev-sync-probe.h                 |   25 +
>   drivers/gpio/gpio-aggregator.c                | 1094 ++++++++++++++---
>   tools/testing/selftests/gpio/Makefile         |    2 +-
>   tools/testing/selftests/gpio/config           |    1 +
>   .../testing/selftests/gpio/gpio-aggregator.sh |  727 +++++++++++
>   10 files changed, 1907 insertions(+), 155 deletions(-)
>   create mode 100644 drivers/gpio/dev-sync-probe.c
>   create mode 100644 drivers/gpio/dev-sync-probe.h
>   create mode 100755 tools/testing/selftests/gpio/gpio-aggregator.sh
> 

Rejected for the following reasons:
- Oracular support will be ending "soon" (July 2025). For that reason it 
does not make sense to add additional features at this point.

-Stefan