| Message ID | 20260902051911.3542655-1-chris.chiu@canonical.com |
|---|---|
| Headers | show |
| Series | Fix SDCA jack detection race and reprobe issues on Dell Slate Max platform with CirrusLogic audio solution | expand |
Rejected for the following reasons: Rejected as per conversation, v4 is already on the mailing list On 9/2/26 08:19, Chris Chiu via kernel-team wrote: > BugLink: https://bugs.launchpad.net/bugs/2163215 > > v2 change: > - Added missing fix commit 36c543cc5100 ("ASoC: SDCA: Fix bad move of > jack_state initialisation") which fixes cb3c257e0824 ("ASoC: SDCA: > Add correct masks whilst reporting SDCA jack status"). Without this > commit, the jack_state initialisation was accidentally moved after > its use, causing incorrect jack detection behavior. > > v3 change: > - Remove the non-essential patches which only do refactoring > > Charles Keepax (7): > ASoC: SDCA: Rename sdca_irq_allocate() to include devm > ASoC: SDCA: Add sdca_irq_cleanup_late() > ASoC: SDCA: Remove devm from primary IRQ cleanup > ASoC: SDCA: Populate IRQ data earlier > ASoC: Add a component fixup_controls callback > ASoC: SDCA: Switch to fixup_controls callback for IRQ registration > ASoC: SDCA: Move kcontrol search out of IRQ > > include/sound/sdca_fdl.h | 2 + > include/sound/sdca_interrupts.h | 14 ++- > include/sound/sdca_jack.h | 3 + > include/sound/soc-component.h | 2 + > sound/soc/sdca/sdca_class.c | 4 +- > sound/soc/sdca/sdca_class_function.c | 6 +- > sound/soc/sdca/sdca_fdl.c | 13 +- > sound/soc/sdca/sdca_interrupts.c | 174 +++++++++++++++------------ > sound/soc/sdca/sdca_jack.c | 114 ++++++++++++------ > sound/soc/soc-component.c | 10 ++ > sound/soc/soc-core.c | 5 + > 11 files changed, 226 insertions(+), 121 deletions(-) >
BugLink: https://bugs.launchpad.net/bugs/2163215 v2 change: - Added missing fix commit 36c543cc5100 ("ASoC: SDCA: Fix bad move of jack_state initialisation") which fixes cb3c257e0824 ("ASoC: SDCA: Add correct masks whilst reporting SDCA jack status"). Without this commit, the jack_state initialisation was accidentally moved after its use, causing incorrect jack detection behavior. v3 change: - Remove the non-essential patches which only do refactoring Charles Keepax (7): ASoC: SDCA: Rename sdca_irq_allocate() to include devm ASoC: SDCA: Add sdca_irq_cleanup_late() ASoC: SDCA: Remove devm from primary IRQ cleanup ASoC: SDCA: Populate IRQ data earlier ASoC: Add a component fixup_controls callback ASoC: SDCA: Switch to fixup_controls callback for IRQ registration ASoC: SDCA: Move kcontrol search out of IRQ include/sound/sdca_fdl.h | 2 + include/sound/sdca_interrupts.h | 14 ++- include/sound/sdca_jack.h | 3 + include/sound/soc-component.h | 2 + sound/soc/sdca/sdca_class.c | 4 +- sound/soc/sdca/sdca_class_function.c | 6 +- sound/soc/sdca/sdca_fdl.c | 13 +- sound/soc/sdca/sdca_interrupts.c | 174 +++++++++++++++------------ sound/soc/sdca/sdca_jack.c | 114 ++++++++++++------ sound/soc/soc-component.c | 10 ++ sound/soc/soc-core.c | 5 + 11 files changed, 226 insertions(+), 121 deletions(-)