diff mbox

[U-Boot,ATMEL] Fix compiler error for cpu at91sam9, if lowlevel init is enabled

Message ID 4E0AF2F7.7060100@bus-elektronik.de
State Accepted
Delegated to: Reinhard Meyer
Headers show

Commit Message

esw@bus-elektronik.de June 29, 2011, 9:40 a.m. UTC
* Fix compiler error for cpu at91sam9, if lowlevel init is enabled
* use correct ATMEL_ name scheme to define ATMEL_BASE_SDRAMC

Signed-off-by: Jens Scharsig
---
 arch/arm/include/asm/arch-at91/at91sam9_sdramc.h |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Reinhard Meyer June 30, 2011, 8:54 a.m. UTC | #1
Dear esw@bus-elektronik.de,
> * Fix compiler error for cpu at91sam9, if lowlevel init is enabled
> * use correct ATMEL_ name scheme to define ATMEL_BASE_SDRAMC
> 
> Signed-off-by: Jens Scharsig
> ---
>  arch/arm/include/asm/arch-at91/at91sam9_sdramc.h |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
Applied to u-boot-atmel/master.
Thanks,
Reinhard

PS: for better readability of Submitter it would be nice
to have real names with the e-Mail address ;)
esw@bus-elektronik.de June 30, 2011, 9:51 a.m. UTC | #2
Am 2011-06-30 10:54, schrieb Reinhard Meyer:
> 
> PS: for better readability of Submitter it would be nice
> to have real names with the e-Mail address ;)

Dear Reinhard Meyer,

sorry about this. I used a different computer than usual to create this
patch.

Best regards

Jens Scharsig
Albert ARIBAUD July 3, 2011, 9:06 p.m. UTC | #3
Hi Jens,

Le 30/06/2011 11:51, Jens Scharsig a écrit :
> Am 2011-06-30 10:54, schrieb Reinhard Meyer:
>>
>> PS: for better readability of Submitter it would be nice
>> to have real names with the e-Mail address ;)
>
> Dear Reinhard Meyer,
>
> sorry about this. I used a different computer than usual to create this
> patch.

While I am fixing author names in commits, do you want me to fix this 
one, and if so, which e-mail address should I put as an author?

> Best regards
>
> Jens Scharsig

Amicalement,
esw@bus-elektronik.de July 4, 2011, 6:09 a.m. UTC | #4
Am 2011-07-03 23:06, schrieb Albert ARIBAUD:
> Hi Jens,
> 
> Le 30/06/2011 11:51, Jens Scharsig a écrit :
>> Am 2011-06-30 10:54, schrieb Reinhard Meyer:
>>>
>>> PS: for better readability of Submitter it would be nice
>>> to have real names with the e-Mail address ;)
>>
>> Dear Reinhard Meyer,
>>
>> sorry about this. I used a different computer than usual to create this
>> patch.
> 
> While I am fixing author names in commits, do you want me to fix this 
> one, and if so, which e-mail address should I put as an author?

Jens Scharsig <esw@bus-elektronik.de>

Best regards

Jens Scharsig
Reinhard Meyer July 4, 2011, 7:28 a.m. UTC | #5
Dear Albert,

thanks for fixing the names.

My assumption of needing an afteernoon to get a new GIT up and running
was too optimistic... After ubuntu 10.10 offered an automated upgrade
to 11.04, I happyly accepted this and ended up with a broken installation
that stops in grub, complaining there is no kernel...

Now installing 11.04 from scratch...

Best Regards,
Reinhard
diff mbox

Patch

diff --git a/arch/arm/include/asm/arch-at91/at91sam9_sdramc.h
b/arch/arm/include/asm/arch-at91/at91sam9_sdramc.h
index 54159a7..2d4c49e 100644
--- a/arch/arm/include/asm/arch-at91/at91sam9_sdramc.h
+++ b/arch/arm/include/asm/arch-at91/at91sam9_sdramc.h
@@ -20,7 +20,7 @@ 
 #ifdef __ASSEMBLY__

 #ifndef ATMEL_BASE_SDRAMC
-#define ATMEL_BASE_SDRAMC	AT91_SDRAMC0_BASE
+#define ATMEL_BASE_SDRAMC	ATMEL_BASE_SDRAMC0
 #endif

 #define AT91_ASM_SDRAMC_MR	ATMEL_BASE_SDRAMC