diff mbox series

net: fix phy_string_for_interface

Message ID 20220510224910.12553-1-tharvey@gateworks.com
State Accepted, archived
Delegated to: Ramon Fried
Headers show
Series net: fix phy_string_for_interface | expand

Commit Message

Tim Harvey May 10, 2022, 10:49 p.m. UTC
commit ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to
PHY_INTERFACE_MODE_NA") broke the phy_string_for_interface function.
Fix it.

Fixes ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to PHY_INTERFACE_MODE_NA")
Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Cc: Marek Behún <marek.behun@nic.cz>
Cc: Stefan Roese <sr@denx.de>
Cc: Ramon Fried <rfried.dev@gmail.com>
Cc: Vladimir Oltean <vladimir.oltean@nxp.com>
---
 include/phy_interface.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Stefan Roese May 11, 2022, 5 a.m. UTC | #1
On 11.05.22 00:49, Tim Harvey wrote:
> commit ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to
> PHY_INTERFACE_MODE_NA") broke the phy_string_for_interface function.
> Fix it.
> 
> Fixes ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to PHY_INTERFACE_MODE_NA")
> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
> Cc: Marek Behún <marek.behun@nic.cz>
> Cc: Stefan Roese <sr@denx.de>
> Cc: Ramon Fried <rfried.dev@gmail.com>
> Cc: Vladimir Oltean <vladimir.oltean@nxp.com>

Reviewed-by: Stefan Roese <sr@denx.de>

Thanks,
Stefan

> ---
>   include/phy_interface.h | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/include/phy_interface.h b/include/phy_interface.h
> index ce3b5004ec22..fed3357b9a26 100644
> --- a/include/phy_interface.h
> +++ b/include/phy_interface.h
> @@ -85,7 +85,7 @@ static const char * const backplane_mode_strings[] = {
>   static inline const char *phy_string_for_interface(phy_interface_t i)
>   {
>   	/* Default to unknown */
> -	if (i > PHY_INTERFACE_MODE_NA)
> +	if (i >= PHY_INTERFACE_MODE_MAX)
>   		i = PHY_INTERFACE_MODE_NA;
>   
>   	return phy_interface_strings[i];

Viele Grüße,
Stefan Roese
Marek Behún May 11, 2022, 10:58 a.m. UTC | #2
On Tue, 10 May 2022 15:49:10 -0700
Tim Harvey <tharvey@gateworks.com> wrote:

> commit ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to
> PHY_INTERFACE_MODE_NA") broke the phy_string_for_interface function.
> Fix it.
> 
> Fixes ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to PHY_INTERFACE_MODE_NA")
> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
> Cc: Marek Behún <marek.behun@nic.cz>
> Cc: Stefan Roese <sr@denx.de>
> Cc: Ramon Fried <rfried.dev@gmail.com>
> Cc: Vladimir Oltean <vladimir.oltean@nxp.com>
> ---
>  include/phy_interface.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/include/phy_interface.h b/include/phy_interface.h
> index ce3b5004ec22..fed3357b9a26 100644
> --- a/include/phy_interface.h
> +++ b/include/phy_interface.h
> @@ -85,7 +85,7 @@ static const char * const backplane_mode_strings[] = {
>  static inline const char *phy_string_for_interface(phy_interface_t i)
>  {
>  	/* Default to unknown */
> -	if (i > PHY_INTERFACE_MODE_NA)
> +	if (i >= PHY_INTERFACE_MODE_MAX)
>  		i = PHY_INTERFACE_MODE_NA;
>  
>  	return phy_interface_strings[i];

Yikes.

Reviewed-by: Marek Behún <marek.behun@nic.cz>
Ramon Fried May 16, 2022, 12:26 a.m. UTC | #3
On Wed, May 11, 2022 at 1:58 PM Marek Behún <marek.behun@nic.cz> wrote:
>
> On Tue, 10 May 2022 15:49:10 -0700
> Tim Harvey <tharvey@gateworks.com> wrote:
>
> > commit ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to
> > PHY_INTERFACE_MODE_NA") broke the phy_string_for_interface function.
> > Fix it.
> >
> > Fixes ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to PHY_INTERFACE_MODE_NA")
> > Signed-off-by: Tim Harvey <tharvey@gateworks.com>
> > Cc: Marek Behún <marek.behun@nic.cz>
> > Cc: Stefan Roese <sr@denx.de>
> > Cc: Ramon Fried <rfried.dev@gmail.com>
> > Cc: Vladimir Oltean <vladimir.oltean@nxp.com>
> > ---
> >  include/phy_interface.h | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/include/phy_interface.h b/include/phy_interface.h
> > index ce3b5004ec22..fed3357b9a26 100644
> > --- a/include/phy_interface.h
> > +++ b/include/phy_interface.h
> > @@ -85,7 +85,7 @@ static const char * const backplane_mode_strings[] = {
> >  static inline const char *phy_string_for_interface(phy_interface_t i)
> >  {
> >       /* Default to unknown */
> > -     if (i > PHY_INTERFACE_MODE_NA)
> > +     if (i >= PHY_INTERFACE_MODE_MAX)
> >               i = PHY_INTERFACE_MODE_NA;
> >
> >       return phy_interface_strings[i];
>
> Yikes.
>
> Reviewed-by: Marek Behún <marek.behun@nic.cz>
Reviewed-by: Ramon Fried <rfried.dev@gmail.com>
Tom Rini May 23, 2022, 5:58 p.m. UTC | #4
On Tue, May 10, 2022 at 03:49:10PM -0700, Tim Harvey wrote:

> commit ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to
> PHY_INTERFACE_MODE_NA") broke the phy_string_for_interface function.
> Fix it.
> 
> Fixes ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to PHY_INTERFACE_MODE_NA")
> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
> Cc: Marek Behún <marek.behun@nic.cz>
> Cc: Stefan Roese <sr@denx.de>
> Cc: Ramon Fried <rfried.dev@gmail.com>
> Cc: Vladimir Oltean <vladimir.oltean@nxp.com>
> Reviewed-by: Stefan Roese <sr@denx.de>
> Reviewed-by: Marek Behún <marek.behun@nic.cz>
> Reviewed-by: Ramon Fried <rfried.dev@gmail.com>

Applied to u-boot/master, thanks!
diff mbox series

Patch

diff --git a/include/phy_interface.h b/include/phy_interface.h
index ce3b5004ec22..fed3357b9a26 100644
--- a/include/phy_interface.h
+++ b/include/phy_interface.h
@@ -85,7 +85,7 @@  static const char * const backplane_mode_strings[] = {
 static inline const char *phy_string_for_interface(phy_interface_t i)
 {
 	/* Default to unknown */
-	if (i > PHY_INTERFACE_MODE_NA)
+	if (i >= PHY_INTERFACE_MODE_MAX)
 		i = PHY_INTERFACE_MODE_NA;
 
 	return phy_interface_strings[i];