diff mbox series

[2/5] pytest: Lower pygit2 requirement

Message ID 20210226125231.7476-2-trini@konsulko.com
State Accepted
Delegated to: Tom Rini
Headers show
Series [1/5] GitLab: Remove "tags" stanzas | expand

Commit Message

Tom Rini Feb. 26, 2021, 12:52 p.m. UTC
The latest versions of pygit2 are not available in practically any
distribution at this time.  Furthermore, we don't need the latest in
order to run all of our testsuites.  Reduce this version requirement to
something older that meets our needs while still supporting running our
tests on older hosts (and so, test labs).

Reported-by: Tom Warren <twarren@nvidia.com>
Signed-off-by: Tom Rini <trini@konsulko.com>
---
 test/py/requirements.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Tom Rini April 7, 2021, 11:06 p.m. UTC | #1
On Fri, Feb 26, 2021 at 07:52:28AM -0500, Tom Rini wrote:

> The latest versions of pygit2 are not available in practically any
> distribution at this time.  Furthermore, we don't need the latest in
> order to run all of our testsuites.  Reduce this version requirement to
> something older that meets our needs while still supporting running our
> tests on older hosts (and so, test labs).
> 
> Reported-by: Tom Warren <twarren@nvidia.com>
> Signed-off-by: Tom Rini <trini@konsulko.com>

Applied to u-boot/master, thanks!
diff mbox series

Patch

diff --git a/test/py/requirements.txt b/test/py/requirements.txt
index 926bccad694f..89ca259b213b 100644
--- a/test/py/requirements.txt
+++ b/test/py/requirements.txt
@@ -11,7 +11,7 @@  pbr==5.4.3
 pluggy==0.13.0
 py==1.8.0
 pyelftools==0.27
-pygit2==1.4.0
+pygit2==0.28.2
 pyparsing==2.4.2
 pytest==5.2.1
 python-mimeparse==1.6.0