diff mbox

[U-Boot,v2,2/4] Add definitions for OpenRD-Client and OpenRD-Ultimate

Message ID 1303170450-4230-3-git-send-email-clint@debian.org
State Superseded
Headers show

Commit Message

Clint Adams April 18, 2011, 11:47 p.m. UTC
---
 MAKEALL                       |    2 ++
 board/Marvell/openrd/openrd.c |    6 ++++++
 boards.cfg                    |    2 ++
 include/configs/openrd.h      |   14 +++++++++++++-
 4 files changed, 23 insertions(+), 1 deletions(-)

Comments

Wolfgang Denk April 25, 2011, 10:11 p.m. UTC | #1
Dear Clint Adams,

In message <1303170450-4230-3-git-send-email-clint@debian.org> you wrote:
> ---
>  MAKEALL                       |    2 ++
>  board/Marvell/openrd/openrd.c |    6 ++++++
>  boards.cfg                    |    2 ++
>  include/configs/openrd.h      |   14 +++++++++++++-
>  4 files changed, 23 insertions(+), 1 deletions(-)

Signed-off-by line missing.  NAK.

Best regards,

Wolfgang Denk
Wolfgang Denk April 25, 2011, 10:12 p.m. UTC | #2
Dear Clint Adams,

In message <1303170450-4230-3-git-send-email-clint@debian.org> you wrote:
> ---
>  MAKEALL                       |    2 ++
>  board/Marvell/openrd/openrd.c |    6 ++++++
>  boards.cfg                    |    2 ++
>  include/configs/openrd.h      |   14 +++++++++++++-
>  4 files changed, 23 insertions(+), 1 deletions(-)

Signed-off-by line missing, NAK.

Also, there is a lot of Coding Style issues (indentation not by TAB).

Please fix globally, and use checkpatch to verify result.


Best regards,

Wolfgang Denk
Clint Adams April 26, 2011, 1:17 a.m. UTC | #3
Changes for v4:
   - Various commit log and whitespace tweaks

Clint Adams (4):
  Rename openrd_base files to openrd
  Add definitions for OpenRD-Client and OpenRD-Ultimate
  Initialize second PHY on OpenRD-Client and OpenRD-Ultimate
  Enable multiple fs options for Marvell SoC family on OpenRD boards

 MAKEALL                                            |    2 +
 board/Marvell/{openrd_base => openrd}/Makefile     |    2 +-
 board/Marvell/{openrd_base => openrd}/kwbimage.cfg |    0
 .../{openrd_base/openrd_base.c => openrd/openrd.c} |   33 +++++++++++++++++---
 .../{openrd_base/openrd_base.h => openrd/openrd.h} |    0
 boards.cfg                                         |    4 ++-
 include/configs/{openrd_base.h => openrd.h}        |   33 +++++++++++++++++---
 7 files changed, 62 insertions(+), 12 deletions(-)
 rename board/Marvell/{openrd_base => openrd}/Makefile (98%)
 rename board/Marvell/{openrd_base => openrd}/kwbimage.cfg (100%)
 rename board/Marvell/{openrd_base/openrd_base.c => openrd/openrd.c} (80%)
 rename board/Marvell/{openrd_base/openrd_base.h => openrd/openrd.h} (100%)
 rename include/configs/{openrd_base.h => openrd.h} (81%)
Clint Adams April 26, 2011, 1:20 a.m. UTC | #4
On Tue, Apr 26, 2011 at 12:12:36AM +0200, Wolfgang Denk wrote:
> Please fix globally, and use checkpatch to verify result.

Thanks, that appears to be this:
http://kernel.org/pub/linux/kernel/people/apw/checkpatch/
Prafulla Wadaskar May 3, 2011, 12:01 p.m. UTC | #5
> -----Original Message-----
> From: Clint Adams [mailto:clint@debian.org]
> Sent: Tuesday, April 26, 2011 6:47 AM
> To: u-boot@lists.denx.de
> Cc: Albert ARIBAUD; Prafulla Wadaskar; Wolfgang Denk; Clint Adams
> Subject: [PATCH v4 0/4] OpenRD-Client and OpenRD-Ultimate support
> 
> Changes for v4:
>    - Various commit log and whitespace tweaks
> 
> Clint Adams (4):
>   Rename openrd_base files to openrd
>   Add definitions for OpenRD-Client and OpenRD-Ultimate
>   Initialize second PHY on OpenRD-Client and OpenRD-Ultimate
>   Enable multiple fs options for Marvell SoC family on OpenRD boards
> 
>  MAKEALL                                            |    2 +
>  board/Marvell/{openrd_base => openrd}/Makefile     |    2 +-
>  board/Marvell/{openrd_base => openrd}/kwbimage.cfg |    0
>  .../{openrd_base/openrd_base.c => openrd/openrd.c} |   33
> +++++++++++++++++---
>  .../{openrd_base/openrd_base.h => openrd/openrd.h} |    0
>  boards.cfg                                         |    4 ++-
>  include/configs/{openrd_base.h => openrd.h}        |   33
> +++++++++++++++++---
>  7 files changed, 62 insertions(+), 12 deletions(-)
>  rename board/Marvell/{openrd_base => openrd}/Makefile (98%)
>  rename board/Marvell/{openrd_base => openrd}/kwbimage.cfg (100%)
>  rename board/Marvell/{openrd_base/openrd_base.c => openrd/openrd.c}
> (80%)
>  rename board/Marvell/{openrd_base/openrd_base.h => openrd/openrd.h}
> (100%)
>  rename include/configs/{openrd_base.h => openrd.h} (81%)
> 

Hi Clint

I have rebased u-boot-marvell.git master branch
I am unable to apply this patch series cleanly to this rebased branch.

Kindly please provide the new patch series for the same.

Regards..
Prafulla . .
Clint Adams May 3, 2011, 3 p.m. UTC | #6
Changes for v5:
   - rebase against current u-boot-marvell.git/master

Clint Adams (4):
  Rename openrd_base files to openrd
  Add definitions for OpenRD-Client and OpenRD-Ultimate
  Initialize second PHY on OpenRD-Client and OpenRD-Ultimate
  Enable multiple fs options for Marvell SoC family on OpenRD boards

 MAKEALL                                            |    2 +
 board/Marvell/{openrd_base => openrd}/Makefile     |    2 +-
 board/Marvell/{openrd_base => openrd}/kwbimage.cfg |    0
 .../{openrd_base/openrd_base.c => openrd/openrd.c} |   33 +++++++++++++++++---
 .../{openrd_base/openrd_base.h => openrd/openrd.h} |    0
 boards.cfg                                         |    4 ++-
 include/configs/{openrd_base.h => openrd.h}        |   33 +++++++++++++++++---
 7 files changed, 62 insertions(+), 12 deletions(-)
 rename board/Marvell/{openrd_base => openrd}/Makefile (98%)
 rename board/Marvell/{openrd_base => openrd}/kwbimage.cfg (100%)
 rename board/Marvell/{openrd_base/openrd_base.c => openrd/openrd.c} (80%)
 rename board/Marvell/{openrd_base/openrd_base.h => openrd/openrd.h} (100%)
 rename include/configs/{openrd_base.h => openrd.h} (81%)
Prafulla Wadaskar May 6, 2011, 1:20 p.m. UTC | #7
> -----Original Message-----
> From: Clint Adams [mailto:clint@debian.org]
> Sent: Tuesday, May 03, 2011 8:31 PM
> To: u-boot@lists.denx.de
> Cc: Albert ARIBAUD; Prafulla Wadaskar; Wolfgang Denk; Ashish Karkare;
> Prabhanjan Sarnaik; Clint Adams
> Subject: [PATCH v5 0/4] OpenRD-Client and OpenRD-Ultimate support
> 
> Changes for v5:
>    - rebase against current u-boot-marvell.git/master
> 
> Clint Adams (4):
>   Rename openrd_base files to openrd
>   Add definitions for OpenRD-Client and OpenRD-Ultimate
>   Initialize second PHY on OpenRD-Client and OpenRD-Ultimate
>   Enable multiple fs options for Marvell SoC family on OpenRD boards
> 
>  MAKEALL                                            |    2 +
>  board/Marvell/{openrd_base => openrd}/Makefile     |    2 +-
>  board/Marvell/{openrd_base => openrd}/kwbimage.cfg |    0
>  .../{openrd_base/openrd_base.c => openrd/openrd.c} |   33
> +++++++++++++++++---
>  .../{openrd_base/openrd_base.h => openrd/openrd.h} |    0
>  boards.cfg                                         |    4 ++-
>  include/configs/{openrd_base.h => openrd.h}        |   33
> +++++++++++++++++---
>  7 files changed, 62 insertions(+), 12 deletions(-)
>  rename board/Marvell/{openrd_base => openrd}/Makefile (98%)
>  rename board/Marvell/{openrd_base => openrd}/kwbimage.cfg (100%)
>  rename board/Marvell/{openrd_base/openrd_base.c => openrd/openrd.c}
> (80%)
>  rename board/Marvell/{openrd_base/openrd_base.h => openrd/openrd.h}
> (100%)
>  rename include/configs/{openrd_base.h => openrd.h} (81%)
> 

Applied this patch series to u-boot-marvell.git/master branch

Regards..
Prafulla . .
diff mbox

Patch

diff --git a/MAKEALL b/MAKEALL
index 6acece7..9e7fd02 100755
--- a/MAKEALL
+++ b/MAKEALL
@@ -361,6 +361,8 @@  LIST_ARM9="			\
 	omap5912osk		\
 	omap730p2		\
 	openrd_base		\
+	openrd_client		\
+	openrd_ultimate		\
 	rd6281a			\
 	sbc2410x		\
 	scb9328			\
diff --git a/board/Marvell/openrd/openrd.c b/board/Marvell/openrd/openrd.c
index e53fa16..14ca88e 100644
--- a/board/Marvell/openrd/openrd.c
+++ b/board/Marvell/openrd/openrd.c
@@ -110,7 +110,13 @@  int board_init(void)
 	/*
 	 * arch number of board
 	 */
+#if defined(CONFIG_BOARD_IS_OPENRD_BASE)
 	gd->bd->bi_arch_number = MACH_TYPE_OPENRD_BASE;
+#elif defined(CONFIG_BOARD_IS_OPENRD_CLIENT)
+	gd->bd->bi_arch_number = MACH_TYPE_OPENRD_CLIENT;
+#elif defined(CONFIG_BOARD_IS_OPENRD_ULTIMATE)
+	gd->bd->bi_arch_number = MACH_TYPE_OPENRD_ULTIMATE;
+#endif
 
 	/* adress of boot parameters */
 	gd->bd->bi_boot_params = kw_sdram_bar(0) + 0x100;
diff --git a/boards.cfg b/boards.cfg
index 40a4476..ef38006 100644
--- a/boards.cfg
+++ b/boards.cfg
@@ -97,6 +97,8 @@  suen3                        arm         arm926ejs   km_arm              keymile
 guruplug                     arm         arm926ejs   -                   Marvell        kirkwood
 mv88f6281gtw_ge              arm         arm926ejs   -                   Marvell        kirkwood
 openrd_base                  arm         arm926ejs   openrd              Marvell        kirkwood        openrd:BOARD_IS_OPENRD_BASE
+openrd_client                arm         arm926ejs   openrd              Marvell        kirkwood        openrd:BOARD_IS_OPENRD_CLIENT
+openrd_ultimate              arm         arm926ejs   openrd              Marvell        kirkwood        openrd:BOARD_IS_OPENRD_ULTIMATE
 rd6281a                      arm         arm926ejs   -                   Marvell        kirkwood
 sheevaplug                   arm         arm926ejs   -                   Marvell        kirkwood
 dockstar                     arm         arm926ejs   -                   Seagate        kirkwood
diff --git a/include/configs/openrd.h b/include/configs/openrd.h
index 13dc34c..7299749 100644
--- a/include/configs/openrd.h
+++ b/include/configs/openrd.h
@@ -33,7 +33,19 @@ 
 /*
  * Version number information
  */
-#define CONFIG_IDENT_STRING	"\nOpenRD_base"
+#ifdef CONFIG_BOARD_IS_OPENRD_ULTIMATE
+# define CONFIG_IDENT_STRING	"\nOpenRD-Ultimate"
+#else
+# ifdef CONFIG_BOARD_IS_OPENRD_CLIENT
+#  define CONFIG_IDENT_STRING	"\nOpenRD-Client"
+# else
+#  ifdef CONFIG_BOARD_IS_OPENRD_BASE
+#   define CONFIG_IDENT_STRING	"\nOpenRD-Base"
+#  else
+#   error Unknown OpenRD board specified
+#  endif
+# endif
+#endif
 
 /*
  * High Level Configuration Options (easy to change)