diff mbox

[U-Boot] config_cmd_defaults.h: new header for common u-boot command defaults

Message ID 1292889429-19902-1-git-send-email-vapier@gentoo.org
State Accepted
Commit 52f0aa835fd6caf5f094b551e435f5c9506d61df
Delegated to: Wolfgang Denk
Headers show

Commit Message

Mike Frysinger Dec. 20, 2010, 11:57 p.m. UTC
We have config_defaults.h which are random configuration settings that
everyone gets by default.  We also have config_cmd_default.h which is a
recommended list of defaults but boards have to opt into.  Now we have
config_cmd_defaults.h which is a list of defaults that everyone gets
and has to actively opt out of.

For now, we populate it with the bootm command which previously was
unable to be disabled.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 common/Makefile               |    2 +-
 include/config_cmd_defaults.h |   14 ++++++++++++++
 mkconfig                      |    1 +
 3 files changed, 16 insertions(+), 1 deletions(-)
 create mode 100644 include/config_cmd_defaults.h

Comments

Wolfgang Denk Jan. 9, 2011, 5:01 p.m. UTC | #1
Dear Mike Frysinger,

In message <1292889429-19902-1-git-send-email-vapier@gentoo.org> you wrote:
> We have config_defaults.h which are random configuration settings that
> everyone gets by default.  We also have config_cmd_default.h which is a
> recommended list of defaults but boards have to opt into.  Now we have
> config_cmd_defaults.h which is a list of defaults that everyone gets
> and has to actively opt out of.
> 
> For now, we populate it with the bootm command which previously was
> unable to be disabled.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
> ---
>  common/Makefile               |    2 +-
>  include/config_cmd_defaults.h |   14 ++++++++++++++
>  mkconfig                      |    1 +
>  3 files changed, 16 insertions(+), 1 deletions(-)
>  create mode 100644 include/config_cmd_defaults.h

Applied, thanks.

Best regards,

Wolfgang Denk
diff mbox

Patch

diff --git a/common/Makefile b/common/Makefile
index abea91c..048df0c 100644
--- a/common/Makefile
+++ b/common/Makefile
@@ -41,7 +41,7 @@  COBJS-y += xyzModem.o
 
 # core command
 COBJS-y += cmd_boot.o
-COBJS-y += cmd_bootm.o
+COBJS-$(CONFIG_CMD_BOOTM) += cmd_bootm.o
 COBJS-y += cmd_help.o
 COBJS-y += cmd_nvedit.o
 COBJS-y += cmd_version.o
diff --git a/include/config_cmd_defaults.h b/include/config_cmd_defaults.h
new file mode 100644
index 0000000..9283daa
--- /dev/null
+++ b/include/config_cmd_defaults.h
@@ -0,0 +1,14 @@ 
+/*
+ * config_cmd_defaults.h - sane defaults for everyone
+ *
+ * Copyright (c) 2010 Analog Devices Inc.
+ *
+ * Licensed under the GPL-2 or later.
+ */
+
+#ifndef _CONFIG_CMD_DEFAULTS_H_
+#define _CONFIG_CMD_DEFAULTS_H_
+
+#define CONFIG_CMD_BOOTM 1
+
+#endif
diff --git a/mkconfig b/mkconfig
index 2fda1d4..db69336 100755
--- a/mkconfig
+++ b/mkconfig
@@ -155,6 +155,7 @@  done
 
 cat << EOF >> config.h
 #define CONFIG_BOARDDIR board/$BOARDDIR
+#include <config_cmd_defaults.h>
 #include <config_defaults.h>
 #include <configs/${CONFIG_NAME}.h>
 #include <asm/config.h>