Show patches with: Submitter = Philippe Mathieu-Daudé       |    State = Action Required       |    Archived = No       |   103 patches
« 1 2 »
Patch Series A/F/R/T S/W/F Date Submitter Delegate State
[v3,32/32] cpu: Only check SSTEP_ENABLE flag in cpu_single_stepping() accel: Unassorted cleanups around debugging - 1 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,31/32] cpu: Rename CPUState @singlestep_enabled -> @singlestep_flags accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,30/32] cpu: Introduce cpu_single_stepping() helper accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,29/32] cpu: Better name cpu_single_step() trace event accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,28/32] accel/tcg: Improve docstrings around TCGCPUOps::*watchpoint* handlers accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,27/32] target/ppc: Ensure TCG is used in ppc_update_daw() accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,26/32] target/arm: Inline check_watchpoints() in arm_debug_check_watchpoint() accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,25/32] accel: Use GdbBreakpointType enum accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,24/32] gdbstub: Introduce GdbBreakpointType enumerator accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,23/32] gdbstub: Reduce @type variable scope accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,22/32] gdbstub/user: Directly call gdb_breakpoint_remove_all() in user mode accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,21/32] accel: Remove unnecessary 'inline' qualifier in remove_all_breakpoints accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,20/32] cpu: Define BreakpointFlags type accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,19/32] cpu: Move BREAKPOINT definitions to 'exec/breakpoint.h' accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,18/32] cpu: Move cpu_breakpoint_test out of line accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,17/32] accel: Remove AccelOpsClass::supports_guest_debug accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,16/32] accel: Hold @can_reverse information in AccelGdbConfig accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,15/32] gdbstub: Make default replay_mode value explicit in stubs accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,14/32] accel: Have each implementation return their AccelGdbConfig accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,13/32] gdbstub: Move supported_sstep_flags in AccelGdbConfig structure accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,12/32] gdbstub: Reduce gdb_supports_guest_debug() scope accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,11/32] accel/kvm: Hold have_guest_debug in KVMState accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,10/32] accel/kvm: Simplify kvm_init() w.r.t. TARGET_KVM_HAVE_GUEST_DEBUG accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,09/32] accel/kvm: Always define AccelOpsClass::supports_guest_debug accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,08/32] accel/whpx: Implement missing AccelClass::gdbstub_supported_sstep_flags accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,07/32] gdbstub: Only return E22 when reverse GDB is not supported accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,06/32] gdbstub: Add trace event for STEP packet handler accel: Unassorted cleanups around debugging 1 - 1 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,05/32] accel/mshv: Replace @dirty field by generic CPUState::vcpu_dirty field accel: Unassorted cleanups around debugging - - 1 1 --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,04/32] accel/hvf: Remove left-over comment accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,03/32] accel/tcg: Restrict tlb_protect/unprotect_code() to TCG accel: Unassorted cleanups around debugging - - 3 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,02/32] target/i386: Remove duplicate tlb_flush() call in cpu_post_load() accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v3,01/32] cpu: Constify CPUState::cc (cached CPUClass pointer) accel: Unassorted cleanups around debugging - - 3 - --- 2026-07-05 Philippe Mathieu-Daudé New
[v2,33/33] cpu: Only check SSTEP_ENABLE flag in cpu_single_stepping() accel: Unassorted cleanups around debugging - 1 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,32/33] cpu: Rename CPUState @singlestep_enabled -> @singlestep_flags accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,31/33] cpu: Introduce cpu_single_stepping() helper accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,30/33] cpu: Better name cpu_single_step() trace event accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,29/33] cpu: Move CPUWatchpoint definition to 'exec/watchpoint.h' accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,28/33] accel/tcg: Improve docstrings around TCGCPUOps::*watchpoint* handlers accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,27/33] target/ppc: Ensure TCG is used in ppc_update_daw() accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,26/33] target/arm: Inline check_watchpoints() in arm_debug_check_watchpoint() accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,25/33] accel: Use GdbBreakpointType enum accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,24/33] gdbstub: Introduce GdbBreakpointType enumerator accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,23/33] gdbstub: Reduce @type variable scope accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,22/33] gdbstub/user: Directly call gdb_breakpoint_remove_all() in user mode accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,21/33] accel: Remove unnecessary 'inline' qualifier in remove_all_breakpoints accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,20/33] cpu: Define BreakpointFlags type accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,19/33] cpu: Move BREAKPOINT definitions to 'exec/breakpoint.h' accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,18/33] cpu: Move cpu_breakpoint_test out of line accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,17/33] accel: Remove AccelOpsClass::supports_guest_debug accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,16/33] accel: Hold @can_reverse information in AccelGdbConfig accel: Unassorted cleanups around debugging - - - - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,15/33] gdbstub: Make default replay_mode value explicit in stubs accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,14/33] accel: Have each implementation return their AccelGdbConfig accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,13/33] gdbstub: Move supported_sstep_flags in AccelGdbConfig structure accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,12/33] gdbstub: Inline gdb_supports_guest_debug() accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,11/33] accel/kvm: Hold have_guest_debug in KVMState accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,10/33] accel/kvm: Simplify kvm_init() w.r.t. TARGET_KVM_HAVE_GUEST_DEBUG accel: Unassorted cleanups around debugging - - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,09/33] accel/kvm: Always define AccelOpsClass::supports_guest_debug accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,08/33] accel/whpx: Implement missing AccelClass::gdbstub_supported_sstep_flags accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,07/33] gdbstub: Only return E22 when reverse GDB is not supported accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,06/33] gdbstub: Add trace event for STEP packet handler accel: Unassorted cleanups around debugging 1 - 1 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,05/33] accel/mshv: Replace @dirty field by generic CPUState::vcpu_dirty field accel: Unassorted cleanups around debugging - - 1 1 --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,04/33] accel/hvf: Remove left-over comment accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,03/33] accel/tcg: Restrict tlb_protect/unprotect_code() to TCG accel: Unassorted cleanups around debugging - - 3 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,02/33] target/i386: Remove duplicate tlb_flush() call in cpu_post_load() accel: Unassorted cleanups around debugging - - 2 - --- 2026-07-03 Philippe Mathieu-Daudé New
[v2,01/33] cpu: Constify CPUState::cc (cached CPUClass pointer) accel: Unassorted cleanups around debugging - - 3 - --- 2026-07-03 Philippe Mathieu-Daudé New
[33/33] cpu: Only check SSTEP_ENABLE flag in cpu_single_stepping() accel: Unassorted cleanups around debugging - 1 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[32/33] cpu: Rename CPUState @singlestep_enabled -> @singlestep_flags accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[31/33] cpu: Introduce cpu_single_stepping() helper accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[30/33] cpu: Better name cpu_single_step() trace event accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[29/33] cpu: Move CPUWatchpoint definition to 'exec/watchpoint.h' accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[28/33] accel/tcg: Improve docstrings around TCGCPUOps::*watchpoint* handlers accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[27/33] target/ppc: Ensure TCG is used in ppc_update_daw() accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[26/33] target/xtensa: Move watchpoints handling to check_hw_watchpoints() accel: Unassorted cleanups around debugging - - - - --- 2026-06-30 Philippe Mathieu-Daudé New
[25/33] target/arm: Factor arm_check_watchpoint_hit() out accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[24/33] target/arm: Inline check_watchpoints() in arm_debug_check_watchpoint() accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[23/33] accel: Use GdbBreakpointType enum accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[22/33] gdbstub: Introduce GdbBreakpointType enumerator accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[21/33] gdbstub: Reduce @type variable scope accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[20/33] gdbstub/user: Directly call gdb_breakpoint_remove_all() in user mode accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[19/33] accel: Remove unnecessary 'inline' qualifier in remove_all_breakpoints accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[18/33] cpu: Define BreakpointFlags type accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[17/33] cpu: Move BREAKPOINT definitions to 'exec/breakpoint.h' accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[16/33] accel/kvm: Hold gdbstub_sstep_flags in KVMState accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[15/33] accel/kvm: Hold have_guest_supported in KVMState accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[14/33] accel: Move supports_guest_debug() declaration to AccelClass accel: Unassorted cleanups around debugging - - 4 - --- 2026-06-30 Philippe Mathieu-Daudé New
[13/33] accel: Have get_gdbstub_config() return @can_reverse value accel: Unassorted cleanups around debugging - - - - --- 2026-06-30 Philippe Mathieu-Daudé New
[12/33] gdbstub: Make default replay_mode value explicit in stubs accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[11/33] gdbstub: Store @can_reverse in GDBState accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[10/33] accel: Change gdbstub_supported_sstep_flags() -> get_gdbstub_config() accel: Unassorted cleanups around debugging - - - - --- 2026-06-30 Philippe Mathieu-Daudé New
[09/33] accel/kvm: Simplify kvm_init() w.r.t. TARGET_KVM_HAVE_GUEST_DEBUG accel: Unassorted cleanups around debugging - - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[08/33] accel/kvm: Always define AccelOpsClass::supports_guest_debug accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[07/33] gdbstub: Only return E22 when reverse GDB is not supported accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[06/33] gdbstub: Add trace event for STEP packet handler accel: Unassorted cleanups around debugging 1 - 1 - --- 2026-06-30 Philippe Mathieu-Daudé New
[05/33] accel/mshv: Replace @dirty field by generic CPUState::vcpu_dirty field accel: Unassorted cleanups around debugging - - 1 1 --- 2026-06-30 Philippe Mathieu-Daudé New
[04/33] accel/hvf: Remove left-over comment accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[03/33] accel/tcg: Restrict tlb_protect/unprotect_code() to TCG accel: Unassorted cleanups around debugging - - 3 - --- 2026-06-30 Philippe Mathieu-Daudé New
[02/33] target/i386: Remove duplicate tlb_flush() call in cpu_post_load() accel: Unassorted cleanups around debugging - - 2 - --- 2026-06-30 Philippe Mathieu-Daudé New
[01/33] cpu: Constify CPUState::cc (cached CPUClass pointer) accel: Unassorted cleanups around debugging - - 3 - --- 2026-06-30 Philippe Mathieu-Daudé New
[RFC,v2,4/4] target/tcg: Rename set_rounding_mode() helpers target/tcg: Rename some helpers common to various targets - - 4 - --- 2026-06-23 Philippe Mathieu-Daudé New
[RFC,v2,3/4] target/tcg: Rename raise_exception() helpers target/tcg: Rename some helpers common to various targets - - 2 - --- 2026-06-23 Philippe Mathieu-Daudé New
« 1 2 »