diff mbox

[Qemu-trivial,1/5] vnc: pass bool pararmeter for vnc_connect

Message ID 51B70F11.7090101@msgid.tls.msk.ru
State New
Headers show

Commit Message

Michael Tokarev June 11, 2013, 11:50 a.m. UTC
11.06.2013 09:15, liguang wrote:
> type last parameter of vnc_connect if bool,
> so pass 'false' instead of '0' for it.

There's another parameter in here, `skipauth', which should be
bool in vnc_connect(), and should be bool in vnc_display_add_client()
too.

Also, there's no big point in splitting 1/5 and 2/5 (vnc_listen_read),
I think.

Does something like the below look ok? (not even compile-tested)
(and I'd really rename `skipauth' to `doauth' everywhere, to mean
exactly the opposite so that we don't have double negatives, but
it is too late already)

From: Michael Tokarev <mjt@tls.msk.ru>
Date:   Tue Jun 11 15:42:44 2013 +0400

    vnc: use booleans for vnc_connect, vnc_listen_read and vnc_display_add_client

    Some arguments to these functions are booleans - either by declaration,
    or by actual usage, but sometimes value of 0 or 1 is passed for a bool,
    and sometimes it is declared as int but a bool value, or true/false,
    is passed to it instead.  Clean it up a bit.

    Cc: liguang <lig.fnst@cn.fujitsu.com>
    Signed-off-by: Michael Tokarev <mjt@tls.msk.ru>

Comments

liguang June 18, 2013, 2:34 a.m. UTC | #1
在 2013-06-11二的 15:50 +0400,Michael Tokarev写道:
> 11.06.2013 09:15, liguang wrote:
> > type last parameter of vnc_connect if bool,
> > so pass 'false' instead of '0' for it.
> 
> There's another parameter in here, `skipauth', which should be
> bool in vnc_connect(), and should be bool in vnc_display_add_client()
> too.
> 
> Also, there's no big point in splitting 1/5 and 2/5 (vnc_listen_read),
> I think.
> 
> Does something like the below look ok? (not even compile-tested)

OK for me.

> (and I'd really rename `skipauth' to `doauth' everywhere, to mean
> exactly the opposite so that we don't have double negatives, but
> it is too late already)
> 
> From: Michael Tokarev <mjt@tls.msk.ru>
> Date:   Tue Jun 11 15:42:44 2013 +0400
> 
>     vnc: use booleans for vnc_connect, vnc_listen_read and vnc_display_add_client
> 
>     Some arguments to these functions are booleans - either by declaration,
>     or by actual usage, but sometimes value of 0 or 1 is passed for a bool,
>     and sometimes it is declared as int but a bool value, or true/false,
>     is passed to it instead.  Clean it up a bit.
> 
>     Cc: liguang <lig.fnst@cn.fujitsu.com>
>     Signed-off-by: Michael Tokarev <mjt@tls.msk.ru>
> 
> diff --git a/include/ui/console.h b/include/ui/console.h
> index f1d79f9..98edf41 100644
> --- a/include/ui/console.h
> +++ b/include/ui/console.h
> @@ -314,7 +314,7 @@ void cocoa_display_init(DisplayState *ds, int full_screen);
>  /* vnc.c */
>  void vnc_display_init(DisplayState *ds);
>  void vnc_display_open(DisplayState *ds, const char *display, Error **errp);
> -void vnc_display_add_client(DisplayState *ds, int csock, int skipauth);
> +void vnc_display_add_client(DisplayState *ds, int csock, bool skipauth);
>  char *vnc_display_local_addr(DisplayState *ds);
>  #ifdef CONFIG_VNC
>  int vnc_display_password(DisplayState *ds, const char *password);
> diff --git a/ui/vnc.c b/ui/vnc.c
> index dfc7459..5601cc3 100644
> --- a/ui/vnc.c
> +++ b/ui/vnc.c
> @@ -2771,7 +2771,8 @@ static void vnc_refresh(DisplayChangeListener *dcl)
>      }
>  }
> 
> -static void vnc_connect(VncDisplay *vd, int csock, int skipauth, bool websocket)
> +static void vnc_connect(VncDisplay *vd, int csock,
> +                        bool skipauth, bool websocket)
>  {
>      VncState *vs = g_malloc0(sizeof(VncState));
>      int i;
> @@ -2883,19 +2884,19 @@ static void vnc_listen_read(void *opaque, bool websocket)
>      }
> 
>      if (csock != -1) {
> -        vnc_connect(vs, csock, 0, websocket);
> +        vnc_connect(vs, csock, false, websocket);
>      }
>  }
> 
>  static void vnc_listen_regular_read(void *opaque)
>  {
> -    vnc_listen_read(opaque, 0);
> +    vnc_listen_read(opaque, false);
>  }
> 
>  #ifdef CONFIG_VNC_WS
>  static void vnc_listen_websocket_read(void *opaque)
>  {
> -    vnc_listen_read(opaque, 1);
> +    vnc_listen_read(opaque, true);
>  }
>  #endif /* CONFIG_VNC_WS */
> 
> @@ -3283,7 +3284,7 @@ void vnc_display_open(DisplayState *ds, const char *display, Error **errp)
>          if (csock < 0) {
>              goto fail;
>          }
> -        vnc_connect(vs, csock, 0, 0);
> +        vnc_connect(vs, csock, false, false);
>      } else {
>          /* listen for connects */
>          char *dpy;
> @@ -3341,9 +3342,9 @@ fail:
>  #endif /* CONFIG_VNC_WS */
>  }
> 
> -void vnc_display_add_client(DisplayState *ds, int csock, int skipauth)
> +void vnc_display_add_client(DisplayState *ds, int csock, bool skipauth)
>  {
>      VncDisplay *vs = vnc_display;
> 
> -    vnc_connect(vs, csock, skipauth, 0);
> +    vnc_connect(vs, csock, skipauth, false);
>  }
> 
>
Michael Tokarev June 18, 2013, 2:35 a.m. UTC | #2
11.06.2013 15:50, Michael Tokarev wrote:
> 11.06.2013 09:15, liguang wrote:
>> type last parameter of vnc_connect if bool,
>> so pass 'false' instead of '0' for it.
> 
> There's another parameter in here, `skipauth', which should be
> bool in vnc_connect(), and should be bool in vnc_display_add_client()
> too.
> 
> Also, there's no big point in splitting 1/5 and 2/5 (vnc_listen_read),
> I think.
> 
> Does something like the below look ok? (not even compile-tested)
> (and I'd really rename `skipauth' to `doauth' everywhere, to mean
> exactly the opposite so that we don't have double negatives, but
> it is too late already)

Hello.

Do you want/plan to respin the series, addressing comments?
Are you okay with my version?

Thanks!

/mjt
liguang June 18, 2013, 2:36 a.m. UTC | #3
在 2013-06-18二的 06:35 +0400,Michael Tokarev写道:
> 11.06.2013 15:50, Michael Tokarev wrote:
> > 11.06.2013 09:15, liguang wrote:
> >> type last parameter of vnc_connect if bool,
> >> so pass 'false' instead of '0' for it.
> > 
> > There's another parameter in here, `skipauth', which should be
> > bool in vnc_connect(), and should be bool in vnc_display_add_client()
> > too.
> > 
> > Also, there's no big point in splitting 1/5 and 2/5 (vnc_listen_read),
> > I think.
> > 
> > Does something like the below look ok? (not even compile-tested)
> > (and I'd really rename `skipauth' to `doauth' everywhere, to mean
> > exactly the opposite so that we don't have double negatives, but
> > it is too late already)
> 
> Hello.
> 
> Do you want/plan to respin the series, addressing comments?
> Are you okay with my version?
> 

Yes, I'm little busy now, but I'll re-spin as soon as possible.
diff mbox

Patch

diff --git a/include/ui/console.h b/include/ui/console.h
index f1d79f9..98edf41 100644
--- a/include/ui/console.h
+++ b/include/ui/console.h
@@ -314,7 +314,7 @@  void cocoa_display_init(DisplayState *ds, int full_screen);
 /* vnc.c */
 void vnc_display_init(DisplayState *ds);
 void vnc_display_open(DisplayState *ds, const char *display, Error **errp);
-void vnc_display_add_client(DisplayState *ds, int csock, int skipauth);
+void vnc_display_add_client(DisplayState *ds, int csock, bool skipauth);
 char *vnc_display_local_addr(DisplayState *ds);
 #ifdef CONFIG_VNC
 int vnc_display_password(DisplayState *ds, const char *password);
diff --git a/ui/vnc.c b/ui/vnc.c
index dfc7459..5601cc3 100644
--- a/ui/vnc.c
+++ b/ui/vnc.c
@@ -2771,7 +2771,8 @@  static void vnc_refresh(DisplayChangeListener *dcl)
     }
 }

-static void vnc_connect(VncDisplay *vd, int csock, int skipauth, bool websocket)
+static void vnc_connect(VncDisplay *vd, int csock,
+                        bool skipauth, bool websocket)
 {
     VncState *vs = g_malloc0(sizeof(VncState));
     int i;
@@ -2883,19 +2884,19 @@  static void vnc_listen_read(void *opaque, bool websocket)
     }

     if (csock != -1) {
-        vnc_connect(vs, csock, 0, websocket);
+        vnc_connect(vs, csock, false, websocket);
     }
 }

 static void vnc_listen_regular_read(void *opaque)
 {
-    vnc_listen_read(opaque, 0);
+    vnc_listen_read(opaque, false);
 }

 #ifdef CONFIG_VNC_WS
 static void vnc_listen_websocket_read(void *opaque)
 {
-    vnc_listen_read(opaque, 1);
+    vnc_listen_read(opaque, true);
 }
 #endif /* CONFIG_VNC_WS */

@@ -3283,7 +3284,7 @@  void vnc_display_open(DisplayState *ds, const char *display, Error **errp)
         if (csock < 0) {
             goto fail;
         }
-        vnc_connect(vs, csock, 0, 0);
+        vnc_connect(vs, csock, false, false);
     } else {
         /* listen for connects */
         char *dpy;
@@ -3341,9 +3342,9 @@  fail:
 #endif /* CONFIG_VNC_WS */
 }

-void vnc_display_add_client(DisplayState *ds, int csock, int skipauth)
+void vnc_display_add_client(DisplayState *ds, int csock, bool skipauth)
 {
     VncDisplay *vs = vnc_display;

-    vnc_connect(vs, csock, skipauth, 0);
+    vnc_connect(vs, csock, skipauth, false);
 }