diff mbox

[v3,for,2.0] update names in option tables to match with actual command-line spelling

Message ID 20140327044345.GB7531@amosk.info
State New
Headers show

Commit Message

Amos Kong March 27, 2014, 4:43 a.m. UTC
On Thu, Mar 27, 2014 at 10:16:44AM +0800, Amos Kong wrote:
> On Wed, Mar 26, 2014 at 05:12:08PM +0100, Markus Armbruster wrote:
> > Eric Blake <eblake@redhat.com> writes:

...
> > > Reviewed-by: Eric Blake <eblake@redhat.com>
> > 
> > I'm not thrilled about the ABI break, but avoiding it would probably
> > take too much code for too little gain.
 
Hi Markus, Eric

> We can add an 'alias_index' field to QemuOptsList, and init it to -1
> in qemu_add_opts().
> 
> And we only re-set 'alias_index' to 'popt->index' in vl.c(option parsing part)
> then we can find opts by qemu_options[i].index.
> 
> We also need to give a warning () if it's group name of added QemuOptsList
> doesn't match with defined option name.
> 
> If someone add a new QemuOpts and the group name doesn't match, he/she will
> get a warning, and call a help function to re-set 'alias_index'.
>  
> I can send a RFC patch for this.

* Option 1
Attached two RFC patches, it added a new field ('alias_index') to
QemuOptsList, and record QEMU_OPTION enum-index to it when group
name of option table doesn't match option name.

And try to find list by index before find list by option name in
qmp_query_command_line_options().

This can avoid the ABI breaking, it also introduced some trouble.
We also need to check if alias_index of unmatched option is set
to a positive number, and report error (option name doesn't match, and
alias_index isn't set) in error state.

* Option 2
OR pass enum-index to qemu_add_opts(), and set enum-index for all the options.
   -void qemu_add_opts(QemuOptsList *list)
   +void qemu_add_opts(QemuOptsList *list, int index)

* Option 3 break ABI

Let's make a decision.

> > How can we prevent future violations of the convention "QemuOptsList
> > member name matches the name of the (primary) option using it for its
> > argument"?  Right now, all we have is /* option name */ tacked to the
> > member.  Which is at best a reminder for those who already know.
> 
> It's absolutely necessary!
>  
> > I'd ask for a test catching violations if I could think of an easy way
> > to code it.
> 
> Currently I prefer this option, so I will send a V3 with strict checking.
diff mbox

Patch

diff --git a/hw/acpi/core.c b/hw/acpi/core.c
index 79414b4..1f459fc 100644
--- a/hw/acpi/core.c
+++ b/hw/acpi/core.c
@@ -27,6 +27,7 @@ 
 #include "qapi/opts-visitor.h"
 #include "qapi/dealloc-visitor.h"
 #include "qapi-visit.h"
+#include "qemu-options.h"
 
 struct acpi_table_header {
     uint16_t _length;         /* our length, not actual part of the hdr */
@@ -64,6 +65,7 @@  static QemuOptsList qemu_acpi_opts = {
 static void acpi_register_config(void)
 {
     qemu_add_opts(&qemu_acpi_opts);
+    qemu_set_opt_index(qemu_acpi_opts.name, QEMU_OPTION_acpitable, NULL);
 }
 
 machine_init(acpi_register_config);
diff --git a/include/qapi/qmp/qerror.h b/include/qapi/qmp/qerror.h
index da75abf..cfbd29d 100644
--- a/include/qapi/qmp/qerror.h
+++ b/include/qapi/qmp/qerror.h
@@ -134,6 +134,9 @@  void qerror_report_err(Error *err);
 #define QERR_INVALID_OPTION_GROUP \
     ERROR_CLASS_GENERIC_ERROR, "There is no option group '%s'"
 
+#define QERR_INVALID_OPTION_INDEX \
+    ERROR_CLASS_GENERIC_ERROR, "There is no option index '%d'"
+
 #define QERR_INVALID_PARAMETER \
     ERROR_CLASS_GENERIC_ERROR, "Invalid parameter '%s'"
 
diff --git a/include/qemu/config-file.h b/include/qemu/config-file.h
index dbd97c4..1884313 100644
--- a/include/qemu/config-file.h
+++ b/include/qemu/config-file.h
@@ -8,6 +8,7 @@ 
 
 QemuOptsList *qemu_find_opts(const char *group);
 QemuOptsList *qemu_find_opts_err(const char *group, Error **errp);
+void qemu_set_opt_index(const char *group, int index, Error **errp);
 void qemu_add_opts(QemuOptsList *list);
 void qemu_add_drive_opts(QemuOptsList *list);
 int qemu_set_option(const char *str);
diff --git a/include/qemu/option.h b/include/qemu/option.h
index 8c0ac34..0d63ec9 100644
--- a/include/qemu/option.h
+++ b/include/qemu/option.h
@@ -103,6 +103,7 @@  typedef struct QemuOptDesc {
 
 struct QemuOptsList {
     const char *name;
+    int alias_index;
     const char *implied_opt_name;
     bool merge_lists;  /* Merge multiple uses of option into a single list? */
     QTAILQ_HEAD(, QemuOpts) head;
diff --git a/util/qemu-config.c b/util/qemu-config.c
index 508adbc..877d0e9 100644
--- a/util/qemu-config.c
+++ b/util/qemu-config.c
@@ -184,6 +184,21 @@  void qemu_add_drive_opts(QemuOptsList *list)
     abort();
 }
 
+void qemu_set_opt_index(const char *group, int index, Error **errp)
+{
+    int i;
+
+    for (i = 0; vm_config_groups[i] != NULL; i++) {
+        if (strcmp(vm_config_groups[i]->name, group) == 0) {
+            vm_config_groups[i]->alias_index = index;
+            break;
+        }
+    }
+    if (vm_config_groups[i] == NULL) {
+        error_set(errp, QERR_INVALID_OPTION_GROUP, group);
+    }
+}
+
 void qemu_add_opts(QemuOptsList *list)
 {
     int entries, i;
@@ -193,6 +208,7 @@  void qemu_add_opts(QemuOptsList *list)
     for (i = 0; i < entries; i++) {
         if (vm_config_groups[i] == NULL) {
             vm_config_groups[i] = list;
+            list->alias_index = -1;
             return;
         }
     }
diff --git a/vl.c b/vl.c
index 2355227..6457d6d 100644
--- a/vl.c
+++ b/vl.c
@@ -2988,7 +2988,9 @@  int main(int argc, char **argv, char **envp)
     qemu_add_opts(&qemu_option_rom_opts);
     qemu_add_opts(&qemu_machine_opts);
     qemu_add_opts(&qemu_smp_opts);
+    qemu_set_opt_index(qemu_smp_opts.name, QEMU_OPTION_smp, NULL);
     qemu_add_opts(&qemu_boot_opts);
+    qemu_set_opt_index(qemu_boot_opts.name, QEMU_OPTION_boot, NULL);
     qemu_add_opts(&qemu_sandbox_opts);
     qemu_add_opts(&qemu_add_fd_opts);
     qemu_add_opts(&qemu_object_opts);