mbox series

[v2,0/4] hw: vfio: some trivial fix

Message ID 20190521151543.92274-1-liq3ea@163.com
Headers show
Series hw: vfio: some trivial fix | expand

Message

Li Qiang May 21, 2019, 3:15 p.m. UTC
These patchset fix some trivial issues,
The first patch makes the code more QOMConventions.
The second decouples VMStateDescription's name with
QOM TypeInfo's name.
The third fixes a typo.
The fourth reduce duplicated code.

Change since v1:
Add more commit message.

Li Qiang (4):
  vfio: pci: make "vfio-pci-nohotplug" as MACRO
  hw: vfio: drop TYPE_FOO MACRO in VMStateDescription
  vfio: platform: fix a typo
  pci: msix: move 'MSIX_CAP_LENGTH' to header file

 hw/pci/msix.c           | 2 --
 hw/vfio/amd-xgbe.c      | 2 +-
 hw/vfio/ap.c            | 2 +-
 hw/vfio/calxeda-xgmac.c | 2 +-
 hw/vfio/ccw.c           | 2 +-
 hw/vfio/pci.c           | 8 ++++----
 hw/vfio/platform.c      | 6 +++---
 include/hw/pci/msix.h   | 2 ++
 8 files changed, 13 insertions(+), 13 deletions(-)

Comments

Alex Williamson May 21, 2019, 3:37 p.m. UTC | #1
On Tue, 21 May 2019 08:15:39 -0700
Li Qiang <liq3ea@163.com> wrote:

> These patchset fix some trivial issues,
> The first patch makes the code more QOMConventions.
> The second decouples VMStateDescription's name with
> QOM TypeInfo's name.
> The third fixes a typo.
> The fourth reduce duplicated code.
> 
> Change since v1:
> Add more commit message.

Thank you for making this series 'trivial' by providing explanation and
justification for each change.  If trivial wants to include this, for
series:

Acked-by: Alex Williamson <alex.williamson@redhat.com>
Philippe Mathieu-Daudé May 21, 2019, 3:39 p.m. UTC | #2
On 5/21/19 5:15 PM, Li Qiang wrote:
> These patchset fix some trivial issues,
> The first patch makes the code more QOMConventions.
> The second decouples VMStateDescription's name with
> QOM TypeInfo's name.
> The third fixes a typo.
> The fourth reduce duplicated code.
> 
> Change since v1:
> Add more commit message.
> 
> Li Qiang (4):
>   vfio: pci: make "vfio-pci-nohotplug" as MACRO
>   hw: vfio: drop TYPE_FOO MACRO in VMStateDescription
>   vfio: platform: fix a typo
>   pci: msix: move 'MSIX_CAP_LENGTH' to header file

Series:
Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Eric Auger May 21, 2019, 3:50 p.m. UTC | #3
Hi,
On 5/21/19 5:15 PM, Li Qiang wrote:
> These patchset fix some trivial issues,
> The first patch makes the code more QOMConventions.
> The second decouples VMStateDescription's name with
> QOM TypeInfo's name.
> The third fixes a typo.
> The fourth reduce duplicated code.
> 
> Change since v1:
> Add more commit message.

Reviewed-by: Eric Auger <eric.auger@redhat.com>

Thanks

Eric
> 
> Li Qiang (4):
>   vfio: pci: make "vfio-pci-nohotplug" as MACRO
>   hw: vfio: drop TYPE_FOO MACRO in VMStateDescription
>   vfio: platform: fix a typo
>   pci: msix: move 'MSIX_CAP_LENGTH' to header file
> 
>  hw/pci/msix.c           | 2 --
>  hw/vfio/amd-xgbe.c      | 2 +-
>  hw/vfio/ap.c            | 2 +-
>  hw/vfio/calxeda-xgmac.c | 2 +-
>  hw/vfio/ccw.c           | 2 +-
>  hw/vfio/pci.c           | 8 ++++----
>  hw/vfio/platform.c      | 6 +++---
>  include/hw/pci/msix.h   | 2 ++
>  8 files changed, 13 insertions(+), 13 deletions(-)
>