diff mbox series

CMake: bump the minimum required CMake version to 3.5

Message ID mailman.69808.1705045892.1880391.openwrt-devel@lists.openwrt.org
State Accepted
Delegated to: Petr Štetiar
Headers show
Series CMake: bump the minimum required CMake version to 3.5 | expand

Commit Message

Thomas Richard via openwrt-devel Jan. 12, 2024, 7:50 a.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
From: Yegor Yefremov <yegorslists@googlemail.com>

Older CMake versions are marked as deprecated and generate
the related warning:

Compatibility with CMake < 3.5 will be removed from a future
version of CMake.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
 CMakeLists.txt | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e86bd4..a3eaf65 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,11 +1,9 @@ 
-cmake_minimum_required(VERSION 2.6)
+cmake_minimum_required(VERSION 3.5)
 
 PROJECT(netifd C)
 
-IF(NOT ${CMAKE_VERSION} LESS 3.0)
-  include(CheckCCompilerFlag)
-  check_c_compiler_flag(-Wimplicit-fallthrough HAS_IMPLICIT_FALLTHROUGH)
-ENDIF()
+include(CheckCCompilerFlag)
+check_c_compiler_flag(-Wimplicit-fallthrough HAS_IMPLICIT_FALLTHROUGH)
 
 ADD_DEFINITIONS(-Wall -Werror)
 IF(CMAKE_C_COMPILER_VERSION VERSION_GREATER 6)