diff mbox series

Extend checks on build prerequisites for building OpenWRT core

Message ID mailman.2752.1618873725.1513.openwrt-devel@lists.openwrt.org
State Accepted
Headers show
Series Extend checks on build prerequisites for building OpenWRT core | expand

Commit Message

Bas Mevissen April 19, 2021, 11:08 p.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
OpenWRT requires a number of Perl modules to be installed. It wasn't checking on all of them.
This patch adds checks for Perl FindBin, File::Copy, File::Compare and Thread::Queue modules.

Failing to install these, will have the build break at some point. By adding these to the
prereq-build.mk script, they are checked on forehand.

Tested on a Fedora 33 and 34 (beta) that was freshly installed. Fedora appears to
break up Perl modules into small packages that need to be installed for the build to succeed.

Signed-off-by: Bas Mevissen <abuse@basmevissen.nl>
---
 include/prereq-build.mk | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

Comments

Bas Mevissen April 28, 2021, 10:13 p.m. UTC | #1
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
> 
> 
> OpenWRT requires a number of Perl modules to be installed. It wasn't checking on all of them.
> This patch adds checks for Perl FindBin, File::Copy, File::Compare and Thread::Queue modules.
> 
> Failing to install these, will have the build break at some point. By adding these to the
> prereq-build.mk script, they are checked on forehand.
> 
> Tested on a Fedora 33 and 34 (beta) that was freshly installed. Fedora appears to
> break up Perl modules into small packages that need to be installed for the build to succeed.
> 
> Signed-off-by: Bas Mevissen <abuse@basmevissen.nl>
> ---
>  include/prereq-build.mk | 13 ++++++++++++-
>  1 file changed, 12 insertions(+), 1 deletion(-)
> 
> diff --git a/include/prereq-build.mk b/include/prereq-build.mk
> index 86c22f7c95..cb3dcc51e3 100644
> --- a/include/prereq-build.mk
> +++ b/include/prereq-build.mk
> @@ -65,11 +65,22 @@ $(eval $(call TestHostCommand,perl-data-dumper, \
>  	Please install the Perl Data::Dumper module, \
>  	perl -MData::Dumper -e 1))
>  
> +$(eval $(call TestHostCommand,perl-findbin, \
> +	Please install the Perl FindBin module, \
> +	perl -MFindBin -e 1))
> +
> +$(eval $(call TestHostCommand,perl-file-copy, \
> +	Please install the Perl File::Copy module, \
> +	perl -MFile::Copy -e 1))
> +
> +$(eval $(call TestHostCommand,perl-file-compare, \
> +	Please install the Perl File::Compare module, \
> +	perl -MFile::Compare -e 1))
> +
>  $(eval $(call TestHostCommand,perl-thread-queue, \
>  	Please install the Perl Thread::Queue module, \
>  	perl -MThread::Queue -e 1))
>  
> -
>  $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
>  	gtar --version 2>&1 | grep GNU, \
>  	gnutar --version 2>&1 | grep GNU, \
> -- 
> 2.31.1
> 
> 


Friendly ping to consider this patch for 21.02.

Thanks,
Baptiste Jonglez May 8, 2021, 10:53 a.m. UTC | #2
Hi,

On 20-04-21, Bas Mevissen via openwrt-devel wrote:
> Date: Tue, 20 Apr 2021 01:08:19 +0200
> From: Bas Mevissen <abuse@basmevissen.nl>
> To: openwrt-devel@lists.openwrt.org
> Cc: Bas Mevissen <abuse@basmevissen.nl>
> Subject: [PATCH] Extend checks on build prerequisites for building OpenWRT core

Merged and backported to 21.02 and 19.07, thanks.

Baptiste
diff mbox series

Patch

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 86c22f7c95..cb3dcc51e3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -65,11 +65,22 @@  $(eval $(call TestHostCommand,perl-data-dumper, \
 	Please install the Perl Data::Dumper module, \
 	perl -MData::Dumper -e 1))
 
+$(eval $(call TestHostCommand,perl-findbin, \
+	Please install the Perl FindBin module, \
+	perl -MFindBin -e 1))
+
+$(eval $(call TestHostCommand,perl-file-copy, \
+	Please install the Perl File::Copy module, \
+	perl -MFile::Copy -e 1))
+
+$(eval $(call TestHostCommand,perl-file-compare, \
+	Please install the Perl File::Compare module, \
+	perl -MFile::Compare -e 1))
+
 $(eval $(call TestHostCommand,perl-thread-queue, \
 	Please install the Perl Thread::Queue module, \
 	perl -MThread::Queue -e 1))
 
-
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
 	gtar --version 2>&1 | grep GNU, \
 	gnutar --version 2>&1 | grep GNU, \