diff mbox series

[v4,4/6] at91: add support for sama5d27-wlsom1-ek board

Message ID mailman.22618.1632130086.1072.openwrt-devel@lists.openwrt.org
State Superseded
Headers show
Series at91: add support for sama5d2 icp, sama5d27 wlsom1 ek and sam9x60ek | expand

Commit Message

Claudiu Beznea Sept. 20, 2021, 9:27 a.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Add support for SAMA5D27 WLSOM1-EK board.

Hardware:
- SIP: SAMA5D27C-LD2G-CU including SAMA5D27 MPU and 2Gbit LPDDR2-SDRAM
- MMC: one standard SD card interface
- Flash: 64 Mb serial quad I/O flash memory (SST26VF064BEUIT-104I/MF)
	 with embedded EUI-48 and EUI-64 MAC addresses
- USB: one USB device, one USB host one HSIC interface
- Ethernet: 1x10/100Mbps port
- WiFi/BT: IEEE 802.11 b/g/n Wi-Fi plus Bluetooth (Wi-Fi/BT) module
	   (ATWILC3000-MR110UA)
- Crypto: one ATECC608B-TNGTLS secure element
- Video: one LCD RGB 18-bit interface, one ISC 12-bit camera interface
- Debug port: one JTAG interface, one UART interface, one WILC UART
              interface
- Leds: one RGB LED
- Buttons: start, reset, wakeup, user buttons
- Expansion: one tamper connector, one mikrobus interface, 2 XPRO PTC
             connector
- Power managament: PMIC (MCP16502)

Flashing:
- follow procedure at [1]

[1] https://www.linux4sam.org/bin/view/Linux4SAM/Sama5d27WLSom1EKMainPage#Create_a_SD_card_with_the_demo

Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
---
 package/boot/at91bootstrap/Makefile | 14 ++++++++++++++
 package/boot/uboot-at91/Makefile    | 14 ++++++++++++++
 target/linux/at91/image/sama5.mk    | 11 +++++++++++
 3 files changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 56e14c57703c..8711acd286bd 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -118,6 +118,18 @@  define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
   BUILD_DEVICES:=microchip_sama5d27-som1-ek
 endef
 
+define AT91Bootstrap/sama5d27_wlsom1_eksd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 WLSOM1 Ek (SDcard0)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
+define AT91Bootstrap/sama5d27_wlsom1_ekdf_qspi_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 WLSOM1 Ek (QSPI Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
 define AT91Bootstrap/sama5d2_ptc_eknf_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (Nand Flash)
   BUILD_SUBTARGET:=sama5
@@ -145,6 +157,8 @@  AT91BOOTSTRAP_TARGETS := \
 	sama5d4_xplainedsd_uboot_secure \
 	sama5d27_som1_eksd1_uboot \
 	sama5d27_som1_ekqspi_uboot \
+	sama5d27_wlsom1_eksd_uboot \
+	sama5d27_wlsom1_ekdf_qspi_uboot \
 	sama5d2_ptc_eknf_uboot \
 	sama5d2_ptc_eksd_uboot
 
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 193f26dae471..5aade7de9cf9 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -107,6 +107,18 @@  define U-Boot/sama5d27_som1_ek_qspiflash
   BUILD_DEVICES:=microchip_sama5d27-som1-ek
 endef
 
+define U-Boot/sama5d27_wlsom1_ek_mmc
+  NAME:=SAMA5D27 WLSOM1 Ek (SDCard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
+define U-Boot/sama5d27_wlsom1_ek_qspiflash
+  NAME:=SAMA5D27 WLSOM1 Ek (QSPI Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
 define U-Boot/sama5d2_ptc_ek_nandflash
   NAME:=SAMA5D2 PTC Ek (Nand Flash)
   BUILD_SUBTARGET:=sama5
@@ -133,6 +145,8 @@  UBOOT_TARGETS := \
 	sama5d4_xplained_nandflash\
 	sama5d27_som1_ek_mmc1 \
 	sama5d27_som1_ek_qspiflash \
+	sama5d27_wlsom1_ek_mmc \
+	sama5d27_wlsom1_ek_qspiflash \
 	sama5d2_ptc_ek_nandflash \
 	sama5d2_ptc_ek_mmc
 
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index ae3494332139..9078db525f97 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -87,6 +87,17 @@  define Device/microchip_sama5d27-som1-ek
 endef
 TARGET_DEVICES += microchip_sama5d27-som1-ek
 
+define Device/microchip_sama5d27-wlsom1-ek
+  $(Device/evaluation-dtb)
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAMA5D27 WSOM1 Ek
+  DEVICE_DTS := at91-sama5d27_wlsom1_ek
+  SUPPORTED_DEVICES := microchip,sama5d27-wlsom1-ek
+  KERNEL_SIZE := 6144k
+  $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += microchip_sama5d27-wlsom1-ek
+
 define Device/microchip_sama5d2-ptc-ek
   $(Device/evaluation-dtb)
   DEVICE_VENDOR := Microchip